12v power to TV not working on 2006 Sprinter

tomaud

New member
The 12v connection for the TV is not getting power. The van's manual says that the power source is directly from the house battery. I have not been able to trace the path. The fuse is shared with the DVD player and is OK. The DVD is working. Any suggestions where I can look to find the problem.
 

marklg

Well-known member
The 12v connection for the TV is not getting power. The van's manual says that the power source is directly from the house battery. I have not been able to trace the path. The fuse is shared with the DVD player and is OK. The DVD is working. Any suggestions where I can look to find the problem.
I have a 2007 GW and the TV is just in front of the bed area. Is yours the same?

Look at the pictures here:


Does yours look the same? I installed my own bluray, so you would not have that wiring. The TV power goes up into the cabinet area. You can see some of it by unscrewing the plate for the bed rocker switch and the light dimmer if you have them. I have not been able to fully trace the wiring.

I do know that the fusebox tends to have loose connections in the back. Also, just because the fuses are marked TV and DVD does not mean they actually wired it that way. I suggest you check all the fuses with a meter to see if any are blown. Maybe get behind the fusebox and wiggle wires.

I also know they used inadequate sized wiring. A failing fresh water pump can drag down the voltage but not blow the fuse. It was shared with the heat and hot water controls.

Regards,

Mark
 

Top Bottom