can we search our own content?

white whale

Member
doesn't seem to be allowed. Would be useful.
 

Cheyenne

UK 2004 T1N 313CDi
Several ways...

Use the Search button above then add your username.

Click on your Username above then 'Your content'

I'm sure there are other ways as well :) :) :)
 

white whale

Member
Was thinking more searching WITHIN my content. A general search query will give options for EVERYWHERE, THIS THREAD, THIS FORUM.. but if you are in your profile with MY CONTENT those options go away. If I posted something before on X , I can only search for X along with ALL the others posts / posters on X.

Maybe my memory is not as good as others, i see others answering a question with links to their previous posts. Some have thousands of posts - they would have to scroll through those manually then?
 

autostaretx

Erratic Member
Up at the top are (effectively) three or four lines of choices.
On the 2nd line, we've got "New Posts", "Find Threads", Watched" and "Search Forums" (and "Mark Forums Read"),
If you click "Search Forums", you get (effectively) the old "Advanced Search"
Put your keywords in the first line, and your username in the "posted by" field.

Seems to work for me (during a quick test).

--dick
 

Cheyenne

UK 2004 T1N 313CDi
WW,

I have just found a feature under 'Advanced Search' (accessed through the search button above) where you can select 'Search Threads' and then select your username and which areas of the forum you want to search.

Search.png
 

sikwan

06 T1N Can
In vb3 while browsing a thread, there is a pull down search box (search this thread). I don't think it exists in xenforo.
 

autostaretx

Erratic Member
In vb3 while browsing a thread, there is a pull down search box (search this thread). I don't think it exists in xenforo.
Top floating tab bar....

SearchBar.png

--dick
 

white whale

Member
Two solid options - Star and Chey. Just checked on last post i did , using the SEARCH FORUMS , you have to " the words" separately or you got a NO RESULT. My subject had plastic and bumper in the title, but unless I did the keywords as "plastic" "bumper" with the " " no results came back.
 

autostaretx

Erratic Member
I'm confused: do you mean you had to quote the individual words:
Code:
"plastic"  "bumper"
(with an intervening space)
or that the two words simply had to be separated
Code:
plastic bumper
(with an intervening space)

or what?
And, for that matter, what were you trying that *didn't* work?

--dick
 

white whale

Member
I typed ----- plastic bumper ----- = no results, "plastic" "bumper" = correct results with all of my posts that those words in the subject or body.
I have seen search parameters where you do have to include + signs or quotes.
 

autostaretx

Erratic Member
I typed ----- plastic bumper ----- = no results, "plastic" "bumper" = correct results with all of my posts that those words in the subject or body.
Very strange ... (i.e. our mileage seems to differ)

If i use the "simple search" and put in "march lion" (without quotes) and tick "titles only"
... it "does the right/expected thing". Coughs up one thread with three words highlighted (lion appears twice).

BUT ... still in simple search, if i add my name as "By:", i get zero hits (i didn't initiate the thread)
If i surround each search word with quotes, i get the same thing: zilch.

If i do NOT use quotes and do NOT select "titles only" (but leave the "By: me"), i get two hits (one each in two threads).
... the thread that didn't have the two words in the title had the two words in the body of the text.
...the 2nd thread had the two words in the title, but (i think) only one word in the body of the text.
I have seen search parameters where you do have to include + signs or quotes.
Sometimes confusing things is that there are two search systems being used by the Forum (one (mysql) may be an idle back-up).
What they accept as mark-up (the pluses, etc) and their behavior may (does) differ.

Since the Search function can be (is) implemented independent of the underlying Forum software, the Forum's Help doesn't offer any help regarding syntax.

I'll kick it around some more... (such as: apostrophes (or either accent character) instead of quotes.)

BobbyTables.png
(source: https://xkcd.com/327/ )

--dick
p.s. for those who don't get it: https://www.explainxkcd.com/wiki/index.php/327:_Exploits_of_a_Mom
((although i can't guarantee that that will totally clear it up))
 

autostaretx

Erratic Member
New amusement ... if i quote "march" "lion", i get three hits ... the third one being *this* thread.
If i don't quote them, i don't see this thread.
(perhaps the engine sees the quotes i'm using in this thread as part of the string??)

--dick
 

Top Bottom