Traffic Sign Assist always displays maximum 55 mph in CA

Michlb

Active member
On CA highways, the Traffic Sign Assist always displays 55 mph even though the car speed limit is higher. As far as I understand it, 144 Sprinters can follow the speed limit for cars. Is it possible to configure the Traffic Sign Assist to display the speed limit advised for cars instead of the 55 mph for trucks?
 

Michlb

Active member
you may need a software update. My new 2019 made in Nov does fine.


Cool - thanks! Yes, mine is build in Düsseldorf in June.

Off topic: You have a new 4x4, right? How you like it? Any downside in everyday use you encountered so far? Mine is RWD. Very smooth driving so far but obvious drawbacks in snow.


Sent from my iPhone using Tapatalk
 

GLJones

Active member
My 2019 was working fine until about 3 weeks ago. Now it is doing the same, displaying 55 if the limit is 60, 65 or 70. I think they pushed a software update and it has a bug. No idea if it affects all MBUX or just a few.

Please call Mercedes PRO support and report it. If they tell you they haven't had any reports, tell them I reported it 2 weeks ago. I am in Florida.
 

GLJones

Active member
Also, despite this being an obvious software bug, they will tell you to take it to the dealer...who will just have to call them. It's really stupid.
 

Michlb

Active member
I would probably call it a overzealous interpretation of the speed laws. It’s probably not a true bug. In CA, the truck speed limit is 55 mph. But is a Sprinter a truck? I doubt it. I drove by California Highway Patrol many times with speeds over 55 mph, and they didn’t mind.

Some engineer probably thought that the Sprinter speed limit in CA should be 55 mph. I bet it varies state by state.
 

GLJones

Active member
According to Mercedes PRO support, it is supposed to display the actual speed limit. They could find no setting or reason it would max out at 55. In fact, my MBUX worked fine displaying 70 on the freeway just 3 weeks ago...then something changed. The only thing I can think of would be a software update (over the air). Support considered it a problem but their recommendation to take it to the dealer is ridiculous. The dealer has one option - reflash the system. If this is a bug in the software, that won't fix it and they will have to contact the software team to address it. Once again, auto manufacturers treat everything as a mechanical/dealer issue. These cars are as much computer as mechanical now and the dealer cannot address software bugs.
 

autostaretx

Erratic Member
Support considered it a problem but their recommendation to take it to the dealer is ridiculous. The dealer has one option - reflash the system. If this is a bug in the software, that won't fix it and they will have to contact the software team to address it. Once again, auto manufacturers treat everything as a mechanical/dealer issue. These cars are as much computer as mechanical now and the dealer cannot address software bugs.
Unfortunately, sometimes ya' just gotta play the game ... take it to a dealer so *they* can fail at it, at which point they push against corporate through their complaint chain.

Some vendors don't react (rapidly) to customer complaints, but DO hop to it when a dealer has a vehicle stuck on (i.e occupying) a lift.

--dick
 

gtinla

New member
On CA highways, the Traffic Sign Assist always displays 55 mph even though the car speed limit is higher. As far as I understand it, 144 Sprinters can follow the speed limit for cars. Is it possible to configure the Traffic Sign Assist to display the speed limit advised for cars instead of the 55 mph for trucks?
I have a 2021 Tiffin Wayfarer. The traffic sign assist recognizes all signs 55 and below. Last month it would not display anything above 55 mph.
 

brianzoh

Member
We hit 23 states this year in our van and there were times it would read the signs fine, others not. Cross state lines and the sign changes a little and BAM it starts working again. Especially irritating as it almost always gets speed limit signs in construction zones, so missing the normal signs is all the more glaring an issue. No real consistency to the issue and it is on the list for my Dec 21 service appt.
 

Shawn182

Active member
I would probably call it a overzealous interpretation of the speed laws. It’s probably not a true bug. In CA, the truck speed limit is 55 mph. But is a Sprinter a truck?
No. The 55 MPH freeway speed limit in CA only applies to trucks with three or more axles or any vehicle while towing.
 

Kajtek1

2015 long/tall limo RV 2.1l
No. The 55 MPH freeway speed limit in CA only applies to trucks with three or more axles or any vehicle while towing.
Now I wonder if the glitch might be in towing module?. When computer thinks you have a trailer - it will display 55 mph.
 

autostaretx

Erratic Member
So it would appear that the ESP update is what really fixed it?

--dick
 

GLJones

Active member
It's a software issue. After they updated the MBUX system it started doing this. They ended up having to replace the instrument cluster to fix ours...apparently there is a new hardware revision to the cluster that is required for this to work. Hopefully, yours is just the software, not the hardware.
 

Pharkas

Member
We picked up our new van in November. It has never read.highway signs above 55 from the factory. Does this need to go back to the dealer then to resolve?
 

GLJones

Active member
We picked up our new van in November. It has never read.highway signs above 55 from the factory. Does this need to go back to the dealer then to resolve?
Yes...this is a bug they need to fix. Mine worked when we got the van. Then they updated the MBUX and it wouldn't go above 55. They replaced the Instrument Cluster with a new revision of the hardware and it works again. It works VERY well too. It sees signs and updates as you pass them.
 

Sksnumber1

New member
Yes...this is a bug they need to fix. Mine worked when we got the van. Then they updated the MBUX and it wouldn't go above 55. They replaced the Instrument Cluster with a new revision of the hardware and it works again. It works VERY well too. It sees signs and updates as you pass them.
So, we basically bought a 2020 Sprinter today (agreed to terms over phone/email and will fly to KY on Monday with a check to buy it) - being brand new (7 miles on it) will we need to replace the instrument cluster when we pick it up? Assuming this will be covered by warranty? A little disappointed if we'll pick it up, drive it home to Colorado only to have to put it right in for service to fix something that should work on a brand-new unit?
 

TN Jim

New member
Mine started working correctly today. Speed limit sign 70mph, dash showed 70. Hope this continues to work.
 

Top Bottom