New instrument cluster- now problems...

Preston

04 Sprinter, 118" Cargo
I had the local Dodge dealer (auburn, ca) complete the lovely recall and like some of you, they needed to replace the instrument cluster. Now, the seat belt light and accompanying beeper is on ALWAYS. :bash:

Did this happen to anyone else? Was there an easy fix???

Any suggestions would be great.

Preston
2004 118" T1N
 

autostaretx

Erratic Member
"ALWAYS" as in it never shuts up?

Obviously it's telling you to return to the dealer and hold their public address microphone next to the instrument cluster.

(i wonder if they bent a pin?)

--dick
 

autostaretx

Erratic Member
Mine has always beeped (for 6 seconds, then shuts up) since it was new in 2005.

Hmmm... My Autel can report the status of the latch ... my one test was with it UNbuckled and it said "Open"
I'll have to see if it notices when it's closed.

--dick
 

Preston

04 Sprinter, 118" Cargo
"ALWAYS" as in it never shuts up?

Obviously it's telling you to return to the dealer and hold their public address microphone next to the instrument cluster.

(i wonder if they bent a pin?)

--dick
Good thinking Dick. I'll do the public address mic if I can't figure it out first. Sounds like other have had the problem- maybe there is a fix so I don't have to take it back to them! Cheers.
 

Preston

04 Sprinter, 118" Cargo
Yes, the new instrument cluster has the beeping and flashing seatbelt light for a 6 second interval even if you have already buckled the seatbelt. Very annoying. Posted a thread on it.

https://sprinter-source.com/forum/showthread.php?t=76669&highlight=Seatbelt

If you find there is a way to reprogram, that'd be great.
Thanks for forwarding the link. Very useful, though I think my situation might be a little different because my SRS light has been on for a while. Something tells me the new cluster is beeping nonstop because of that?

Both belts seem to work fine and with the old cluster, the thing never beeped- just constant SRS light illuminated.

I think the SRS light came on because water over flowed the shallow well in the passengers side dashboard. I thought maybe the airbag was tweaked. Do you know, is that a reason why the light would be on and possibly why the seatbelt light is beeping like crazy?
 

OldWest

T1N Westfalia
If beeping beyond the 6 to 7 seconds and have SRS light, then probably a different issue then just seatbelt buckling.

Problem is that new replacement instrument cluster may mean old diagnostic protocols may not be the same. Hopefully, someone has more info (I'm not a tech, just sharing personal experience and repeating what I saw on the Internet).
 

autostaretx

Erratic Member
I can't recall people complaining of a beeping if their SRS light came on due to a fault
(usually powering up the Sprinter without having reconnected an airbag)((amazingly common user-goof))

Once an "airbag connection dubious" condition has been sensed, the SRS light will not go out until it's cleared by a scanner.
The SRS "logic" is handled in the SRS controller, not the IC panel.

--dick
 

Preston

04 Sprinter, 118" Cargo
I have found a local T1N owner on this forum and he has the proper tool to reset the SRS light. I'll start with that to see if anything changes. Thanks for the input. I'll let you know if that helps! :cheers:
 

Top Bottom