Sprinter CDI cutting out

deefer

New member
Hope someone can help......
My van sometimes cuts out if I use an indicator or occasionally when selecting reverse gear (stickshift). All the lights on the instrument cluster flash like a christmas tree then cut altogether. The ignition shows no life for a few seconds then fires as normal. When indicating there is also occacionally a hissing sound like a gas leak or something sinister.There doesent appear to be anything shorting, at least not to the eye, I havent electrically tested anything as I wouldnt have a clue where to start! Is this a common fault? The van is great in every other respect and I would prefer to tackle the problem rather than sell the vehicle. The obvious answer is to take it to a main dealer, but I would appreciate some advice before I do that as I am sure they will simply replace lots of expensive parts and frankly I cant afford it.
 

Scott_Mc

Sprintering Since Aug/02
at first read sounds like a major electrical connection gone bad.

Check your battery connections.
 

Aqua Puttana

Poly - Thread Finder
Deefer,
First a hale and hearty welcome to the forum.

You don't say what year. It'd be nice if people would just put their vehicle info in their signature.

There have been reports of chafed wiring harnesses under and around the steering column. I believe they were mostly on NAFTA 2001 - 2003 model year, but I'm not certain. It may be something like a chafed wire going to ground. That is a guess.

Anyway, if you do a search using "wire", "harness", "chafe", "wiring" you may find something specific to your model year. I'd use both the forum search option and the Google box. They often give differing results. Hope this does some good. AP/vic

Edit: Oops. Stickshift. You're probably from the other side of the pond. I guess harnesses can chafe there too?
Hope someone can help......
My van sometimes cuts out if I use an indicator or occasionally when selecting reverse gear (stickshift). All the lights on the instrument cluster flash like a christmas tree then cut altogether. The ignition shows no life for a few seconds then fires as normal. When indicating there is also occacionally a hissing sound like a gas leak or something sinister.There doesent appear to be anything shorting, at least not to the eye, I havent electrically tested anything as I wouldnt have a clue where to start! Is this a common fault? The van is great in every other respect and I would prefer to tackle the problem rather than sell the vehicle. The obvious answer is to take it to a main dealer, but I would appreciate some advice before I do that as I am sure they will simply replace lots of expensive parts and frankly I cant afford it.
 
Last edited:

Ger-01

New member
Hope someone can help......
My van sometimes cuts out if I use an indicator or occasionally when selecting reverse gear (stickshift). All the lights on the instrument cluster flash like a christmas tree then cut altogether. The ignition shows no life for a few seconds then fires as normal. When indicating there is also occacionally a hissing sound like a gas leak or something sinister.There doesent appear to be anything shorting, at least not to the eye, I havent electrically tested anything as I wouldnt have a clue where to start! Is this a common fault? The van is great in every other respect and I would prefer to tackle the problem rather than sell the vehicle. The obvious answer is to take it to a main dealer, but I would appreciate some advice before I do that as I am sure they will simply replace lots of expensive parts and frankly I cant afford it.
Hi there, I have EXACTLY the same problem as above and cannot solve it, did you manage to get it fixed? If so could you please point me in the right direction, any help would be greatly appreciated, thanks in advance
 

mawsea

sprinter guru
A few years ago I had similar symptoms and it ended up being a defective fuse block. You might try tapping it next time this occurs? It is located in the steering column. That's just a guess....
 

Top Bottom