Radio problem resolved

katmat

New member
I have had a problem w/ the reception on my 05 3500 radio. Finally traced it out to the amp. in the antenna base. I had 12 volts up to the base but I was still having a problem w/ the am reception. I tried a piece of copper wire in the coax from the radio & the sound was much better. I tried a friends antenna on my base & it was not the antenna. I opened up the base & there is a small printed circuit board in it.

Does anyone have a base that they want to a sell?

Thanks,
Matt Murphy
 

katmat

New member
Dealer wanted $126.00 for a new base, found a used one for $20.00.
Problem is solved!!!!!
 

Sacto John

New member
Where did you fine the base for so cheep? My antenna was broken off by the first owner and I can not thread the new antenna into the base.
 

katmat

New member
Where did you fine the base for so cheep? My antenna was broken off by the first owner and I can not thread the new antenna into the base.
Found a local guy on Craigslist that was parting out a Sprinter.
 

glasseye

Well-known member
... I tried a piece of copper wire in the coax from the radio & the sound was much better.
Matt Murphy
Matt, my ('04 - Sound 10) AM reception is pretty bad, too. Can you explain what you did with the copper wire and the coax? I'd like to try that test on mine.

thanks!

Peter
 

katmat

New member
Matt, my ('04 - Sound 10) AM reception is pretty bad, too. Can you explain what you did with the copper wire and the coax? I'd like to try that test on mine.

thanks!

Peter

First I took the interior light down. Next I just put a small piece of wire (about 18 gauge) in the coax end that comes from the radio & then twisted that wire on to a piece of #12 copper wire, then stuck it out the pass. window.
 

Top Bottom