Conductor plug on transmission change questions

parallevar

2004 2500 118” High Roof
Hello,

I'm needing to swap out the conductor plate/ plug (on transmission) due to fluid contaminating the electrical connections (and even up to the TCM, which I've already cleaned).

I'm planning to do a write up later when I'm done, but I have a few questions if anyone can chime in.

Is it a bad idea to change that plug and not change the transmission fluid as well? How much fluid can I expect to leak out of the housing, even if I jack up the front end? Lastly, is it a bad idea to spray brake/ contact cleaner into the conductor plug? The male end was wet with fluid, and I'm sure the female end is too, but I don't want to spray that stuff up there if it can get inside the transmission and contaminate the trans fluid- I'm just not sure what it looks like inside the plug yet.

Thanks,
Cam
 

Nautamaran

2004 140” SHC T1N 2500
No need to change the fluid.

I’ve read elsewhere that you can expect a trickle of fluid while the socket is removed, not a gushing fountain, so expect to loose less than a litre/quart. Parking diagonally on a slope with the connector uphill will help reduce the flow.
Beware of the low installation torque for the retaining bolt! It’s only a few (6?) Newton meters... so just snug. Too tight risks cracking the plastic conductor plate.

The O-rings around the plastic socket (are supposed to...) isolate the connector and cable from the fluid in the transmission case, so clean away on the cable end, but of course dry it before reinstalling.

Good luck,

-dave
 

MillionMileSprinter

Formerly Type2Teach
I would add that it's really important not to rely on the retaining bolt to "suck" the socket into the hole. I use the end of a screwdriver to tap the socket in snugly and then tighten the bolt. It isn't hard to over tighten the bolt and do damage to the conductor plate!
Good job going to the other end of the wiring to make sure it wasn't all covered in ATF!
 

parallevar

2004 2500 118” High Roof
I would add that it's really important not to rely on the retaining bolt to "suck" the socket into the hole. I use the end of a screwdriver to tap the socket in snugly and then tighten the bolt. It isn't hard to over tighten the bolt and do damage to the conductor plate!
Good job going to the other end of the wiring to make sure it wasn't all covered in ATF!
Hey Joel,
It was actually, I'll post some photos in my write up, but as soon as I pulled the seat and looked at the TCM plug it was obvious that was part of the problem. I used brake cleaner and then contact cleaner until I was able to shake out clean fluid.... hopefully this will work!

Thanks,
Cam
 

Patrick of M

2005 T1N 2500 (NA spec)
If you don’t know the last time the trans fluid and filter was changed, now is a good time to do it. It’s expensive fluid, but the transmission is way more expensive.
 

Aqua Puttana

Poly - Thread Finder
If you don’t know the last time the trans fluid and filter was changed, now is a good time to do it. It’s expensive fluid, but the transmission is way more expensive.
:thumbup:

I believe that most members would agree that a 40 - 60,000 mile OCI is a proper maintenance interval. Reports are that with the van jacked up high enough there isn't much loss of fluid, but I haven't tried that method... yet.

vic
 

MillionMileSprinter

Formerly Type2Teach
:thumbup:
I believe that most members would agree that a 40 - 60,000 mile OCI is a proper maintenance interval. Reports are that with the van jacked up high enough there isn't much loss of fluid, but I haven't tried that method... yet.
vic
Totally. If more owners stuck to this schedule, there wouldn't be so much metalic "dust" buildup on the conductor plate and shift solenoids.
... but then I guess I wouldn't be getting so much work cleaning out transmissions...
Oh well. Do the maintenance on schedule! You and your sprinter (and your wallet) will be happier for it. :thumbup:
 

parallevar

2004 2500 118” High Roof
I have been thinking of changing the fluid, but it was serviced about 30k miles ago and the van only has 90k on it. I've looked at the fluid after using a dipstick and it looked pretty clear and quite red. Who knows, if the electrical contact cleaning doesn't solve my problem I may have to drop the pan to get to the solenoids anyway, so I've kinda been waiting to see if this new conductor plug will do the trick.
 

Aqua Puttana

Poly - Thread Finder
I have been thinking of changing the fluid, but it was serviced about 30k miles ago and the van only has 90k on it.
...
I wouldn't change the fluid/filter yet. I shoot for a 60k transmission service. I included the 40k number because some here like to be more conservative.

:cheers: vic
 

Patrick of M

2005 T1N 2500 (NA spec)
I have been thinking of changing the fluid, but it was serviced about 30k miles ago and the van only has 90k on it. I've looked at the fluid after using a dipstick and it looked pretty clear and quite red. Who knows, if the electrical contact cleaning doesn't solve my problem I may have to drop the pan to get to the solenoids anyway, so I've kinda been waiting to see if this new conductor plug will do the trick.
Didn’t realize it was changed that recently,.....was it the correct fluid? I only ask because I thought it was common practice to change the connector o ring when’s doing a fluid/filter change. If yours is leaking that was probably not done...ergo maybe other things were not done properly.
I know from a recent experience that none spec trans fluid does not perform as well as the good stuff.
 

parallevar

2004 2500 118” High Roof
Didn’t realize it was changed that recently,.....was it the correct fluid? I only ask because I thought it was common practice to change the connector o ring when’s doing a fluid/filter change. If yours is leaking that was probably not done...ergo maybe other things were not done properly.
I know from a recent experience that none spec trans fluid does not perform as well as the good stuff.
Well, that is a GOOD question! It's red, so I have that going for me. I'm planning to use the good stuff from europarts-sd when I finally service the transmission, but I have been hesitant to add more fluid for exactly this reason. Luckily the fluid level appears ok at this point, but this is part of the reason I'm planning to change the fluid/ filter/ etc in about 10k miles. (Plus having it done at 100k makes for easy math moving forward...)
 

Aqua Puttana

Poly - Thread Finder
... I'm planning to change the fluid/ filter/ etc in about 10k miles. ...
20k on a transmission isn't really a bunch of miles in the overall scheme of things.

My opinion is that only 20k total miles will be fine if it is a ATFIII based transmission fluid formulation. It may even be ok for 20k if it is ATF4+. There were a few Dodge dealers incorrectly putting that into the Sprinter transmissions. I have no data as to a safe interval, just opinions.

It would be best to know if it is an ATFIII formulation or not though.

Good to hear you're back up and running. :thumbup:

:cheers: vic
 

sethlp

2006 2500 140 HT 263k
Conductor plate question? I bought a kit with one in it before I found the DARF thread.
I'm about to do the darf mod. I've got a 06 with 264k and wondering if I should replace the plate or return it and not take the risk as it seams like a tricky replacement.

Thanks
 

sethlp

2006 2500 140 HT 263k
Thanks my tranny fluid was black. So much for pervious owner records.
Thinking I might go through it anyways. shifting wasn't that great on top of the rsn.
 
Last edited:

Patrick of M

2005 T1N 2500 (NA spec)
20k on a transmission isn't really a bunch of miles in the overall scheme of things.

My opinion is that only 20k total miles will be fine if it is a ATFIII based transmission fluid formulation. It may even be ok for 20k if it is ATF4+. There were a few Dodge dealers incorrectly putting that into the Sprinter transmissions. I have no data as to a safe interval, just opinions.

It would be best to know if it is an ATFIII formulation or not though.

Good to hear you're back up and running. :thumbup:

:cheers: vic
Fwiw my transmission was filled with ATF+4 by a Dodge dealer (when it still belonged to my FiL) and I ended up having problems in less than 5000 KMs (although 3 years elapsed) . When I cleaned out the bottom of the trans there was a fair amount of black silt, and when I took off the solenoid plate there was black silt throughout, not tons, but I had a solenoid this was sticking and putting the trans into LHM.
 

Top Bottom