3500 Brake Shoes (Parking Brake) Spring Squeal..

Hey There Sprinter-Forum,

Hope everyone has been well. Getting ready for winter. Scored a great deal on a 3500 Cab and Chassis. Working on the brake system. Removed wheel, hubs, calipers expecting to need to replace rotors and pads given the lack of braking (dead pedal) and intense squealing, grinding, and grabbing. I'm assuming the vehicle sat for a couples of years.

Upon removal of the braking system I discovered the rotors were barely worn and the pads were almost new in terms of thickness.

I'm getting ready to install the new dual piston calipers, but I need to figure out why the Spring (05139480AA/05139736AA) on the brake shoe is rubbing on the hub/bearing kit assembly.

I've uploaded a short video demonstrating the problem. Forgive the audible hell. I've found a few posts on the forum that describe the problem. However, all solutions tend to lean towards the shoe pads themselves. This is not the case as the rubbing exists even with the rotor removed. Ideas?

Is it possible that the springs are different between the 2500 and 3500 models and the incorrect spring currently installed?

You Tube Link https://youtu.be/djVNY69Ga0A





 
Last edited:

MillionMileSprinter

Formerly Type2Teach
IIRC, the spring package for the parking brakes is the same for the 2500 and 3500. However, there are some extra springs in the pack and it is possible to use the incorrect springs.
 
IIRC, the spring package for the parking brakes is the same for the 2500 and 3500. However, there are some extra springs in the pack and it is possible to use the incorrect springs.
Thanks for the quick reply.

Hmmm...well, the springs came installed on the vehicle. I didn't install the shoes. I'm tempted to order new parking brake shoes along with a replacement cable. Grrr...
 

Top Bottom