Espar (Eberspacher) D2 "No Signal" After running for hours


Active member
we solved our issue! Turns out a connector was missing the orange wedge thing that separates the pins, and after conversing with our dealer, we stole one from an unused connector and everything is now working fine!

It would be helpful to all if you would provide pics of this 'wedge'.


Active member
It would be helpful to all if you would provide pics of this 'wedge'.
Good point! But we are NOT taking the wedge out, as it's finally working right. lol. Here is the picture - it's simply that orange insert that keeps the pins separated - on the opposite side of what is pictured, it has a tiny grip area where you can hold it and push it into the connector, carefully being sure the pins are going in to their respective holes. If that insert is missing it's easy for pins to touch if slightly bent, apparently. My partner did all the discussion with the dealer but I was in on most of it. I hope this helps.



Active member
Glad you solved the issue....can you expand on what connector?
see above in the thread, as someone else asked so I attached a photo. These should be in several of the connectors, though not all, depending on the type they are. This connector was to our smart controller, gray with the orange 'wedge'.


Active member
In preparation for an upcoming trip, and because I haven't fired the heater for many months, I figured I'd fire it for a while at full power just to make sure its working and give it a nice hot burn off.

Press the start button on the Easy Start Timer, and 'NO SIGNAL' is displayed. Hmm. Weird. Never had an issue like that and heater has been installed and running for several years now. Of course, it immediately makes me think communication and then the wiring. But what has changed? Obviously the EST is still getting power to show 'NO SIGNAL'. So looking to the wiring between EST and heater unit. I was recently on some pretty rough roads that could have jostled a wire or connector loose I suppose.

I ended up pulling the seat and swivel, and finding the 3 wire connector coming from EST. Pulled it apart, looked good (clean, no corrosion), but blew it out, and reconnected it. I take a look at the EST and now is showing 'INIT'. So looks like it just re-recognized the unit again. Full menu is back on the EST display.

So with it seemingly fixed, I fired it up and gave it a good run. Hopefully we'll not run into this again anytime soon.

The moral of the story:
'NO SIGNAL' was fixed by disconnecting and reconnecting connector for the 3 wires between EST and heater unit. Leads to diagnosis of bad connection in connector due to vibration.

Hardware Configuration: Espar D2 24V with 12/24 boost supply, Easystart Timer, High Altitude Kit

Plenty of helpful tips in this thread to get me heading in the right direction with the initial troubleshooting.

As always, YMMV


Active member
Tis the season for random No Signals again for me.

Sat in the driveway after a long drive for 24 hours and checked it was working after parked. Came back 24 hours to a no signal. Ugh.

Pulling the 5 amp fuse resets it every time.


Engineer In Residence
I randomly had the no signal after leaving my heater running for 5 or 6 days. I forgot it was on, and it was warm enough it never fired up. I think next time I will go webasto...


New member
This was causing issues for me as well. On a recent trip up to frigid South Dakota from temperate Texas, the heater was working fine. Then the van sat in 0 degree SD weather for a week while we were visiting family. On the way back home I was receiving "NO SIGNAL" on my remote: the fan on the heater would run for about 30 seconds, no firing occurred, and then the whole thing shut down.

Long story short, I isolated the problem to my high altitude kit through a few replicated tests: when I removed the altitude kit from the system (basically, unplugged it from the connection between the remote receiver and the heater) everything ran fine. My suspicion is that the extended cold weather destroyed its internal components somehow, but I'm not happy with this explanation since it seems sort of bizarre. Either way, I plan to replace the altitude kit and this might give you an idea of something else to check.

Top Bottom