OM647 engine tick/tap once warm on acceleration.

RileyC

2002 140 shc, 2005 158 sh
Hey everyone, Some background: I'm a relatively new forum member and Sprinter owner. I bought this rough looking van, but what I thought was a good running van this past July. It has 210k miles and I don't really know its service history or how it was treated in its past life. I have been constantly working on it since purchasing, and had finally gotten it to a point where I thought I was done working on it for a while. The Forum has been an invaluable resource for me during this process.
Here is the issue I'm having: Once the engine is warm and accelerating it makes what sounds like a valve tick to me. Its louder when going uphill at highway speeds. Its quiet when at idle or when you rev the engine up in park. The check engine light is off, having the blower fan on or off doesn't make a difference. The oil has recently been changed. Its getting 22mpg and finally has good power after replacing maf and freeing up turbo linkage. I think its a new noise, maybe it wasn't as noticeable before the van got its mojo back.
My questions are: what causes this noise and what can I do to rule out different causes? and if it is internal to the engine can anything be done to "safely" clean or flush the engine? Thanks, I know this is long winded, just wanted to give as much info as possible. I can try and record the noise with my phone when driving to work this afternoon but I don't know if it will be loud enough to be discernable on a recording. Oh, I have not been carrying heavy loads thus far.
 

RileyC

2002 140 shc, 2005 158 sh
I tried recording the noise with my phone, but you cant hear it very well. Its a clicking or ticking sound. I may try and change the oil and filter a couple of times in the next thousand miles or so and see if that quiets it down. If anyone has any suggestions, let me know.
 

Talbott594

Talbott594
Did you ever figure out your ticking? Mine ticks too. Mine ticks all the time. Tick,Tick,Tick,Tick,Tick,and so on. Mine actually ticks louder when you first crank it, then in seconds it gets lower but still ticks.
 

derekhski

New member
have either of you looked at your injectors? I ask as I have the tick to, some days no tick, some days a tick..... I thought I saw a note some time back pointing to that its on of the signs of black death, but to scared and not enough time to take the panel cover off on top of the engine and look. (daughters 3, wife wants some me time)(different story) Just asking? Interested in what you have done to research and will advise when I do?
 

glas1700

Member
have either of you looked at your injectors? I ask as I have the tick to, some days no tick, some days a tick..... I thought I saw a note some time back pointing to that its on of the signs of black death, but to scared and not enough time to take the panel cover off on top of the engine and look. (daughters 3, wife wants some me time)(different story) Just asking? Interested in what you have done to research and will advise when I do?
Better to take a few minutes and inspect for black death than to let it go until it's really difficult to clean up.
 

MercedesGenIn

Mercedes-Benz Resource
If the tick diminishes slightly when you press the brake at idle - suspect vac pump as source of noise.

All the best
Steve
 

Top Bottom