Stranded in Boulder. Low boost.

JohnForde

New member
Hi forum,

I'm a friend of member JohnForde who is stranded at my house in his 2004 Sprinter. It is running poorly with lots of black smoke on acceleration and low power. We've done some preliminary trouble-shooting thanks to the great help here and right now our main suspect is the turbo vane control. The linkage is not frozen as it moves when started and when the MAF wires are removed (down at idle, up to 'engine off' position when MAF disabled) but the funny thing is that it does NOT move significantly at all when the engine is rev'd. In other words, when started at idle the actuator arm moves down about 2 inches (viewed from the top) but then when the engine is rev'ed up it doesn't move at all until the engine is off or the MAF wires are disconnected.

Some other information is that the air filter was extremely dirty and has been replaced (no change). To my un-trained ear it sounds like the turbo has a dry bearing when the engine is rev'ed up (it's quiet at idle) but when spinning the shaft by hand it feels smooth and spins easily. It also has the aluminum turbo resonator.

We pulled some codes using a generic OBDII and got the following (the MAF codes could be due to the fact that we drove to the store with the sensor disconnected)

P0402 - excessive EGR flow
P2506 - ECM/PCM power input
P0102 - MAF low input
P0100 - MAF circuit
P0131 - 02 low voltage (bank 1 sensor 1)
P0406 - EGR sensor A circuit high
P0299 - turbo underboost

It sure seems like an air supply problem due to the black smoke and low power. At idle or easy cruising speed it seems to be running fine. It is only during acceleration or high rev's the problems become noticeable.

Any help in diagnosing this would be greatly appreciated!
 

NelsonSprinter

Former Nelson BC Sprinter
If the codes were accurate, and they may not be, it would indicate to me a wiring/connection problem to the ECM or to those sensors, preventing the turbo's actuator from turning on the boost under acceleration, or the actuator stuck. Did the MAF get reconnected after the air filter change?
 

lindenengineering

Well-known member
Hi forum,

I'm a friend of member JohnForde who is stranded at my house in his 2004 Sprinter. It is running poorly with lots of black smoke on acceleration and low power. We've done some preliminary trouble-shooting thanks to the great help here and right now our main suspect is the turbo vane control. The linkage is not frozen as it moves when started and when the MAF wires are removed (down at idle, up to 'engine off' position when MAF disabled) but the funny thing is that it does NOT move significantly at all when the engine is rev'd. In other words, when started at idle the actuator arm moves down about 2 inches (viewed from the top) but then when the engine is rev'ed up it doesn't move at all until the engine is off or the MAF wires are disconnected.

Some other information is that the air filter was extremely dirty and has been replaced (no change). To my un-trained ear it sounds like the turbo has a dry bearing when the engine is rev'ed up (it's quiet at idle) but when spinning the shaft by hand it feels smooth and spins easily. It also has the aluminum turbo resonator.

We pulled some codes using a generic OBDII and got the following (the MAF codes could be due to the fact that we drove to the store with the sensor disconnected)

P0402 - excessive EGR flow
P2506 - ECM/PCM power input
P0102 - MAF low input
P0100 - MAF circuit
P0131 - 02 low voltage (bank 1 sensor 1)
P0406 - EGR sensor A circuit high
P0299 - turbo underboost

It sure seems like an air supply problem due to the black smoke and low power. At idle or easy cruising speed it seems to be running fine. It is only during acceleration or high rev's the problems become noticeable.

Any help in diagnosing this would be greatly appreciated!
John
As with most generic scanners/code readers they fall short, you need a sub code to really nail it down (ex P1404/004)
Equally the cheapy readers in some case mus-interpret the code and it leads you up the garden path. Its one of the reason why many mechanics hate working on Sprinters.

Also what is stored in the PCM might be old redundant codes and of no real value. So beware.

My first thought based upon experience is that you have a charge pressure leak which can easily be found by smoking the system with a smoke machine.

If you take the Boulder turnpike a trip into the dealer (MB Westminster 303 410 7816 Tracy) for a simple scan might be more helpful, or if you don't mind using a Independent like me. We are off of Hwy 95 in Golden. (720 344 1877)
Both of us will give you some pointers on DIY fix yah.
Cheers Dennis
 

Aqua Puttana

Poly - Thread Finder
JohnForde and friend,
Not that anyone asked...

Mapquest shows the city center of Boulder to be 1/2 hour from the the center of Colden Golden, CO. Were I stuck in Boulder I would call Linden Engineering to check for an appointment and head that direction if they can accomodate you.

Based upon posting history here on Sprinter-source I would be confident that Linden Engineering would be able to help you. In addition to that, I would look at it as an opportunity to meet Dennis. I suspect that alone will be worth the price of admission. FWIW. vic
 
Last edited:

NBB

Active member
MB Westminster is not competent, IMO, nor is Valley in Boulder. I would definitely try Golden.
 

Aqua Puttana

Poly - Thread Finder
Golden... ???? :bash:

Sorry 'bout that. Ya know what? Even Mapquest helps the mindless. Although I used the wrong name it still took me to Golden. No amount of planning will ever replace dumb luck. :cheers: vic
 

lindenengineering

Well-known member
Well
He's fixed and gone!
Simple problem, turbo hose off at the charge cooler.
I wish they were all like that.
Thanks for the recommendations forum members.

Colorado Al.
I have a few Pnzgauers in at the moment, one being a total crash rebuilt. Went down a mountain ravine from about 2000 ft end over end. Lucky no-one is inside !
As for Urals, I am trying to shoehorn a Kubota 3 cylinder diesel into a sidecar type bike.
Any suggestion what it should be called?
Kubural??:laughing:
Cheers Dennis
 

Coast2Coast

2006 158 Cargo
MB Westminster is not competent, IMO, nor is Valley in Boulder. I would definitely try Golden.


They lost the best parts guy ever Adam, please come back. We miss you out here. I remember Adam called me to check on me with a parts order when I was making a 1600 mile run from Denver to Eastern Pa. Hope you can return one day! All the best :thumbup:
 

surlyoldbill

New member
hey Dennis, my buddy has fallen out of love/lust with his 404 Unimog with radiobox (all original stuff still mounted in the radiobox). Is that of interest to you?
 

Colorado_Al

Active member
Well
He's fixed and gone!
Simple problem, turbo hose off at the charge cooler.
I wish they were all like that.
Thanks for the recommendations forum members.

Colorado Al.
I have a few Pnzgauers in at the moment, one being a total crash rebuilt. Went down a mountain ravine from about 2000 ft end over end. Lucky no-one is inside !
As for Urals, I am trying to shoehorn a Kubota 3 cylinder diesel into a sidecar type bike.
Any suggestion what it should be called?
Kubural??:laughing:
Cheers Dennis
Right on! A Kubota diesel will rattle all the bolts right out of that URAL! Hell, the stock engines those come with nearly do. I'm still not quite sure how Ural passed USA safety and emissions. Death traps! Glad to hear you're making them more so. Sounds like a fun ride! If you get it working maybe we can add a veggie oil tank to really do it up.
Hope you and your family are well!
Al
 

lindenengineering

Well-known member
Right on! A Kubota diesel will rattle all the bolts right out of that URAL! Hell, the stock engines those come with nearly do. I'm still not quite sure how Ural passed USA safety and emissions. Death traps! Glad to hear you're making them more so. Sounds like a fun ride! If you get it working maybe we can add a veggie oil tank to really do it up.
Hope you and your family are well!
Al
Al
I am not converting it for an unusual ride heavens forbid! More as a tug unit for pulling and pushing dead vehicles around the yard.
Once upon a time when I lived in Iran (1978/79), working for Leyland Motors Iran, I rode a 1956 Tiger 100 out of Tehran and up to Kandahar & Kabul. I was trying to get to Samarkand but they wouldn't let me in. I suppose in hindsight I should have been riding Ural.:frown:

On the way back I encountered an old guy in his 80's with an old Soviet Ural ploughing a field with some kids. I enjoyed a cuppa with them on the side of the road. That's what gave me the idea to fab a tow hitch in the bike and use it as a push me pull you in the yard.

Truthfully, I cannot get used to the motorcycle and sidecar no matter how I try. So there is no chance of me scudding this thing up the road. Except perhaps for grins and giggles.

As for famous curios I do have this thing coming back in for a gearbox fault, its still registered to Elstree Studios in Boreham Wood, London UK. It housed in Ft Collins;-
http://www.youtube.com/watch?v=SEwK26IcHM0
Enjoy the clip.
Cheers Dennis
 

JohnForde

New member
Dennis was awesome.
Dennis, you are awesome!
Wish we had someone like him here in MN.
On the other hand, maybe my wife will let me justify four :cheers:trips to colorado each year to keep the Sprinter in fine shape!
 

lindenengineering

Well-known member
Dennis was awesome.
Dennis, you are awesome!
Wish we had someone like him here in MN.
On the other hand, maybe my wife will let me justify four :cheers:trips to colorado each year to keep the Sprinter in fine shape!
John
Many thanks for the kind words and I hope you had a good repair experience.
Certainly you were the talk of the shop today as Deborah was back having her Land Rover fixed.
I think after scudding about on test in your van she is becoming a Sprinter nut. :cheers:

I trust you had a safe journey home, come back to Colorado when you can.
Very best regards and happy Sprintering
Linda Dennis & the crew in the shop.
 

Top Bottom