2011 Dome Light Issue

RTANK

New member
I have a 2011 MB with a dome light problem. This is the basic light with auto/off/on position. The light does not operate the the auto position. Switch contacts are ok. All rear cargo lights work properly. Manual position works properly. The dash indicator shows when either door is opened, but no light. I show about 12v on the auto side and a full volt higher on the manual side of switch. Dealer said the SAM shows the circuit has been shut down because of short. I haven't found a short yet and I have pulled the A-pillar cover and also looked under dash and above headliner (as much as possible without pulling it), and all looks ok. Any thoughts? Where is the BCM located? Does anyone have a lighting diagram for this? I was thinking of just running new wiring for the dome from the BCM.
 
Last edited:

Cvollmar

New member
I have had this issue in a couple of trucks in my fleet. Mercedes has told us there is a problem with the signal aquisition module or SAM module for short. We have been told not to replace them and that they are working on a fix for it. I will post it if and when we get it.
 

RTANK

New member
Found the connector at BCM. The wiring was fully intact to dome. No shorts. Checked voltage again across red (power) to Grn/Brn (Ground through BCM) 10.5 volts until light is switched on. I tried running a relay (.2A draw) instead of the light (.9A) without success. It does appear that the BCM has a problem.
 

RTANK

New member
Update... The dealership reset the computer a few months ago and the lighting has been working since then.
 

Vander

Sprinter Tech
I had a van come on to where I work for almost the sam issue, exept the light did not come on switch to both directions, if you have battery voltage on both contacts then you definitely don't have an open circuti and it's not a short or it would be blowing the fuse or having power all the time. In that case, it's Most likely the SAM modual on the BCM that's causing the issue the sam modual controlls all the lighting in the vans.
 

rvBob

New member
I have a 2012 sprinter with the same issue of the dome light not working in the auto switch position. I changed out the cargo and dome lights to LED about 4 months ago. Tired of replacing burned out incandescent bulbs. Is this the possible cause of this issue. Will replacing the LED bulb back to incandescent correct or only resetting the computer will correct? Can I reset computer with a basic code reader I have. Thanks

PS - This is a great forum - have gained a lot of information from the post.
 

RTANK

New member
I believe the dealership will have to do the reset. I haven't had an issue after they reset mine. I do have one led installed but I don't like it much. I will swap it out one day for a standard bulb. Good luck!
 

Bobmirko

New member
I believe the dealership will have to do the reset. I haven't had an issue after they reset mine. I do have one led installed but I don't like it much. I will swap it out one day for a standard bulb. Good luck!
Do you remember if they only reset the SAM module or if they reset the whole ECU and put a new software in it?

Thanks!
 

RTANK

New member
This was only for a reset of the SAM module. As far as I'm aware there was not an update performed. Still no problems!
 

Mickyfin

Member
Ive been struggling with the very same issue as the op.
 

sparkplug

Active member

Mickyfin

Member
Thanks for that, I've made a note if that, and will check tomorrow and report back.

Sent from my Nokia 9 using Tapatalk
 

Burkilimo

New member
I had this problem in one of our sprinters - no dome light when opening the drivers side door. Noticed that if you close it - but not actually close it - if that makes any sense - and then push it open again - the light turns on. Never really bothered fixing it - as this “fix” seemed to work when the drivers needed it
 

Top Bottom