Sprinter-Forum    
 

Go Back   Sprinter-Forum > NCV3 Sprinters > NCV3 Talk

NCV3 Talk General Discussions related to NCV3 Sprinters.


 
Thread Tools Display Modes
Old 11-05-2017, 09:31 PM   #1
EBH
 
Join Date: Nov 2012
Location: Alberta Canada
Posts: 139
Thanks: 92
Thanked 17 Times in 13 Posts
Default TPM

I have a 2007 sprinter RV ( US Model) and my TPM light flashes and then stays on, it will go out after a while etc.and than come back on again, also on the digital display it shows TPM when the light is on.?
It indicates there is a problem with the TPM system.
I believe it has a receiver unit/controller some where,.
Would anyone know where this is located and what it looks like?
Any help would be appreciated .
Ed
EBH is offline   Reply With Quote
Old 11-05-2017, 11:34 PM   #2
bcislander
'07 Mercedes-badged Dodge
 
bcislander's Avatar
 
Join Date: May 2011
Location: Vancouver Island
Posts: 889
Thanks: 164
Thanked 365 Times in 257 Posts
Default Re: TPM

There is a pressure sensor in each wheel. Most likely the battery in one or more of the wheel sensors is 'dead', which will cause the TPMS warning light to illuminate, just as it has done in my Sprinter. Battery life for these sensors varies, but failure after 10y would not be unusual.

Check the tire pressures regularly and ignore the light or replace the pressure sensors. I intend to replace the sensors the next time I have to replace the tires.
__________________
2007 Mercedes-badged Dodge 2500, GWV Legend RV
bcislander is offline   Reply With Quote
The Following 2 Users Say Thank You to bcislander For This Useful Post:
EBH (11-06-2017), ptheland (11-05-2017)

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT. The time now is 05:49 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.