Sprinter-Forum    
 

Go Back   Sprinter-Forum > Regional Discussions > Australia, New Zealand, and Asia Pacific


 
Thread Tools Display Modes
Old 02-08-2019, 04:08 AM   #1
mcguyver
 
Join Date: Aug 2016
Location: Brisbane Australia
Posts: 236
Thanks: 290
Thanked 51 Times in 30 Posts
Default Power steering issues

I am currently in NZ. Before departure I left my van (2012 CD316 4WD) to have a service.

They have just contacted me and are saying it has a leaking power steering pump. They are also saying the steering rack is rusted on and needs to be replaced but sourcing parts is an issue.

Anyone had any similar issues?

Any and all info appreciated.
__________________
2012 316 MWB 4WD
mcguyver is offline   Reply With Quote
Old 02-08-2019, 05:31 AM   #2
Bobnoxious
 
Join Date: Mar 2015
Location: Noxville, Noxious
Posts: 17,140
Thanks: 9,828
Thanked 6,212 Times in 4,523 Posts
Default Re: Power steering issues

Quote:
Originally Posted by mcguyver View Post
I am currently in NZ. Before departure I left my van (2012 CD316 4WD) to have a service.

They have just contacted me and are saying it has a leaking power steering pump. They are also saying the steering rack is rusted on and needs to be replaced but sourcing parts is an issue.

Anyone had any similar issues?

Any and all info appreciated.
No similar experience. Question, any evidence of leaking or steering issues prior to taking it for service? Also, some members had reported satisfactory results with power steering stop leak. Worth a try before R&R.

Last edited by Bobnoxious; 02-08-2019 at 08:24 AM.
Bobnoxious is offline   Reply With Quote
The Following User Says Thank You to Bobnoxious For This Useful Post:
mcguyver (02-08-2019)
Old 02-08-2019, 03:20 PM   #3
Midwestdrifter
 
Join Date: Sep 2013
Location: Charlotte NC
Posts: 11,729
Thanks: 2,293
Thanked 7,782 Times in 4,931 Posts
Default Re: Power steering issues

Were the boots torn on the rack? Otherwise there is no reason for it to be in bad shape.

A leaking PS pump. Where from? Shaft seal? Reservoir O-ring? High pressure fitting? Its not unusual for the low pressure return hose to leak at the reservoir barb fitting. Also, overfilling the pump can cause spillage that may be misdiagnosed as a leak. In addition, if they were turning the steering wheel with the engine off, the fluid can overflow from the cap vent.

The rack can likely be cleaned and greased for more life, depending on if it has been damaged by debris.


On the T1N, the 2wd rack can be modified to work on the 4wd. I am not sure about the NCV3 though.

A few photos would be immensely useful.
__________________
2004 T1N | Overland Conversion in Process Completed...For now... | 187,000 miles | 140" | High Roof | My Build Thread
Another Random Blog | http://VagariesAbound.blogspot.com
Midwestdrifter is online now   Reply With Quote
The Following User Says Thank You to Midwestdrifter For This Useful Post:
mcguyver (02-09-2019)
Old 03-08-2019, 03:52 AM   #4
mcguyver
 
Join Date: Aug 2016
Location: Brisbane Australia
Posts: 236
Thanks: 290
Thanked 51 Times in 30 Posts
Default Re: Power steering issues

Thought I would update this. After much searching for replacement racks I came across Ultimate Power steering at Brendale in Brisbane.

They totally rebuilt the rack including rechromimg the shaft for $1400. Comes with 2 year warranty

Very happy with the result.
__________________
2012 316 MWB 4WD
mcguyver is offline   Reply With Quote
The Following User Says Thank You to mcguyver For This Useful Post:
Midwestdrifter (03-08-2019)
Old 03-08-2019, 05:32 AM   #5
jaahn
 
Join Date: Nov 2014
Location: Waratah, Newcastle.
Posts: 309
Thanks: 84
Thanked 108 Times in 91 Posts
Default Re: Power steering issues

Hi Mac
Thanks for updating us, glad you are happy.
One thing though, I am puzzled as to the shaft that was the problem. Is that the input shaft that was rusty, or the rack which had failed. Or have I misunderstood the problem area completely. Also were the boots torn or split in the convolutions.
Cheers Jaahn
jaahn is online now   Reply With Quote
Old 03-11-2019, 01:14 AM   #6
mcguyver
 
Join Date: Aug 2016
Location: Brisbane Australia
Posts: 236
Thanks: 290
Thanked 51 Times in 30 Posts
Default Re: Power steering issues

Jaan
It was the Chrome shaft on the rack. Boots had a split on the top so was hard to se
__________________
2012 316 MWB 4WD
mcguyver is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT. The time now is 09:09 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.