Sprinter-Forum    
 

Go Back   Sprinter-Forum > Sprinter-Based RV's & Conversions > Sprinter-Based RV Brands > Winnebago / Itasca

Winnebago / Itasca Itasca Navion, Winnebago View.


 
Thread Tools Display Modes
Old 02-02-2020, 08:17 PM   #1
myst
 
Join Date: Apr 2019
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default 2006 Winnebago View, license plate light and over sink lights not working

Hey everyone, just started having some electrical issues with our 2006 Winnebago View. I noticed that the rear license plate lights don't work. There is no power to the wires, there is a good ground.

Also the 2 light under the cabinet sitting with over the sink don't work, and the lights under the storage sitting above the dining table near the TV slide down do not work.

And the windshield washer pump doesn't work.

Not sure if any of this is related but all 3 use to work a month or so ago. Any input help would be appreciated

PS figured out the overhead lighting issue, it was one of the fuses under the fridge. No not sure what's up with license plate light and windshield washer motor

Last edited by myst; 02-02-2020 at 10:27 PM.
myst is offline   Reply With Quote
Old 02-04-2020, 05:56 PM   #2
4wheeldog
 
Join Date: Mar 2015
Posts: 1,011
Thanks: 554
Thanked 589 Times in 387 Posts
Default Re: 2006 Winnebago View, license plate light and over sink lights not working

Quote:
Originally Posted by myst View Post
Hey everyone, just started having some electrical issues with our 2006 Winnebago View. I noticed that the rear license plate lights don't work. There is no power to the wires, there is a good ground.

Also the 2 light under the cabinet sitting with over the sink don't work, and the lights under the storage sitting above the dining table near the TV slide down do not work.

And the windshield washer pump doesn't work.

Not sure if any of this is related but all 3 use to work a month or so ago. Any input help would be appreciated

PS figured out the overhead lighting issue, it was one of the fuses under the fridge. No not sure what's up with license plate light and windshield washer motor
First thing that comes to mind is to check for rodents chewing on wires.
4wheeldog is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT. The time now is 05:30 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.