Sprinter-Forum    
 

Go Back   Sprinter-Forum > Regional Discussions > Australia, New Zealand, and Asia Pacific


 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 06-10-2019, 04:29 PM   #1
MEAT_WAGON
 
Join Date: Mar 2019
Posts: 7
Thanks: 7
Thanked 0 Times in 0 Posts
Exclamation First Transmission,then edc light, now no start HELP!!

Little help please legends,
this is cooking my brain and I'm ready to torch this thing.

timeline
bought 03 mob ex Australian ambulance been sitting 4 years and just had sprintshift replaced
2 tanks of fuel later wouldn't change gears automatically
but would change up manually and back down auto
then box started working again
close to bottom of tank of fuel stalled like it ran out of fuel as pulled into servo.
put $20 in at servo drove off fine
got to mainland 45 min up the road pulled into another servo where fuel much cheaper
full tank drove off edc light came on and stalled wouldn't start
started got 15 min up road and etc light came on again and died completely and wouldn't start
pulled water drain and put back in no start
pulled filter off realising after there was no way to prime it
scabbed fuel from filler pipe under bus
couldn't get air out of lines.
new filter new 0 rings on nearly everything, new one way valve on filter new lines, hand prime with a fluid pump got all air out
still won't start even with starter fluid..

what next guys? bit strapped for cash and need to fix it myself, will get a mobile mechanic to come with a scanner to see what codes but want to cover everything simple myself first.

bought an 03 sprinter, mob, ex Australian ambulance. it had been sitting for 4 years, and had a "new sprint shift transmission" put in just before I got it. workshop receipt for $4800. had oil in the radiator coolant filler, was told it would cycle out give it a few flushes as the cooler had just been replaced. had it for about a month and hadn't done too much driving as I live on a small island off Brisbane. but seemed to run like a dream, gearbox a little clunky. then all of a sudden wouldn't change automatically only up maualy and down auto. the rest is pretty much explained above.
MEAT_WAGON is offline   Reply With Quote
 

Tags
air in fuel lines, edc, fuel filter, sprintshift, starting problem

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT. The time now is 07:16 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.