Sprinter-Forum    
 

Go Back   Sprinter-Forum > T1N Sprinters > T1N Talk

T1N Talk General Discussions related to T1N Sprinters.


 
Thread Tools Display Modes
Old 08-17-2019, 10:51 AM   #1
DIYSprinterCamper
 
Join Date: Aug 2019
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default 311cdi issue with intermittent power loss

I have a 2004 sprinter 311cdi with sprintshift and a speed limiter set to 100 km/h. There's also a tachograph fitted as it used to be a disability minibus (originally converted by uv modular in the UK)

I'll describe the issue as best I can...

When driving around 92 - 96 km/h, there's a slight loss of power and the orange exclamation mark light comes on. This is usually very brief. It's almost like it wants to change up a gear, then realises it can't go up, so it changes its mind! The power drops, there's a bit of a 'lurch' in the van, the light flashes once or twice, but then it comes back to normal.

This happens when I drive in Auto mode, and the same happens if I override the auto and have it in gear 6.

A similar thing happens when going uphill with a turn, at speeds above 80km/h, but in this situation the light stays on for as long as the wheel is turned and there is no real loss of power.

I hope you understand the problem?

I should also say that the tachograph has been disabled and there's a permanent TCO light.

Can anyone suggest what's going on? And if so, what to do!

Thanks, Andy
DIYSprinterCamper is offline   Reply With Quote
Old 08-17-2019, 11:10 AM   #2
Eric Experience
 
Eric Experience's Avatar
 
Join Date: Aug 2008
Location: Victoria Australia
Posts: 2,908
Thanks: 113
Thanked 1,581 Times in 1,046 Posts
Default Re: 311cdi issue with intermittent power loss

Andy.
I am not familiar with the set up you have but suggest you take it back to the company that installed it and ask them to remove it. Eric.
Eric Experience is offline   Reply With Quote
Old 08-17-2019, 02:29 PM   #3
Aqua Puttana
Poly - Thread Finder
 
Aqua Puttana's Avatar
 
Join Date: Apr 2008
Location: The Falls of Niagara, USA
Posts: 24,540
Thanks: 12,517
Thanked 13,760 Times in 8,742 Posts
Default Re: 311cdi issue with intermittent power loss

I agree with Eric that the aftermarket unit could still be a contributor.

The yellow triangle indicates that the driver safety system(s) operated. Your problems could be related to a wheel speed sensor system issue, but getting rid any/all aftermarket unit possible influence would be my first priority.

vic
__________________
DAD NAS (N. Amer. Spec) 2004 140 2500 >330,000+ mi. Arctic Whitewash Brush-tone Grey
2006 Freightliner 140 2500HC >183,000+ mi. Arctic Whitewash (Spotted Snow Leopard accents)
"My opinion and worth everything you'll never pay for it." assumed.
Anyone can hold the helm when the sea is calm. Publilius Syrus
"There are only 10 types of people in the world: Those who understand binary, and those who don't." HaWiiLuVeR
16 ounces of unnecessary prevention can be worth a pound of manure.
Aqua Puttana is online now   Reply With Quote
Old 08-19-2019, 09:49 AM   #4
DIYSprinterCamper
 
Join Date: Aug 2019
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default Re: 311cdi issue with intermittent power loss

Hi Eric, Vic, thanks for that advice. Unfortunately the company in question stopped trading a few years ago, and I can't find any trace of their employees.

I will look into the wheel speed sensor, that sounds like a possible cause of the problem
DIYSprinterCamper is offline   Reply With Quote
Old 08-19-2019, 11:16 AM   #5
Eric Experience
 
Eric Experience's Avatar
 
Join Date: Aug 2008
Location: Victoria Australia
Posts: 2,908
Thanks: 113
Thanked 1,581 Times in 1,046 Posts
Default Re: 311cdi issue with intermittent power loss

Andy.
Where are you located? Eric
Eric Experience is offline   Reply With Quote
Old 08-19-2019, 08:32 PM   #6
DIYSprinterCamper
 
Join Date: Aug 2019
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default Re: 311cdi issue with intermittent power loss

Quote:
Originally Posted by Eric Experience View Post
Andy.
Where are you located? Eric
In Manchester, England
DIYSprinterCamper is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT. The time now is 12:24 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.