Sprinter-Forum    
 

Go Back   Sprinter-Forum > Sprinter-Based RV's & Conversions > Sprinter-Based RV Brands > Leisure Travel Vans > Unity


 
Thread Tools Display Modes
Old 08-05-2019, 02:09 PM   #1
JoePhoenix
2016 Unity TB
 
Join Date: Oct 2014
Location: Phoenix, AZ
Posts: 607
Thanks: 217
Thanked 430 Times in 256 Posts
Default Back-up Camera Fuse

I was over at my storage facility this weekend to check the batteries, start up the engine, etc., and when I put the van in reverse, the screen in the Becker was black. The radio and all other functions of the Becker seemed to work.

So, have I blown a fuse, is there a loose connection somewhere, or has the camera gone bad? It certainly was working when I put it in storage. If there's a fuse associated with the camera, where is it located?

Thanks,
Joe
__________________
2016 LTV Unity TB
JoePhoenix is offline   Reply With Quote
Old 08-08-2019, 04:50 AM   #2
carolinawrenn
 
Join Date: Jan 2017
Posts: 3
Thanks: 0
Thanked 1 Time in 1 Post
Default Re: Back-up Camera Fuse

I have a 2014 Unity MB, my rear camera's screen is also black, but label "check surroundings...." still comes up.
After a fuse blew a few months ago, the rear view camera does not come on when I put the vehicle in reverse, I have to hold the momentary toggle down.
Also, after the fuse blew, my side cameras do not work when the turn signals are activated.
Alec Wrenn
carolinawrenn is offline   Reply With Quote
The Following User Says Thank You to carolinawrenn For This Useful Post:
JoePhoenix (08-08-2019)
Old 08-08-2019, 01:51 PM   #3
JoePhoenix
2016 Unity TB
 
Join Date: Oct 2014
Location: Phoenix, AZ
Posts: 607
Thanks: 217
Thanked 430 Times in 256 Posts
Default Re: Back-up Camera Fuse

Quote:
Originally Posted by carolinawrenn View Post
I have a 2014 Unity MB, my rear camera's screen is also black, but label "check surroundings...." still comes up.
Alec Wrenn
This is what mine is doing. Do you remember where the fuse was? Was it in the Becker head unit or in one of the fuse boxes?
__________________
2016 LTV Unity TB
JoePhoenix is offline   Reply With Quote
Old 08-09-2019, 02:20 PM   #4
TW56
2016 UnityCB on a MB '15
 
Join Date: Mar 2015
Posts: 27
Thanks: 5
Thanked 5 Times in 4 Posts
Default Re: Back-up Camera Fuse

We have a 2016CB with a rear camera not working. I had a 1/2 screen display for a short period before the camera display went black. I still receive the check surroundings message at the bottom of the display when in reverse.

Not sure where the problem is, the partial screen view prior to the camera failure leads me to think it may have be a bad connection or camera failure and less likely to be a fuse problem. I am interested in any other owners who had a similar failure and any solutions.
__________________
2016 Unity CB 2015 MB Chassis
TW56 is offline   Reply With Quote
Old 08-11-2019, 12:43 PM   #5
SSTraveler
2014 LTV Unity Murphy Bed
 
SSTraveler's Avatar
 
Join Date: Jan 2014
Location: South Carolina
Posts: 1,602
Thanks: 676
Thanked 1,537 Times in 775 Posts
Default Re: Back-up Camera Fuse

There is another radio fuse under the passenger seat between the Isolator Solenoid and Connex Camera switch box.
Attached Images
File Type: jpg inCollage_20190811_083943114-900x900.jpg (199.1 KB, 43 views)
__________________
SSTraveler
2014 Unity Murphy Bed/2014 MB Chassis
SSTraveler is offline   Reply With Quote
The Following User Says Thank You to SSTraveler For This Useful Post:
JoePhoenix (08-11-2019)
Old 08-11-2019, 12:49 PM   #6
JoePhoenix
2016 Unity TB
 
Join Date: Oct 2014
Location: Phoenix, AZ
Posts: 607
Thanks: 217
Thanked 430 Times in 256 Posts
Default Re: Back-up Camera Fuse

Quote:
Originally Posted by SSTraveler View Post
There is another radio fuse under the passenger seat between the Isolator Solenoid and Connex Camera switch box.
Thanks. I'll check it out and see if that solves my problem, SST.
__________________
2016 LTV Unity TB
JoePhoenix is offline   Reply With Quote
Old 08-11-2019, 05:15 PM   #7
lindy
 
Join Date: Jul 2016
Location: Jacksonville Oregon
Posts: 49
Thanks: 46
Thanked 38 Times in 27 Posts
Default Re: Back-up Camera Fuse

I just had our MD2016 Dash radio out. There is a small fuse located in the wireing block at the rear of radio. I was wiring in 12volt USB outlets and needed the radio out for access.
Al
__________________
Al McMurray
2016 Unity MB
Southern Oregon
lindy is offline   Reply With Quote
Old 08-11-2019, 11:02 PM   #8
TW56
2016 UnityCB on a MB '15
 
Join Date: Mar 2015
Posts: 27
Thanks: 5
Thanked 5 Times in 4 Posts
Default Re: Back-up Camera Fuse

Dumb question...do you actually need to unbolt the passenger seat to look underneath it or is there some trick to getting under there? We never swivel our around.
__________________
2016 Unity CB 2015 MB Chassis
TW56 is offline   Reply With Quote
Old 08-12-2019, 01:04 PM   #9
SSTraveler
2014 LTV Unity Murphy Bed
 
SSTraveler's Avatar
 
Join Date: Jan 2014
Location: South Carolina
Posts: 1,602
Thanks: 676
Thanked 1,537 Times in 775 Posts
Default Re: Back-up Camera Fuse

Quote:
Originally Posted by TW56 View Post
Dumb question...do you actually need to unbolt the passenger seat to look underneath it or is there some trick to getting under there? We never swivel our around.
No, i haven't removed the seat for any of my work under the passenger seat. You just remove the panel that the awning controls are attached to. First you have to remove the awning controls and the lift the vinyl skirt to see the access panel. Many do remove the seat. It is supposed to be easy with just 4 Torx head bolts to remove but I just didn't want to do all that extra work when I can easily work through that access panel opening.
Attached Images
File Type: jpg 20180513_145827-900x700.jpg (122.7 KB, 25 views)
__________________
SSTraveler
2014 Unity Murphy Bed/2014 MB Chassis

Last edited by SSTraveler; 08-12-2019 at 01:11 PM.
SSTraveler is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT. The time now is 09:26 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.