Sprinter-Forum    
 

Go Back   Sprinter-Forum > General Forums > Sprinter Talk

Sprinter Talk General discussion about anything and everything about Sprinters.
SubForums: Events Scanners


 
Thread Tools Display Modes
Old 10-15-2019, 07:22 AM   #1
vanart
 
Join Date: Aug 2019
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default 2014 Sprinter accelerates by itself !?!?!?

RE 2014 Sprinter (Itasca Navion)


Here is an account of what happened earlier today:

1. driving on some bumpy gravel/logging road (in a hindsight - stupid idea) ...

2. 3 messages appears after 20 min:
- Something ABS
- Something ESP
- Something See the mechanics/garage...

3. What happens next found only in B movies... the car starts to accelerate by itself for around 5- 10 second while shifting gears sporadically.... I push the brake pedal... continue driving for another 10 min.

4. Parked for 2 hours

5. Drove back onto the pavements messages still there

6. Made a pit stop for 10 min

7. Started the engine the messages disappeared (close call or so i thought).

8. After driving for 25 min on a regular road messages appear again and again car starts to accelerate by itself shifting gears sporadically almost cousin rear end collision. I switch gear into "N" as pushing brakes along could not stop it...

9. Stop for 10 min. to start breathing again, to cope with adrenaline.

10. Started engine again, messages disappeared again, drive normally for 10 min before parking it at home.



Any ideas would be appreciated.

Needless to say that those codes need to be looked at, but perhaps someone had a similar situation.

Could I have damaged the transmission by driving on a logging road?

P.S. While we at it what is the recommended ODB2 (from Amazon) by the community as the the extortion from the dealership needs to be contained.
vanart is offline   Reply With Quote
Old 10-15-2019, 11:56 AM   #2
Eric Experience
 
Eric Experience's Avatar
 
Join Date: Aug 2008
Location: Victoria Australia
Posts: 2,953
Thanks: 113
Thanked 1,617 Times in 1,071 Posts
Default Re: 2014 Sprinter accelerates by itself !?!?!?

Vanart.
Some history please. ownership . Kilometers. My guess is rodent damage to the main loom. Eric.
Eric Experience is offline   Reply With Quote
Old 10-15-2019, 01:02 PM   #3
BrennWagon
Pete
 
Join Date: May 2017
Location: Philadelphia
Posts: 542
Thanks: 471
Thanked 287 Times in 205 Posts
Default Re: 2014 Sprinter accelerates by itself !?!?!?

Check for loose plugs and damaged wiring and scan the ecu with a Sprinter specific scanner that can look into the traction control system. Faulty/misaligned wheel speed sensors can make the computer think crazy things and cut power. Also inspect and test the accelerator assembly.
BrennWagon is online now   Reply With Quote
Old 10-15-2019, 01:34 PM   #4
Ziggy
 
Join Date: Jun 2012
Posts: 28
Thanks: 44
Thanked 7 Times in 5 Posts
Default Re: 2014 Sprinter accelerates by itself !?!?!?

Wheel sensor has gone bad, this has happened to me several times. It is unnerving about the acceleration, it has happened to me also, always associated with loss of one of the wheel sensors. Sometimes the warnings will go away with so many starts and stops, only if the sensor is partially going bad. Eventually the warnings remain on when the sensor dies fully. I have driven over 1100 miles with a bad sensor though, you have no ABS, cruise control, or 4 wheel drive. The uncontrolled acceleration only seemed to happen to me at very low speed, and only sporadically.

Good luck!


Sent from my iPhone using Tapatalk
Ziggy is offline   Reply With Quote
The Following User Says Thank You to Ziggy For This Useful Post:
elemental (10-15-2019)
Old 10-15-2019, 01:55 PM   #5
Aqua Puttana
Poly - Thread Finder
 
Aqua Puttana's Avatar
 
Join Date: Apr 2008
Location: The Falls of Niagara, USA
Posts: 25,075
Thanks: 12,913
Thanked 14,131 Times in 8,980 Posts
Default Re: 2014 Sprinter accelerates by itself !?!?!?

Quote:
Originally Posted by Ziggy View Post
... It is unnerving about the acceleration, it has happened to me also, always associated with loss of one of the wheel sensors. Sometimes the warnings will go away with so many starts and stops, only if the sensor is partially going bad.
...
Interesting. Good to know.

The wheel speed sensors are used for a feedback loop to the ECM aka ECU. Depending upon the failure mode a sensor could intermittently provide an RPM signal lower than actual. A completely failed and recognized as bad sensor would have the ECM switch to a default mode.

vic
__________________
DAD NAS (N. Amer. Spec) 2004 140 2500 >330,000+ mi. Arctic Whitewash Brush-tone Grey
2006 Freightliner 140 2500HC >183,000+ mi. Arctic Whitewash (Spotted Snow Leopard accents)
"My opinion and worth everything you'll never pay for it." assumed.
Anyone can hold the helm when the sea is calm. Publilius Syrus
"There are only 10 types of people in the world: Those who understand binary, and those who don't." HaWiiLuVeR
16 ounces of unnecessary prevention can be worth a pound of manure.
Aqua Puttana is offline   Reply With Quote
Old 10-15-2019, 06:00 PM   #6
autostaretx
Erratic Member
 
autostaretx's Avatar
 
Join Date: Sep 2006
Location: Seattle
Posts: 17,707
Thanks: 3,099
Thanked 8,021 Times in 5,848 Posts
Default Re: 2014 Sprinter accelerates by itself !?!?!?

Also check your oil ... an oil leak (say, via the turbo) into the air intake stream can cause a diesel to treat it as "Oh, Joy! More Fuel!"

... been there, done that ... in a VW Rabbit (30 to 65 mph in very few seconds... interesting smoke plume)

--dick
__________________
2005 T1N 118" Freightliner 2500 Passenger Wagon (2.7L, 15" tires, standard (short) roof)
Get YOUR Sprinter's full configuration datacard by entering your VIN to https://www.datamb.com/
http://diysprinter.co.uk/reference <-- lots of service documentation, Thanks to Jens Moller and Arnie_Oli
((as always: this post may go through a couple of post-posting edits... so maybe give it ten minutes before commenting))
autostaretx is online now   Reply With Quote
The Following 2 Users Say Thank You to autostaretx For This Useful Post:
Aqua Puttana (10-16-2019), sailquik (10-15-2019)
Old 10-16-2019, 01:04 PM   #7
owner
 
owner's Avatar
 
Join Date: Sep 2011
Location: VIC AU
Posts: 2,124
Thanks: 747
Thanked 1,025 Times in 722 Posts
Default Re: 2014 Sprinter accelerates by itself !?!?!?

Did you have cruise control switched on? Thats the only way I can think of a speed sensor causing un-demanded acceleration. Or maybe pedal position sensor fault but those are fail-safe when faulty. Otherwise most likely what dick said, runaway due to PCV/turbo oil ingestion.

When yiu shifted to N did the engine rev high?

Last edited by owner; 10-16-2019 at 01:06 PM.
owner is offline   Reply With Quote
Old 10-17-2019, 04:02 AM   #8
vanart
 
Join Date: Aug 2019
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default Re: 2014 Sprinter accelerates by itself !?!?!?

Thank you my good Samaritans,

All savings on fuel are being flushed down the toilet when you have to pay thousands of dollars every-time van shakes or goes briefly on a non pavement road.... And I am hoping it is just sensors... Last time I replaced some sensors it was around 2 Gs, thankfully under warranty ...

Quote:
Originally Posted by owner View Post
Did you have cruise control switched on? ?
No cruise control,


Quote:
Originally Posted by owner View Post

When yiu shifted to N did the engine rev high?
:-)
just tried to avoid a collision with a car in front! Pushing my Break pedal did not provide sufficient stopping power...
vanart is offline   Reply With Quote
Old 10-18-2019, 02:48 PM   #9
Hooligan2
 
Hooligan2's Avatar
 
Join Date: Apr 2015
Posts: 100
Thanks: 6
Thanked 65 Times in 45 Posts
Default Re: 2014 Sprinter accelerates by itself !?!?!?

I had a wheel sensor fail, 3 lights (ASR-ABS-ESP) only symptom was cruise disengaged.. stopped to refuel and on restart, no lights, exiting station, pulled into traffic engine very late shift from 1st (over 3000rpm) went to 2nd, hard shift back to first engine surged and hard acceleration against the brake for 5+ seconds.. lights came back on.. Continued home (270miles) with lights on and did not restart to prevent clearing the lights. MB replaed LR wheel sensor -warranty. FWIW Wheel sensors are covered under 5yr/100K Fed Emissions warranty.

ESP- Stability program has the ability to control power and braking according to MB video. ???
__________________

Pensacola, Fl
2016 Siesta Sprinter 24ST
George the Newfoundland, Lily the Pug
1972 Moto Guzzi Eldorado
Hooligan2 is offline   Reply With Quote
Old 10-20-2019, 11:15 PM   #10
vanart
 
Join Date: Aug 2019
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default Re: 2014 Sprinter accelerates by itself !?!?!?

Thank you Hooligan2
Exactly the same chain of events for me...

Unfortunately it is the first month out of that 5 y warranty.
I don't know if every little things will kill the sensor, and as a result I am left with a couple of thousand repair bill, well I feel it is just plain extortion form the MB side...
vanart is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT. The time now is 06:23 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.