Sprinter-Forum    
 

Go Back   Sprinter-Forum > Regional Discussions > Australia, New Zealand, and Asia Pacific


 
Thread Tools Display Modes
Old 02-14-2014, 11:42 AM   #11
Eric Experience
 
Eric Experience's Avatar
 
Join Date: Aug 2008
Location: Victoria Australia
Posts: 2,959
Thanks: 113
Thanked 1,621 Times in 1,075 Posts
Default Re: No turn signals . Help.

Nick.
Some one else posted the drawing. Sounds like you did a good job with the fire hose. If you take the trim off around the switches and them clean the switches as best you can with compressed air you may get the dirt out of the switches. Eric
Eric Experience is offline   Reply With Quote
Old 02-14-2014, 12:20 PM   #12
MillionMileSprinter
Formerly Type2Teach
 
MillionMileSprinter's Avatar
 
Join Date: Dec 2010
Location: Philadelphia, PA, USA
Posts: 3,160
Thanks: 1,167
Thanked 1,533 Times in 858 Posts
Default Re: No turn signals . Help.

I would second swapping the grey relays on the bottom of the steering column fuse box. My buddy had similar issues with his blinkers and after cleaning everything, i finally swapped the two relays next to each other. Viola! No more blinker issues.
__________________
Sprinter Mechanic
'04 long/tall Silver Passenger 156K (Totaled! 11/2018)
'06 long/tall White Passenger 180K
'06 medium/short Silver Passenger 265k
Joel Sell
For HELP, SERVICE and MORE
Visit: www.millionmilesprinter.com
Cooling System Kit: https://www.millionmilesprinter.com/...n-life-cooling
Follow me on Instagram: https://www.instagram.com/million_mile_sprinter/
MMS YouTube Channel: https://www.youtube.com/channel/UCuq...mQ8mWdgF1XpLhg
MillionMileSprinter is offline   Reply With Quote
The Following User Says Thank You to MillionMileSprinter For This Useful Post:
SILVERFOX (02-15-2014)
Old 02-15-2014, 04:24 AM   #13
SILVERFOX
 
SILVERFOX's Avatar
 
Join Date: Nov 2010
Location: Far Nth Coast, NSW.Australia
Posts: 141
Thanks: 26
Thanked 23 Times in 17 Posts
Default Re: No turn signals . Help.

Thanks again.
If we get to the bottom of this I hope it can also help others in the future.

I will have a play with it tomorrow or Monday. Does anyone know if the relays are available in most places or are they a bit special???

Cheers
Nick.
SILVERFOX is offline   Reply With Quote
Old 07-14-2014, 01:52 PM   #14
SILVERFOX
 
SILVERFOX's Avatar
 
Join Date: Nov 2010
Location: Far Nth Coast, NSW.Australia
Posts: 141
Thanks: 26
Thanked 23 Times in 17 Posts
Default Re: No turn signals . Help.

HI AND THANKS TO ALL FOR YOUR HELP AND COMMENTS. Well I finally found it was the relay in question. Problem solved and has been reliable. Thanks again. Nick.
SILVERFOX is offline   Reply With Quote
Old 07-14-2014, 09:07 PM   #15
Aqua Puttana
Poly - Thread Finder
 
Aqua Puttana's Avatar
 
Join Date: Apr 2008
Location: The Falls of Niagara, USA
Posts: 25,164
Thanks: 12,959
Thanked 14,218 Times in 9,025 Posts
Default Re: No turn signals . Help.

Quote:
Originally Posted by Type2Teach View Post
... i finally swapped the two relays next to each other. Viola! No more blinker issues.
You might consider buying a replacement relay.

By swapping those relays you moved what is possibly a defective relay causing an intermittent wiper issue to the engine relay position which could set you up for future engine operation problems.

My opinion. Much better to leave the engine relay alone and swap the two less critical outside relays.

vic
__________________
DAD NAS (N. Amer. Spec) 2004 140 2500 >330,000+ mi. Arctic Whitewash Brush-tone Grey
2006 Freightliner 140 2500HC >183,000+ mi. Arctic Whitewash (Spotted Snow Leopard accents)
"My opinion and worth everything you'll never pay for it." assumed.
Anyone can hold the helm when the sea is calm. Publilius Syrus
"There are only 10 types of people in the world: Those who understand binary, and those who don't." HaWiiLuVeR
16 ounces of unnecessary prevention can be worth a pound of manure.
Aqua Puttana is offline   Reply With Quote
Old 07-19-2014, 12:58 PM   #16
SILVERFOX
 
SILVERFOX's Avatar
 
Join Date: Nov 2010
Location: Far Nth Coast, NSW.Australia
Posts: 141
Thanks: 26
Thanked 23 Times in 17 Posts
Default Re: No turn signals . Help.

Thanks for the suggestion Vic. Do you think I should simply replace the three relays at the bottom of the fusebox?
SILVERFOX is offline   Reply With Quote
Old 07-19-2014, 05:38 PM   #17
MillionMileSprinter
Formerly Type2Teach
 
MillionMileSprinter's Avatar
 
Join Date: Dec 2010
Location: Philadelphia, PA, USA
Posts: 3,160
Thanks: 1,167
Thanked 1,533 Times in 858 Posts
Default Re: No turn signals . Help.

Point well taken, Vic. Where can I buy those relays other than the stealership?
__________________
Sprinter Mechanic
'04 long/tall Silver Passenger 156K (Totaled! 11/2018)
'06 long/tall White Passenger 180K
'06 medium/short Silver Passenger 265k
Joel Sell
For HELP, SERVICE and MORE
Visit: www.millionmilesprinter.com
Cooling System Kit: https://www.millionmilesprinter.com/...n-life-cooling
Follow me on Instagram: https://www.instagram.com/million_mile_sprinter/
MMS YouTube Channel: https://www.youtube.com/channel/UCuq...mQ8mWdgF1XpLhg
MillionMileSprinter is offline   Reply With Quote
Old 07-19-2014, 08:36 PM   #18
MillionMileSprinter
Formerly Type2Teach
 
MillionMileSprinter's Avatar
 
Join Date: Dec 2010
Location: Philadelphia, PA, USA
Posts: 3,160
Thanks: 1,167
Thanked 1,533 Times in 858 Posts
Default Re: No turn signals . Help.

Quote:
Originally Posted by SILVERFOX View Post
Thanks for the suggestion Vic. Do you think I should simply replace the three relays at the bottom of the fusebox?
By just pulling them out and cleaning them, I have fixed (for now) the flasher issues on 3 different T1Ns. No one has come back for a re-fix. I would like to have a new one on hand, but will continue to just clean the contacts until there is a need to actually replace the relay.
__________________
Sprinter Mechanic
'04 long/tall Silver Passenger 156K (Totaled! 11/2018)
'06 long/tall White Passenger 180K
'06 medium/short Silver Passenger 265k
Joel Sell
For HELP, SERVICE and MORE
Visit: www.millionmilesprinter.com
Cooling System Kit: https://www.millionmilesprinter.com/...n-life-cooling
Follow me on Instagram: https://www.instagram.com/million_mile_sprinter/
MMS YouTube Channel: https://www.youtube.com/channel/UCuq...mQ8mWdgF1XpLhg
MillionMileSprinter is offline   Reply With Quote
Old 07-20-2014, 04:38 AM   #19
Aqua Puttana
Poly - Thread Finder
 
Aqua Puttana's Avatar
 
Join Date: Apr 2008
Location: The Falls of Niagara, USA
Posts: 25,164
Thanks: 12,959
Thanked 14,218 Times in 9,025 Posts
Default Re: No turn signals . Help.

Quote:
Originally Posted by SILVERFOX View Post
Thanks for the suggestion Vic. Do you think I should simply replace the three relays at the bottom of the fusebox?
Personally I would not mess with the center position engine ECM aka ECU relay unless it has given some indication of trouble. "Let sleeping dogs lie." comes to mind.

I'm not certain whether the paticular Amazon information below will help on your side of the world, but the info from the box may have some value.

Quote:
Originally Posted by Type2Teach View Post
Point well taken, Vic. Where can I buy those relays other than the stealership?
Some info is here.

http://sprinter-source.com/forum/sho...808#post315808

vic
__________________
DAD NAS (N. Amer. Spec) 2004 140 2500 >330,000+ mi. Arctic Whitewash Brush-tone Grey
2006 Freightliner 140 2500HC >183,000+ mi. Arctic Whitewash (Spotted Snow Leopard accents)
"My opinion and worth everything you'll never pay for it." assumed.
Anyone can hold the helm when the sea is calm. Publilius Syrus
"There are only 10 types of people in the world: Those who understand binary, and those who don't." HaWiiLuVeR
16 ounces of unnecessary prevention can be worth a pound of manure.
Aqua Puttana is offline   Reply With Quote
Old 01-27-2015, 11:42 PM   #20
blisspacket
2002 T1N, 2014 I4-7spd
 
Join Date: Jun 2009
Location: StAugustine FL
Posts: 69
Thanks: 27
Thanked 27 Times in 16 Posts
Default Re: No turn signals . Help.

Putting in my two cents. This seems a great thread in that Cheyenne posted that nice diagram of fuses and relays under the steering column. Yes, I had the same intermittent operation of turn signals. Then nothing. At one point I opened up the relay and attempted to dress the points. Best solution was spend $7 each at an Amazon site and got three relays to RnR all three. Turn signals operate now as do wipers. Fly in the ointment: sometimes I get a "Start Error" which creates NO action when I turn the key to start. I'd had an electrical drain a few years back, so have an underthedash major battery disconnect switch. Per another guru on this site, I simply do a battery disconnect, reconnect, and my "Start Error" has disappeared, I'm off and away. I dread the day when Start Error reappears, but so far allz well. I have 120k miles on this Sprinter, it's a gem in so many ways, and this Forum is a superb asset, but I gotta say I'm disappointed. Not so much so that we didn't jump onto an 07 V6 that is a marvel of engineering--I hope!!
blisspacket is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT. The time now is 10:59 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.