Sprinter-Forum    
 

Go Back   Sprinter-Forum > Sprinter-Based RV's & Conversions > Sprinter-Based RV Brands > Airstream > Sprinter Westfalia


 
Thread Tools Display Modes
Old 08-09-2019, 02:02 PM   #1
gowestygirl
 
Join Date: Feb 2011
Posts: 6
Thanks: 2
Thanked 8 Times in 2 Posts
Default Central Electronic System - Fridge buttons not working

Hi All,

In the last view years we haven't used our Westfalia a lot. Regardless of that we are back in repair mode! Well, as I am typing my husband is underneath the camper fixing the leaking gray water valve. But that is not the main issue we are having right now

I was wondering if anybody had problems with their Central Electronic System (the little panel where the mirror is supposed to be showing battery status, fridge, etc)? For a long time turning the fridge on and off was a hit and miss thing. It would take multiple tries to get it to work. And it has gotten worse - now we try turning it on for 10-20 times hoping at some point that it works. Amount of pressure seems to make no difference, the same with the order or sequence you try to press the two buttons. Well, ideally I try to press them simultaneously. Setting the temp control for the fridge works fine.
Turning off has the same problem. So, I use the main electric switch to turn the whole thing off now.

Has anybody had a similar issue, or installed a separate control for the fridge? I am trying to get a new Control Panel from Germany but the whole of the Westfalia company is on summer vacation and I haven't heard back from Manfred Ermel, the other German Westfalia source, in days either. And I couldn't find another source to buy the panel from on the web so far.

Any help or info is appreciated.

Cheers, Claudia
gowestygirl is offline   Reply With Quote
Old 08-09-2019, 02:28 PM   #2
OldWest
T1N Westfalia
 
Join Date: Jul 2009
Posts: 2,026
Thanks: 206
Thanked 590 Times in 445 Posts
Default Re: Central Electronic System - Fridge buttons not working

Repair:

https://sprinter-source.com/forum/sh...hlight=Buttons

Buy:

https://sprinter-source.com/forum/sh...hlight=Central

Other:

https://sprinter-source.com/forum/sh...hlight=Central

Direct Control Alternative:

https://sprinter-source.com/forum/sh...ad.php?t=73358


Please post whatever you find and do. Thanks.

Last edited by OldWest; 08-09-2019 at 02:33 PM. Reason: Fix links.
OldWest is offline   Reply With Quote
The Following User Says Thank You to OldWest For This Useful Post:
gowestygirl (08-10-2019)
Old 08-09-2019, 06:08 PM   #3
Kiltym
 
Join Date: Jan 2015
Posts: 377
Thanks: 42
Thanked 63 Times in 52 Posts
Default Re: Central Electronic System - Fridge buttons not working

If setting temp works fine, and on/off does not, it implies its only the on/off button that is having the issue. Likely the heater wont turn on/off either......?

I would try to take it apart per the onemanvan thread and fix that one button (or all if so inclined). Will likely provide a fix, without ordering anything.
Kiltym is offline   Reply With Quote
The Following User Says Thank You to Kiltym For This Useful Post:
gowestygirl (08-10-2019)
Old 08-10-2019, 01:36 PM   #4
gowestygirl
 
Join Date: Feb 2011
Posts: 6
Thanks: 2
Thanked 8 Times in 2 Posts
Default Re: Central Electronic System - Fridge buttons not working

Thanks OldWest. I did look at some of the links before, esp. the one with attaching the foil to the back of the buttons looked interesting. I am not sure that we have the same problem because pressing harder does not make a difference. I'll post once we have resolved the issue.

Also, just ordered a new Valterra 1 1/2" cableactivated valve and 2 new 4" clamps to fix the gray water tank leak :-)
Cheers, Claudia
gowestygirl is offline   Reply With Quote
Old 08-10-2019, 01:42 PM   #5
gowestygirl
 
Join Date: Feb 2011
Posts: 6
Thanks: 2
Thanked 8 Times in 2 Posts
Default Re: Central Electronic System - Fridge buttons not working

Thanks Kiltym,
Yes, I agree. I think it is the on and off button. The fridge button works (I can adjust temp). I don't know about the heater we have never used it before so it didn't even enter my mind to try turning it on. I am just not sure that the button fix will work because the amount of pressure doesn't seem to be an issue. But considering how expensive a new unit is and the pain to get one delivered we may just fool around with the old one - hopefully not killing it altogether!
gowestygirl is offline   Reply With Quote
Old 08-11-2019, 12:52 AM   #6
gowestygirl
 
Join Date: Feb 2011
Posts: 6
Thanks: 2
Thanked 8 Times in 2 Posts
Default Re: Central Electronic System - Fridge buttons not working

It's FIXED!! Well, at least it is working like a charm now.

Thanks OldWest and Kiltym (and onemanvan for coming up with it) we tried the "stick a little metal dot behind the on/off button" and it worked perfectly. With just a slight pressure it is turning on and off now. Repair was really a 10 min affair. We used the sticky foil tape you use for heating ducts - just because we had it lying around. Not sure if it will stick there long term but for now it is working :-)
gowestygirl is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT. The time now is 03:04 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.