Sprinter-Forum    
 

Go Back   Sprinter-Forum > Sprinter-Based RV's & Conversions > Sprinter-Based RV Brands > Airstream > Interstate


 
Thread Tools Display Modes
Old 05-25-2012, 06:46 PM   #1
Boludo
 
Join Date: Mar 2012
Posts: 42
Thanks: 4
Thanked 3 Times in 2 Posts
Default What's up with my GenSet?

Maybe better said, what's up with me? Can't figure it out.

So I have the Cummins Onan Generator. I believe it's the MicroLite 2800 series. So first of all if I press down on the stop to prime, light doesn't go on showing it primed. If I go to start it, It makes one click and that's it. It's not like when you have a dead battery and it clicks multiple times. It's one louder click and that's it. Generator has 80 hours on it. I checked fuse and oil level and everything there is good. Now first dumb question. Does it have a battery within the generator or does it run off the Aux battery? Second of all, anyone else experience this or know what it might be?
Boludo is offline   Reply With Quote
Old 05-25-2012, 07:14 PM   #2
sailquik
 
sailquik's Avatar
 
Join Date: Mar 2008
Location: Cape Hatteras, North Carolina
Posts: 8,814
Thanks: 3,062
Thanked 5,534 Times in 3,358 Posts
Default Re: What's up with my GenSet?

Boludo,
A couple of "guesses".
It could have it's own starting battery or it could use the AUX battery but most I've seen
have a gen set staring battery so if you run the Aux Battery and the Sprinter starting battery
down, the gen set will still start to charge everything back up.
Are you sure you have every thing in your coach turned off? No appliances plugged in or
turned on if they are hard wired?
Sometimes gen sets will not start if there is a demand already drawing from the system.
Also check the battery disconnect switch (if you have one) to ensure that all the other
batteries are disconnected from the gen set and whatever inverter (s) you may have.
When storing your RV I would think it's best to turn the battery disconnect to OFF so a
bad battery will not discharge all the others. Also a good idea to keep your RV plugged into shore power if you have 110 v 30 amps available.
Then take a digital volt meter and check the charge in each of your batteries.
Engine starting
House or Aux battery
Gen set battery.
All should be at least 11.5-12.5 volts.
If any of the batteries are < 12 volts, get a small trickle charger and bring the voltage
back up in each battery individually.
Also check the resistance of all your ground connections. Should be near 0.00 ohms.
Hope this helps,
Roger
__________________
2014 Sprinter 516 series (3500 DRW) 170"/4325 mm wb Hi Top Short Back
OM-651 I4 2.143 liter two stage turbo charged with 36.9 PSIA MAP Limit Valve
7 Speed 7G-Tronic, manually shiftable, automatic transmission.
Suspension Seats, Active Safety Package +, Parktronic, OEM Hitch/wiring
OEM back up camera, Bi Xenon light package, fog lamps, headlight washers.
Had 2006 T1N 3500/158|2010 NCV3 519/3500/144|2011 & 2012 NCV3 519/3500 170

Last edited by sailquik; 05-25-2012 at 07:19 PM.
sailquik is offline   Reply With Quote
Old 05-25-2012, 07:23 PM   #3
ben322
 
ben322's Avatar
 
Join Date: Oct 2009
Location: Bethesda, MD
Posts: 255
Thanks: 43
Thanked 83 Times in 59 Posts
Default Re: What's up with my GenSet?

The generator uses the house batteries to start. The house batteries must be in the on position for the generator to run, (large red dial rotated clockwise to the 1st position from off). If your Interstate sat on the dealers lot for an extended period, you should check the condition of the batteries. I ended up replacing both batteries with Lifeline 24's at which point I found out that the dip switches for the Tripplite were set incorrectly for AGM batteries. I don't know it this contributed to the early death of the original set but that's water under the bridge now. That said, since your still under warranty, stop by a AS dealer and let them look at it if you still can't get the generator to start.
__________________
2009 Airstream Interstate
2006 E320CDI
2000 F350 CC 4WD Powerstroke
ben322 is offline   Reply With Quote
Old 05-25-2012, 07:55 PM   #4
Boludo
 
Join Date: Mar 2012
Posts: 42
Thanks: 4
Thanked 3 Times in 2 Posts
Default Re: What's up with my GenSet?

Do you guys get a constant buzzing sound when you open the cabinet door to the tripplite (where the dip switches are). I hear a constant buzzing sound from there even when nothing is running or turned on. I even turned off the main large dial switch and buzzing still coming from it.
Anyways my house battery is at 12.38. I made sure nothing was on. I may just run this to the dealer but I have had nothing but problems over there and the next closest one in SoCal is too far.
Boludo is offline   Reply With Quote
Old 05-25-2012, 09:02 PM   #5
ben322
 
ben322's Avatar
 
Join Date: Oct 2009
Location: Bethesda, MD
Posts: 255
Thanks: 43
Thanked 83 Times in 59 Posts
Default Re: What's up with my GenSet?

Constant buzzing is not normal. Check your Tripplite manual for correct dip switch position, (assuming you know what type of batteries came installed). 12.38V should be fine with nothing on it. A final check might be to pop the panel off the generator, (easy with 2 slide latches), and make sure the rocker switch is set to run and not off but since you had it running before this should not be a problem. You could also call/email Tripplite to see what their diagnosis would be for the buzzing.
__________________
2009 Airstream Interstate
2006 E320CDI
2000 F350 CC 4WD Powerstroke
ben322 is offline   Reply With Quote
Old 05-25-2012, 10:11 PM   #6
Boludo
 
Join Date: Mar 2012
Posts: 42
Thanks: 4
Thanked 3 Times in 2 Posts
Default Re: What's up with my GenSet?

So a few things I've observed.
1. dip switches are correct
2. on the TRIPP-LITE in the overhead cabinet where it says RV Inverter/Charger, you have 2 options to switch to. You can flip switch to left which is Auto/Invert. You can turn switch to the right which is Line/Charge Only. What do you guys have yours on when it's in use? When it's flipped on the left it makes that buzzing sound from the unit where the dip switches are. When it's on the right it does not make a buzzing sound.
3. I've attached a picture which shows green lights when switched to the right. However this picture was from a month ago. Now if it's switched to the right, there are no lights at all.

Sounds like I just need to take this in to the dealer.
Thanks guys for all your help. I will also call Tripp-Lite to see what they say.
Attached Images
File Type: jpg Tripp-Lite.JPG (127.8 KB, 74 views)
Boludo is offline   Reply With Quote
Old 05-26-2012, 02:32 AM   #7
ben322
 
ben322's Avatar
 
Join Date: Oct 2009
Location: Bethesda, MD
Posts: 255
Thanks: 43
Thanked 83 Times in 59 Posts
Default Re: What's up with my GenSet?

We only use the auto invert when we need AC power, otherwise it's always in line charge mode. When the house batteries are on, the pump, lights, fridge will all work so no need to use the converter.
__________________
2009 Airstream Interstate
2006 E320CDI
2000 F350 CC 4WD Powerstroke
ben322 is offline   Reply With Quote
Old 05-26-2012, 06:06 AM   #8
Boludo
 
Join Date: Mar 2012
Posts: 42
Thanks: 4
Thanked 3 Times in 2 Posts
Default Re: What's up with my GenSet?

Quote:
Originally Posted by ben322 View Post
We only use the auto invert when we need AC power, otherwise it's always in line charge mode. When the house batteries are on, the pump, lights, fridge will all work so no need to use the converter.
Ben, That's good to know. I'm knew at all this so this kind of stuff is very helpful. How about when running the microwave? Do you switch to auto invert?

Thanks!
Boludo is offline   Reply With Quote
Old 05-26-2012, 12:56 PM   #9
ben322
 
ben322's Avatar
 
Join Date: Oct 2009
Location: Bethesda, MD
Posts: 255
Thanks: 43
Thanked 83 Times in 59 Posts
Default Re: What's up with my GenSet?

On edit: I meant inverter, not converter.

You'll need to run the generator or be connected to shore power to run the microwave. Only on the generator will you need to invert as shore power will provide AC.
__________________
2009 Airstream Interstate
2006 E320CDI
2000 F350 CC 4WD Powerstroke
ben322 is offline   Reply With Quote
Old 09-01-2012, 02:20 AM   #10
garageguy
 
Join Date: Sep 2012
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default Just got a 2008 interstae. What is the correct procedure for set up shore power

steps to set un shore power. also what does the red switch do behind the passenger seat by the sliding door.
can tell i just got it.
Thanks
garageguy
garageguy is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT. The time now is 09:22 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.