Sprinter-Forum    
 

Go Back   Sprinter-Forum > Regional Discussions > Australia, New Zealand, and Asia Pacific


 
Thread Tools Display Modes
Old 11-01-2013, 07:54 AM   #11
NORTON
 
Join Date: Jan 2011
Location: adelaide south australia
Posts: 530
Thanks: 87
Thanked 257 Times in 190 Posts
Default Re: Hi New guy here new member with sprintshift problems on a 316 EX ambo 03 Model

As Iggy suggested a Star Diagnosis is a good place to start and can give data on the hydraulic operation.
If the vehicle is not needed for work or your transport it would be worthwhile trying to repair it yourself.
How long does the pump run when first activated after standing for few hours? other members have said that 10 seconds is a sign of a failing pump
Are there any oil leaks around the rear end of the box, hydraulic circuit.
Did the oil level get checked for the hydraulic circuit?
I would do as Eric suggested but I use electrical contact cleaner as it leaves no residue,on any connections that you can access around the box, especially The Gearbox Hydraulic Pressure Sender which is located at front of the Accumulater, they are a bit difficult to do as there are 2 clips that have to be depressed while wriggling to loosen it.
These are posibillities but worth trying.
Look in T1n data base for 'Sprintshift Gearbox Design and Function' page 35, 53 and 32-33 to see those components. If you need info about checking the gearbox hydraulic level I can advise.
If it went to the dealer they should?? be doing this while charging like a wounded bull.
murray
NORTON is offline   Reply With Quote
The Following User Says Thank You to NORTON For This Useful Post:
316 Wollongong guy (11-01-2013)
Old 11-01-2013, 08:57 AM   #12
316 Wollongong guy
 
Join Date: Oct 2013
Posts: 51
Thanks: 23
Thanked 5 Times in 4 Posts
Default Re: Hi New guy here new member with sprintshift problems on a 316 EX ambo 03 Model

Hi norton I have used contact cleaner on the plugs as discussed there doesn't appear to be any oil leaks anywhere there

The pump does run for a few seconds not 10 more like 6-7

The dealer it was at (who can't be named) did do oil level with the new pump and the old and the oil is new the dealer it was at says according to star there's nothing wrong with it which is why I'm hesitant to take it to another stealer ship who doesn't understand sprintshift as my local MBA dealer is definitely more of a car dealer rather than commercial

It isn't my main mode of transport so going to try repair it myself if I can ( I do have access to a hoist and a fairly full range of tools)

It's just the diagnosis I need to get sorted and don't get me wrong I don't want it for free I just don't want to pay anyone else who doesn't know what there looking at

I will try all the plugs again tomorrow just for my own curiosity again
__________________
2003 316 CDI Ex Ambo Sprinter with sprintshift doing DIY camper for 3
316 Wollongong guy is offline   Reply With Quote
Old 11-01-2013, 11:10 AM   #13
NORTON
 
Join Date: Jan 2011
Location: adelaide south australia
Posts: 530
Thanks: 87
Thanked 257 Times in 190 Posts
Default Re: Hi New guy here new member with sprintshift problems on a 316 EX ambo 03 Model

I just tried mine [ex ambo 316 2001] and the pump cycles after 2 shifts and you can hear the shifter working, engaging the gears.
As far as the hydraulic oil level, it is not a simple procedure as the 'control' plug on the bottom of the unit does not give an indication of the oil level, when removed a small amount of oil will be present ,this is due to driving conditions causing some oil to enter the riser tube which controls the correct amount when adding oil, so you have to add oil till it flows out.
I would assume that they followed correct procedure as MB workshops have the WIS which explains step by step method
There is a Transmission control unit under the drivers seat, might pay to check the connections
When you say it wont select any gears do mean displaying the selected gear on the dash or selecting the gear in the box?
murray
NORTON is offline   Reply With Quote
Old 11-01-2013, 08:25 PM   #14
316 Wollongong guy
 
Join Date: Oct 2013
Posts: 51
Thanks: 23
Thanked 5 Times in 4 Posts
Default Re: Hi New guy here new member with sprintshift problems on a 316 EX ambo 03 Model

It won't select any gears in the box or change on the display most times when you move the shifter the dash doesn't change at all the pump cycles but no gear engages and the dash stays on N every so often when you move the shifter the n will begin to flash and then go F
__________________
2003 316 CDI Ex Ambo Sprinter with sprintshift doing DIY camper for 3
316 Wollongong guy is offline   Reply With Quote
Old 11-02-2013, 01:22 AM   #15
Iggy66
 
Join Date: Mar 2007
Location: Central Coast NSW
Posts: 236
Thanks: 43
Thanked 91 Times in 74 Posts
Default Re: Hi New guy here new member with sprintshift problems on a 316 EX ambo 03 Model

Possibly sounds like you might not be building any hydraulic pressure, the pump will turn off if no increase in pressure is evident from the sensor to protect the pump from burning out.

The other clue possibly pointing to this is the low pressure error code you had in the beginning.

This doesn't mean it's the pump, it could be the pressure sensor or the accumulator or a wiring fault.

Cheers, Iggy
Iggy66 is offline   Reply With Quote
Old 11-02-2013, 02:01 AM   #16
316 Wollongong guy
 
Join Date: Oct 2013
Posts: 51
Thanks: 23
Thanked 5 Times in 4 Posts
Default Re: Hi New guy here new member with sprintshift problems on a 316 EX ambo 03 Model

My next guess was accumulator or pressure sensor but as stated before don't really want to guess is either of those a cheap product to replace?
__________________
2003 316 CDI Ex Ambo Sprinter with sprintshift doing DIY camper for 3
316 Wollongong guy is offline   Reply With Quote
Old 11-02-2013, 08:31 AM   #17
NORTON
 
Join Date: Jan 2011
Location: adelaide south australia
Posts: 530
Thanks: 87
Thanked 257 Times in 190 Posts
Default Re: Hi New guy here new member with sprintshift problems on a 316 EX ambo 03 Model

I think that Iggy is on the right track, but without a Star diagnosis its a worry.
When my sprintshift was on Star it listed at least 6 possible causes to the clutch problem ,so there is a good possibility there were others for you
To depressurise the hydraulic circuit I disconnected sprintshift pump at the connection and it took 18 gear selections to cease operating, this would be a way of testing the accummulator, but as yours wont select gears it should not be any use, and you dont know what pressure was there to begin.
VANWORKS 08 83497446 in Adelaide specialise in Sprinter repairs and parts, so they have hands on experience, maybe a phone call enquiring about the parts and explaining the problems they might have some ideas, their prices have been good as well

murray
NORTON is offline   Reply With Quote
Old 11-02-2013, 08:06 PM   #18
Charliektm400exc
316 Ex Ambulance 2002
 
Join Date: Jun 2011
Location: Hobart
Posts: 152
Thanks: 75
Thanked 41 Times in 40 Posts
Default Re: Hi New guy here new member with sprintshift problems on a 316 EX ambo 03 Model

Another option for you on finding some help with diagnosing problem is based on the fact it's an ex-ambulance. Go and see your local ambos and see if they can tell you who did the service work for them. Even if it's in house, you might be able to get to talk to one of the mechanics who could put you on the right track.

Charlie
Charliektm400exc is online now   Reply With Quote
Old 11-03-2013, 10:04 AM   #19
Eric Experience
 
Eric Experience's Avatar
 
Join Date: Aug 2008
Location: Victoria Australia
Posts: 3,010
Thanks: 115
Thanked 1,669 Times in 1,098 Posts
Default Re: Hi New guy here new member with sprintshift problems on a 316 EX ambo 03 Model

Woolongong
I like the way you think, not wanting to change parts in a random way. My way of solving problems is to describe the system first.
My description is a mechanical system controlled by a hydraulic system controlled by an analog electrical system controlled by a digital electrical system controlled by the driver. We need to find which system is broken. From reading the post so far the hydraulic pressure is suspect. from what I have read the pump runs when you open the door then switches of. We need to know if the pump turns off because it has done its job or because it times out. I think the pressure would drop over time so if the pressure is there when you cycle the pump it should run for a time related to how much the pressure has dropped. That is if you hear the pump for 10 seconds and then after a few seconds run the pump again it should only run for say 5 seconds. If it runs for the same 10 seconds again then it must be timing out. Eric.
Eric Experience is offline   Reply With Quote
The Following User Says Thank You to Eric Experience For This Useful Post:
316 Wollongong guy (11-03-2013)
Old 11-03-2013, 10:05 AM   #20
316 Wollongong guy
 
Join Date: Oct 2013
Posts: 51
Thanks: 23
Thanked 5 Times in 4 Posts
Default Re: Hi New guy here new member with sprintshift problems on a 316 EX ambo 03 Model

It always runs for ailing time never short so I suspect your right not enough hydraulics if pressure
__________________
2003 316 CDI Ex Ambo Sprinter with sprintshift doing DIY camper for 3
316 Wollongong guy is offline   Reply With Quote

Tags
ambulance, auto, gearbox, sprintshift

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT. The time now is 09:56 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.