Sprinter-Forum    
 

Go Back   Sprinter-Forum > T1N Sprinters > T1N Talk

T1N Talk General Discussions related to T1N Sprinters.


 
Thread Tools Display Modes
Old 11-12-2016, 04:39 PM   #1
superstardj
 
Join Date: Apr 2012
Location: Montreal, Canada
Posts: 87
Thanks: 189
Thanked 20 Times in 14 Posts
Default Check engine light now gone...dont know why !

I had a glow plug issue , one glow plug was to be replaced so we did that and changed the glow plug module also.
Deleted the codes and got a Monitor incomplete from EGR vavle :((

after doing that got two new glow plug codes r17 and r16 and an oxygen sensor code, so decided to go and change the oxygen sensor. did that this morning and deleted the codes ( who cares the mechanic did and i will have to get a green diesel engineering anyway to get rid of the monitor incomplete !

went for a ride and now all codes are gone and i got 0 incomplete monitors !!

can somebody explain to me what the hell happened

Thanks
superstardj is offline   Reply With Quote
Old 11-12-2016, 06:13 PM   #2
lindenengineering
 
Join Date: Dec 2009
Location: Littleton Colorado
Posts: 13,567
Thanks: 3,368
Thanked 11,316 Times in 5,751 Posts
Default Re: Check engine light now gone...dont know why !

Quote:
Originally Posted by superstardj View Post
I had a glow plug issue , one glow plug was to be replaced so we did that and changed the glow plug module also.
Deleted the codes and got a Monitor incomplete from EGR vavle :((

after doing that got two new glow plug codes r17 and r16 and an oxygen sensor code, so decided to go and change the oxygen sensor. did that this morning and deleted the codes ( who cares the mechanic did and i will have to get a green diesel engineering anyway to get rid of the monitor incomplete !

went for a ride and now all codes are gone and i got 0 incomplete monitors !!

can somebody explain to me what the hell happened

Thanks
Well basically you eliminated by fair means, foul or simply throwing parts at it and then taking it for a test drive! You got all the parameters to jive, it then closed the monitors and got no fault.

The trick as a Pro in this business is to understand the live data put your finger on the problem; then simply fix it and close the monitors.

So are you going to leave it as it is now or spend $600 for something that you don't need.
Or with that cas are you going to buy MB emblems and bedeck it with something is also doesn't need to make it run properly?

All the best
Dennis
lindenengineering is online now   Reply With Quote
The Following User Says Thank You to lindenengineering For This Useful Post:
superstardj (11-12-2016)
Old 11-12-2016, 08:25 PM   #3
superstardj
 
Join Date: Apr 2012
Location: Montreal, Canada
Posts: 87
Thanks: 189
Thanked 20 Times in 14 Posts
Default Re: Check engine light now gone...dont know why !

so basically all the stars where in line !! will definetly pimp it now that its mecanically perfect....i just have a small problem with the brake pedal at low speed, it just vibrates from abs. might be a stuck caliper ?
superstardj is offline   Reply With Quote
Old 11-12-2016, 08:35 PM   #4
lindenengineering
 
Join Date: Dec 2009
Location: Littleton Colorado
Posts: 13,567
Thanks: 3,368
Thanked 11,316 Times in 5,751 Posts
Default Re: Check engine light now gone...dont know why !

Quote:
Originally Posted by superstardj View Post
so basically all the stars where in line !! will definetly pimp it now that its mecanically perfect....i just have a small problem with the brake pedal at low speed, it just vibrates from abs. might be a stuck caliper ?
just vibrates from ab[/B]
Check the air gap on your front brake ABS sensors!
Having a habit of walking out it will case that symptom.
Simply tap them back in to contact the tone ring!
Then try it out again
Dennis
lindenengineering is online now   Reply With Quote
The Following User Says Thank You to lindenengineering For This Useful Post:
superstardj (11-13-2016)
Old 11-14-2016, 04:55 PM   #5
superstardj
 
Join Date: Apr 2012
Location: Montreal, Canada
Posts: 87
Thanks: 189
Thanked 20 Times in 14 Posts
Default Re: Check engine light now gone...dont know why !

funny thing happenned this morning on second start : MIL came on and i read the codes, it showed 3 codes for glow plugs but stored !! weird i still dont understand this truck
the codes are not current and if i delete them they wont come back until a few days...any clues ? i hate to have to clear codes all the time
superstardj is offline   Reply With Quote
Old 11-14-2016, 05:13 PM   #6
lindenengineering
 
Join Date: Dec 2009
Location: Littleton Colorado
Posts: 13,567
Thanks: 3,368
Thanked 11,316 Times in 5,751 Posts
Default Re: Check engine light now gone...dont know why !

Don't delete!
If you do that you will open all the monitors.
Having stored codes is OK! The light should go out after a few successful starts with no glow active plug faults.
Tackle the issue in isolation by all means but keep your finger off the delete codes button.
Dennis
lindenengineering is online now   Reply With Quote
The Following User Says Thank You to lindenengineering For This Useful Post:
superstardj (11-15-2016)

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT. The time now is 09:23 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.