Sprinter-Forum    
 

Go Back   Sprinter-Forum > NCV3 Sprinters > NCV3 Talk

NCV3 Talk General Discussions related to NCV3 Sprinters.


 
Thread Tools Display Modes
Old 04-17-2019, 03:49 PM   #1
bensalvage
 
Join Date: Dec 2018
Posts: 6
Thanks: 3
Thanked 4 Times in 2 Posts
Default “M” button on dash doesn’t function

I have a 2007 sprinter with the standard dash. Since buying it used the M button doesn’t work. I’ve pulled the battery to reset but it still doesn’t work. Any ideas? Replace the whole dash?
bensalvage is offline   Reply With Quote
Old 04-17-2019, 04:07 PM   #2
NelsonSprinter
Former Nelson BC Sprinter
 
NelsonSprinter's Avatar
 
Join Date: Apr 2010
Location: Nelson, Kootenay Rockies, BC, Canada
Posts: 3,816
Thanks: 495
Thanked 1,058 Times in 822 Posts
Default Re: “M” button on dash doesn’t function

Are you pressing the O button first for 30 seconds to open the menu ?
__________________
Previous owner of '02 FL 2500 140WB Cargo door windows, 15" Alloys, LT235/75R15-E Nokian Rotiivas, Nokian Hakka C studded winters, Curt 4 hitch, 3.72 rear with 30MPG Cdn GDE ECO Tuned. . .
I am NOT a MECHANIC, I just play one online.

'02-'03 Fuel filter leak fix http://sprinter-source.com/forum/sho...ix+fuel+filter
15" tire options http://sprinter-source.com/forum/sho...t=tire+options
NelsonSprinter is offline   Reply With Quote
Old 04-17-2019, 05:06 PM   #3
sparkplug
 
Join Date: Feb 2015
Location: UK
Posts: 78
Thanks: 13
Thanked 28 Times in 24 Posts
Default Re: “M” button on dash doesn’t function

I bought a secondhand instrument cluster as I thought mine might be faulty (headlight warning buzzer didn't work, but it turned out to be something else) and when fitting it I discovered that someone had obviously been a bit heavy handed and had snapped the plastic stem which pushes down onto the actual switch.

Easy thing to check. I can't remember which side was broken on mine so it's a 50/50 chance that I've got a spare which you would be welcome to!

Let me know if that's the fault and I'll dig through my parts bin to see if I can help you out
__________________
MWB 2008 Mercedes Sprinter 311 CDi (UK RHD) in the faster DHL Yellow colour
sparkplug is online now   Reply With Quote
Old 04-17-2019, 09:33 PM   #4
Düsseldorfer
 
Düsseldorfer's Avatar
 
Join Date: Dec 2008
Location: PNW
Posts: 417
Thanks: 117
Thanked 271 Times in 134 Posts
Default Re: “M” button on dash doesn’t function

Quote:
Originally Posted by NelsonSprinter View Post
Are you pressing the O button first for 30 seconds to open the menu ?
It works differently on an early NCV3, Nelson: pressing M also scrolls you through different simple options, like setting the clock or recalibrating TPMS, in addition to the hidden oil service etc reset menus.

I think Sparkplug might be on to something, Ben. Of course the worst case is that some gorilla broke the microswitch on the instrument panel circuit board... but start by investigating the button first, as he suggests. Replacing the instrument panel (circuit board & gauges) is a dealer job I think -- I believe it needs coding with a top-level scan tool. (Someone correct me if I'm wrong.)
Düsseldorfer is offline   Reply With Quote
Old 04-18-2019, 01:41 AM   #5
NelsonSprinter
Former Nelson BC Sprinter
 
NelsonSprinter's Avatar
 
Join Date: Apr 2010
Location: Nelson, Kootenay Rockies, BC, Canada
Posts: 3,816
Thanks: 495
Thanked 1,058 Times in 822 Posts
Default Re: “M” button on dash doesn’t function

Quote:
Originally Posted by Düsseldorfer View Post
It works differently on an early NCV3, Nelson: pressing M also scrolls you through different simple options, like setting the clock or recalibrating TPMS, in addition to the hidden oil service etc reset menus.

I think Sparkplug might be on to something, Ben. Of course the worst case is that some gorilla broke the microswitch on the instrument panel circuit board... but start by investigating the button first, as he suggests. Replacing the instrument panel (circuit board & gauges) is a dealer job I think -- I believe it needs coding with a top-level scan tool. (Someone correct me if I'm wrong.)
I understand what the M should do, but the instructions I saw said to press the O for 30 seconds first then scrolling thru M works , I guess they got it wrong http://resetservicelight.com/reset-s...edes-sprinter/
__________________
Previous owner of '02 FL 2500 140WB Cargo door windows, 15" Alloys, LT235/75R15-E Nokian Rotiivas, Nokian Hakka C studded winters, Curt 4 hitch, 3.72 rear with 30MPG Cdn GDE ECO Tuned. . .
I am NOT a MECHANIC, I just play one online.

'02-'03 Fuel filter leak fix http://sprinter-source.com/forum/sho...ix+fuel+filter
15" tire options http://sprinter-source.com/forum/sho...t=tire+options

Last edited by NelsonSprinter; 04-18-2019 at 01:45 AM.
NelsonSprinter is offline   Reply With Quote
Old 04-18-2019, 02:07 AM   #6
Düsseldorfer
 
Düsseldorfer's Avatar
 
Join Date: Dec 2008
Location: PNW
Posts: 417
Thanks: 117
Thanked 271 Times in 134 Posts
Default Re: “M” button on dash doesn’t function

Quote:
Originally Posted by NelsonSprinter View Post
I understand what the M should do, but the instructions I saw said to press the O for 30 seconds first then scrolling thru M works , I guess they got it wrong
No, that's right, I'm just saying that the M button does other things that would immediately tell Ben that it didn't work.
Düsseldorfer is offline   Reply With Quote
The Following User Says Thank You to Düsseldorfer For This Useful Post:
NelsonSprinter (04-18-2019)
Old 04-18-2019, 07:22 AM   #7
sparkplug
 
Join Date: Feb 2015
Location: UK
Posts: 78
Thanks: 13
Thanked 28 Times in 24 Posts
Default Re: “M” button on dash doesn’t function

Quote:
Originally Posted by Düsseldorfer View Post
Replacing the instrument panel (circuit board & gauges) is a dealer job I think -- I believe it needs coding with a top-level scan tool. (Someone correct me if I'm wrong.)
It didn't need any diagnostic tools or dealership intervention for me.

I simply removed the old one and plugged in the new one.

After a few seconds and some odd noises it all fired up and displayed my mileage etc just as the old one did.

Simple job.
__________________
MWB 2008 Mercedes Sprinter 311 CDi (UK RHD) in the faster DHL Yellow colour
sparkplug is online now   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT. The time now is 11:10 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.