Sprinter-Forum    
 

Go Back   Sprinter-Forum > T1N Sprinters > T1N Talk

T1N Talk General Discussions related to T1N Sprinters.


 
Thread Tools Display Modes
Old 01-21-2020, 07:22 PM   #21
dbeyer
 
dbeyer's Avatar
 
Join Date: Oct 2006
Location: South New Jersey
Posts: 181
Thanks: 109
Thanked 33 Times in 20 Posts
Default Re: Engine stops on freeway I stuck on shoulder

Quote:
Originally Posted by Midwestdrifter View Post
Fuel volume regulator control circuit low

Do you have the code number for this?



P0091 & P0003


When you turn the ignition to start, does anything happen at all?


No



Does the MBII let you monitor the start process on the ECM live data? You can check to see if the start signal is reaching the ECM.

Not sure my buddy lent it to me. Control module voltage is 7.9V but doesn't change when I turn ignition to start position.
__________________
2004 - 118" Standard Roof Cargo
Converted to Mobile Office

Last edited by dbeyer; 01-21-2020 at 08:11 PM.
dbeyer is offline   Reply With Quote
Old 01-21-2020, 08:46 PM   #22
autostaretx
Erratic Member
 
autostaretx's Avatar
 
Join Date: Sep 2006
Location: Seattle
Posts: 18,234
Thanks: 3,183
Thanked 8,354 Times in 6,066 Posts
Default Re: Engine stops on freeway I stuck on shoulder

Just to double check: you DID open the fuse block that is bolted on to the battery's positive terminal?



I would also highly suspect the ECM relay that is on the bottom of the steering column's fuse block:
(item (2) in this drawing)



I think you can swap it with another relay for testing (its coil may be bad, its internal contacts could be dirty)

Another area of frequent failure is where the engine's wiring harness bends behind the fuel filter. Cutting the plastic Ty-Wrap lets you "soften" the bend and massage the wiring bundle. If symptoms change after that, you may have located the problem.

good luck
--dick
__________________
2005 T1N 118" Freightliner 2500 Passenger Wagon (2.7L, 15" tires, standard (short) roof)
Get YOUR Sprinter's full configuration datacard by entering your VIN to https://www.datamb.com/
http://diysprinter.co.uk/reference <-- lots of service documentation, Thanks to Jens Moller and Arnie_Oli
((as always: this post may go through a couple of post-posting edits... so maybe give it ten minutes before commenting))
autostaretx is online now   Reply With Quote
Old 01-21-2020, 09:01 PM   #23
CJPJ
2008 3500 170"ext. 3.0 V6
 
CJPJ's Avatar
 
Join Date: May 2010
Location: Contra Costa California, Douglas County, Oregon
Posts: 4,166
Thanks: 4,173
Thanked 2,202 Times in 1,451 Posts
Default Re: Engine stops on freeway I stuck on shoulder

That isn't right, .. the thirteen prong transmission cable connector o-ring seal is leaking and the oil is wicking up the wires and affecting the Tcm.
Quote:
.. and module connections. TCM plugs had oil on the inside of the plugs otherwise everything looked good.
https://europarts-sd.com/transmissio...g2002-2008.asp

Last edited by CJPJ; 01-21-2020 at 09:11 PM.
CJPJ is online now   Reply With Quote
Old 01-21-2020, 11:38 PM   #24
Patrick of M
2005 T1N 2500 (NA spec)
 
Join Date: Apr 2017
Location: Montreal
Posts: 1,497
Thanks: 550
Thanked 669 Times in 485 Posts
Default Re: Engine stops on freeway I stuck on shoulder

Fwiw the actual key switch can be a weak link. It is a mechanical switch with contact points and they can fail. Perhaps check for current flow through the key switch in its various positions. Ie 12v in, then in different key positions there will be 12v out...key switches have messed me up plenty over the years on older vehicles.
__________________
Patrick of Montreal
2005 T1N (NA spec).
Patrick of M is offline   Reply With Quote
Old 01-22-2020, 03:13 PM   #25
Aqua Puttana
Poly - Thread Finder
 
Aqua Puttana's Avatar
 
Join Date: Apr 2008
Location: The Falls of Niagara, USA
Posts: 25,675
Thanks: 13,393
Thanked 14,587 Times in 9,266 Posts
Default Re: Engine stops on freeway I stuck on shoulder

Being that "check this, try that" didn't work, it will come down to systematic troubleshooting.

There is a bunch of information contained in this thread that relates to circuit troubleshooting and schematics. It isn't just Click no start.

https://sprinter-source.com/forum/sh...ad.php?t=58993

vic
__________________
DAD NAS (N. Amer. Spec) 2004 140 2500 >330,000+ mi. Arctic Whitewash Brush-tone Grey
2006 Freightliner 140 2500HC >183,000+ mi. Arctic Whitewash (Spotted Snow Leopard accents)
"My opinion and worth everything you'll never pay for it." assumed.
Anyone can hold the helm when the sea is calm. Publilius Syrus
"There are only 10 types of people in the world: Those who understand binary, and those who don't." HaWiiLuVeR
16 ounces of unnecessary prevention can be worth a pound of manure.
Aqua Puttana is offline   Reply With Quote
Old 01-22-2020, 04:45 PM   #26
dbeyer
 
dbeyer's Avatar
 
Join Date: Oct 2006
Location: South New Jersey
Posts: 181
Thanks: 109
Thanked 33 Times in 20 Posts
Default Re: Engine stops on freeway I stuck on shoulder

[QUOTE=autostaretx;842982]Just to double check: you DID open the fuse block that is bolted on to the battery's positive terminal?


Yes inspected fuses and have 12 volts on both sides of the fuses.


I would also highly suspect the ECM relay that is on the bottom of the steering column's fuse block:
(item (2) in this drawing)
I think you can swap it with another relay for testing (its coil may be bad, its internal contacts could be dirty)


Switched the relays as you suggested.


Another area of frequent failure is where the engine's wiring harness bends behind the fuel filter. Cutting the plastic Ty-Wrap lets you "soften" the bend and massage the wiring bundle. If symptoms change after that, you may have located the problem.


Inspected wiring harness and moved around without any change.
__________________
2004 - 118" Standard Roof Cargo
Converted to Mobile Office
dbeyer is offline   Reply With Quote
Old 01-22-2020, 04:48 PM   #27
Midwestdrifter
 
Join Date: Sep 2013
Location: Charlotte NC
Posts: 11,374
Thanks: 2,238
Thanked 7,541 Times in 4,770 Posts
Default Re: Engine stops on freeway I stuck on shoulder

Time to get down to troubleshooting in a methodical way. Test the ECM, SKREEM, and Cluster for power at there connectors. If so, move on to communication. Can the scanner connect to each of these modules. If so, move on to start sequence. Confirm ignition switch signal, SKREEM handshake, and then move on to starter. Since the unit stalled, I don't believe you will get this far. You either have a wiring fault causing the stall, or a sudden failure of the ECM (very rare).
__________________
2004 T1N | Overland Conversion in Process Completed...For now... | 187,000 miles | 140" | High Roof | My Build Thread
Another Random Blog | http://VagariesAbound.blogspot.com
Midwestdrifter is offline   Reply With Quote
Old 01-22-2020, 04:54 PM   #28
dbeyer
 
dbeyer's Avatar
 
Join Date: Oct 2006
Location: South New Jersey
Posts: 181
Thanks: 109
Thanked 33 Times in 20 Posts
Default Re: Engine stops on freeway I stuck on shoulder

Quote:
Originally Posted by CJPJ View Post
That isn't right, .. the thirteen prong transmission cable connector o-ring seal is leaking and the oil is wicking up the wires and affecting the Tcm.

https://europarts-sd.com/transmissio...g2002-2008.asp
thanks, I ordered the transmission cable connector.


Do you think this caused the engine to die while traveling 60 MPH on freeway and now is the cause of no starter spinning at all?
__________________
2004 - 118" Standard Roof Cargo
Converted to Mobile Office
dbeyer is offline   Reply With Quote
Old 01-22-2020, 04:58 PM   #29
Midwestdrifter
 
Join Date: Sep 2013
Location: Charlotte NC
Posts: 11,374
Thanks: 2,238
Thanked 7,541 Times in 4,770 Posts
Default Re: Engine stops on freeway I stuck on shoulder

Quote:
Originally Posted by dbeyer View Post
...
Do you think this caused the engine to die while traveling 60 MPH on freeway and now is the cause of no starter spinning at all?
Not likely. I have never seen a trans issue cause stalling like that, and fail to restart. The CANbus wires do run through that connector, so its possible it could prevent a start by blocking communication (not likely).

Even if this was the case, unplugging the connector should then allow a start.
__________________
2004 T1N | Overland Conversion in Process Completed...For now... | 187,000 miles | 140" | High Roof | My Build Thread
Another Random Blog | http://VagariesAbound.blogspot.com
Midwestdrifter is offline   Reply With Quote
Old 01-22-2020, 05:24 PM   #30
CJPJ
2008 3500 170"ext. 3.0 V6
 
CJPJ's Avatar
 
Join Date: May 2010
Location: Contra Costa California, Douglas County, Oregon
Posts: 4,166
Thanks: 4,173
Thanked 2,202 Times in 1,451 Posts
Default Re: Engine stops on freeway I stuck on shoulder

I don't know that. The connector seal failure is common here on this forum(with oil wiking damaging the Tcm) with Mb vehicles. I'm on the third connector but corrected the leak befor the wicking. I saw a wet connector and replaced it.
Suggest watching the u-tube video, shown on the euro parts link ..how to clean and replace.
Quote:
Originally Posted by dbeyer View Post
thanks, I ordered the transmission cable connector.

Do you think this caused the engine to die while traveling 60 MPH on freeway and now is the cause of no starter spinning at all?
https://sprinter-source.com/forum/sh...or+leaking+oil

Last edited by CJPJ; 01-22-2020 at 05:58 PM.
CJPJ is online now   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT. The time now is 03:59 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.