Sprinter-Forum    
 

Go Back   Sprinter-Forum > Sprinter-Based RV's & Conversions > Sprinter-Based RV Brands > Leisure Travel Vans > Free Spirit


 
Thread Tools Display Modes
Old 05-25-2019, 04:35 AM   #1
Tahoe Dave
 
Join Date: Aug 2016
Posts: 21
Thanks: 3
Thanked 2 Times in 2 Posts
Default Outlets and Microwave not working?

Could use some help on diagnosing the following problem on my 2013 Free Spirit SS...

(1) Not one of the 4 outlets are hot and I cannot reset the 2 that are Ground Fault outlets
(2) The Microwave doesn't work and it's breaker resets and appears to be okay

Any help/hints are greatly appreciated...

Dave
Tahoe Dave is offline   Reply With Quote
Old 06-08-2019, 04:29 PM   #2
h2oxtc
 
Join Date: Sep 2018
Location: British Columbia
Posts: 4
Thanks: 1
Thanked 1 Time in 1 Post
Default Re: Outlets and Microwave not working?

Were you able to solve the power issue?
h2oxtc is offline   Reply With Quote
Old 06-13-2019, 02:38 PM   #3
Tahoe Dave
 
Join Date: Aug 2016
Posts: 21
Thanks: 3
Thanked 2 Times in 2 Posts
Default Re: Outlets and Microwave not working?

Yes and thanks for asking. It turns out that the breaker for my locking extension cord to the Sprinter had tripped. This, in turn prevented the reset on all of the rigs GFI outlets.
Tahoe Dave is offline   Reply With Quote
The Following User Says Thank You to Tahoe Dave For This Useful Post:
autostaretx (06-13-2019)

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT. The time now is 03:58 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.