Sprinter-Forum    
 

Go Back   Sprinter-Forum > Regional Discussions > Europe


 
Thread Tools Display Modes
Old 05-11-2010, 03:20 PM   #1
3SIXTY
 
Join Date: May 2010
Posts: 7
Thanks: 2
Thanked 1 Time in 1 Post
Default 02 311 CDI clunking and tapping only under acceleration....?

Heya everyone,

I've just spent an hour looking around this forum as a new member and can see this place will be a great resource in future... however I haven't found any posts relating to my particular problem so here goes:

Vehicle: 2002 311 CDI with 170K on the clock

I have a tapping and clunking sound coming from the engine bay whilst under acceleration, the slightest touch of the accelerator introduces this noise which increases with the revs...

The noise disappears when I step off the power or when in neutral.

There was a lack of power but the garage fitted a new transducer valve, heat plugs and fixed a fault that had an oil symbol flashing on the dash with 'HI' flashing underneath it... which has it running like a dream, apart from this noise... the garage also claimed the noise was being caused by a badly fitted exhaust which they have fixed but none of this work has fixed the noise...

As I say she's driving lovely at the minute so I wonder whether theres any real cause for worry but tapping and clunking rings my alarm bells every time!

Any help on offer would be greatly appreciated, please help!

many thanks, Ian

PS: I just spoke to the garage and they say they ran a full diagnostic and the only stored codes that came up reported that the transducer valve and the heat plugs needed replacing. No other codes came up... so they think the vehicle is fine...

Last edited by 3SIXTY; 05-11-2010 at 03:59 PM. Reason: extra info
3SIXTY is offline   Reply With Quote
Old 05-12-2010, 11:29 AM   #2
3SIXTY
 
Join Date: May 2010
Posts: 7
Thanks: 2
Thanked 1 Time in 1 Post
Default Re: 02 311 CDI clunking and tapping only under acceleration....?

Anyone have any ideas what could be happening here?!?! Just to be clear the tapping and clunking doesn't seem to dramatic, its almost as if there is just something loose in the engine bay, or a belt/fan rubbing or something... i have tried checking for loose parts but after fettling and tightening the noise is still there...

Am i right in thinking that because the noise only happens under acceleration and not at any other time while in gear then it cant be a serious cause deep within the engine? as that sort of noise would be constant when the engine is turning?

Please help!!!

Ian
3SIXTY is offline   Reply With Quote
Old 05-12-2010, 11:35 AM   #3
Altered Sprinter
Happy Little Vegemite
 
Altered Sprinter's Avatar
 
Join Date: Nov 2006
Location: Hobart Tasmania Australia
Posts: 14,942
Thanks: 1,114
Thanked 2,354 Times in 1,863 Posts
Default Re: 02 311 CDI clunking and tapping only under acceleration....?

Hi Ian I do! or did get this low chain rattle on a cold start till engine reached operating temp. you could just hear it on take off .
Changed oil brand and it no longer happens, But may not be the same as you are experiencing
313Cdi 205 Sprinter
Richard
__________________
I get My Rocks off! In a Mercedes Sprinter
AU..Tasmanian time AEST Hobart
There is a peaceful solution.It's called a peace Revolution.
No Shalam - No Shalom
Now lets take back the - Sprinter-Forum.


Of course I'm being totally biased.
Driving my life Away in a 313 Cdi Mercedes-Sprinter


Altered Sprinter is offline   Reply With Quote
Old 05-12-2010, 11:54 AM   #4
3SIXTY
 
Join Date: May 2010
Posts: 7
Thanks: 2
Thanked 1 Time in 1 Post
Default Re: 02 311 CDI clunking and tapping only under acceleration....?

Thanks Richard, my noise is hanging around unfortunately at all temperatures...

Do you have any thoughts about my logic that any major engine tapping or knocking would be present constantly instead of just under acceleration?

many thanks, ian
3SIXTY is offline   Reply With Quote
Old 05-12-2010, 12:13 PM   #5
Altered Sprinter
Happy Little Vegemite
 
Altered Sprinter's Avatar
 
Join Date: Nov 2006
Location: Hobart Tasmania Australia
Posts: 14,942
Thanks: 1,114
Thanked 2,354 Times in 1,863 Posts
Default Re: 02 311 CDI clunking and tapping only under acceleration....?

HI IAN: One thought as to a sprinter doing what you describe if it's really more so than any other Sprinter Diesel:could be piston slap due to worn cams or bearing usually the last two.
I could suggest to take it to MB for a compression test. for an accurate assessment beween cylinders.
Sorry I'm not much help .
Richard
__________________
I get My Rocks off! In a Mercedes Sprinter
AU..Tasmanian time AEST Hobart
There is a peaceful solution.It's called a peace Revolution.
No Shalam - No Shalom
Now lets take back the - Sprinter-Forum.


Of course I'm being totally biased.
Driving my life Away in a 313 Cdi Mercedes-Sprinter


Altered Sprinter is offline   Reply With Quote
Old 05-12-2010, 01:08 PM   #6
Altered Sprinter
Happy Little Vegemite
 
Altered Sprinter's Avatar
 
Join Date: Nov 2006
Location: Hobart Tasmania Australia
Posts: 14,942
Thanks: 1,114
Thanked 2,354 Times in 1,863 Posts
Default Re: 02 311 CDI clunking and tapping only under acceleration....?

Quote:
Originally Posted by 3SIXTY View Post
Thanks Richard, my noise is hanging around unfortunately at all temperatures...

Do you have any thoughts about my logic that any major engine tapping or knocking would be present constantly instead of just under acceleration?

many thanks, ian
Local rep Chris from Birmingham in the UK sent me a PM try looking for a broken exhaust manifold bolt.
richard
__________________
I get My Rocks off! In a Mercedes Sprinter
AU..Tasmanian time AEST Hobart
There is a peaceful solution.It's called a peace Revolution.
No Shalam - No Shalom
Now lets take back the - Sprinter-Forum.


Of course I'm being totally biased.
Driving my life Away in a 313 Cdi Mercedes-Sprinter


Altered Sprinter is offline   Reply With Quote
The Following User Says Thank You to Altered Sprinter For This Useful Post:
3SIXTY (05-12-2010)
Old 05-12-2010, 01:52 PM   #7
3SIXTY
 
Join Date: May 2010
Posts: 7
Thanks: 2
Thanked 1 Time in 1 Post
Default Re: 02 311 CDI clunking and tapping only under acceleration....?

Thank you very much for your posts richard, I am heading to an independent garage tomorrow to investigate the problem and have diagnostics checked again... I fear the garage who sold me the van are hiding something... I shall check the manifold bolts, I really hope it is something this simple!

Thank you once again, I shall post my progress tomorrow : )
3SIXTY is offline   Reply With Quote
The Following User Says Thank You to 3SIXTY For This Useful Post:
Altered Sprinter (05-12-2010)
Old 05-12-2010, 01:55 PM   #8
Altered Sprinter
Happy Little Vegemite
 
Altered Sprinter's Avatar
 
Join Date: Nov 2006
Location: Hobart Tasmania Australia
Posts: 14,942
Thanks: 1,114
Thanked 2,354 Times in 1,863 Posts
Default Re: 02 311 CDI clunking and tapping only under acceleration....?

Quote:
Originally Posted by 3SIXTY View Post
Thank you very much for your posts richard, I am heading to an independent garage tomorrow to investigate the problem and have diagnostics checked again... I fear the garage who sold me the van are hiding something... I shall check the manifold bolts, I really hope it is something this simple!

Thank you once again, I shall post my progress tomorrow : )
Your more than welcome. please let us know, so we can learn from your experiences too.
Richard
__________________
I get My Rocks off! In a Mercedes Sprinter
AU..Tasmanian time AEST Hobart
There is a peaceful solution.It's called a peace Revolution.
No Shalam - No Shalom
Now lets take back the - Sprinter-Forum.


Of course I'm being totally biased.
Driving my life Away in a 313 Cdi Mercedes-Sprinter


Altered Sprinter is offline   Reply With Quote
Old 05-13-2010, 06:40 PM   #9
3SIXTY
 
Join Date: May 2010
Posts: 7
Thanks: 2
Thanked 1 Time in 1 Post
Default Re: 02 311 CDI clunking and tapping only under acceleration....?

Hello all,

well the diagnostic showed no error codes which is good news.... However we have found a leak on the water pump, the garage say that faulty bearings in the water pump would cause the noise only under acceleration... so a very promising diagnosis which can be fixed for under 170...

they also say an ABS fault caused by a cracked ABS ring (i think thats what they called it) is a very cheap part too... so everything can be sorted for under 200

Please do post if you've had this problem or don't think this is a correct diagnosis?

Ian
3SIXTY is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT. The time now is 08:54 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.