Sprinter-Forum    
 

Go Back   Sprinter-Forum > T1N Sprinters > T1N Talk

T1N Talk General Discussions related to T1N Sprinters.


 
Thread Tools Display Modes
Old 08-16-2019, 12:39 AM   #1
Preston
04 Sprinter, 118" Cargo
 
Preston's Avatar
 
Join Date: Mar 2014
Location: Nevada City, California
Posts: 80
Thanks: 60
Thanked 10 Times in 8 Posts
Default New instrument cluster- now problems...

I had the local Dodge dealer (auburn, ca) complete the lovely recall and like some of you, they needed to replace the instrument cluster. Now, the seat belt light and accompanying beeper is on ALWAYS.

Did this happen to anyone else? Was there an easy fix???

Any suggestions would be great.

Preston
2004 118" T1N
Preston is offline   Reply With Quote
Old 08-16-2019, 01:18 AM   #2
autostaretx
Erratic Member
 
autostaretx's Avatar
 
Join Date: Sep 2006
Location: Seattle
Posts: 17,564
Thanks: 3,079
Thanked 7,940 Times in 5,789 Posts
Default Re: New instrument cluster- now problems...

"ALWAYS" as in it never shuts up?

Obviously it's telling you to return to the dealer and hold their public address microphone next to the instrument cluster.

(i wonder if they bent a pin?)

--dick
__________________
2005 T1N 118" Freightliner 2500 Passenger Wagon (2.7L, 15" tires, standard (short) roof)
Get YOUR Sprinter's full configuration datacard by entering your VIN to https://www.datamb.com/
http://diysprinter.co.uk/reference <-- lots of service documentation, Thanks to Jens Moller and Arnie_Oli
((as always: this post may go through a couple of post-posting edits... so maybe give it ten minutes before commenting))
autostaretx is offline   Reply With Quote
Old 08-16-2019, 02:50 AM   #3
OldWest
T1N Westfalia
 
Join Date: Jul 2009
Posts: 2,043
Thanks: 211
Thanked 599 Times in 452 Posts
Default Re: New instrument cluster- now problems...

Yes, the new instrument cluster has the beeping and flashing seatbelt light for a 6 second interval even if you have already buckled the seatbelt. Very annoying. Posted a thread on it.

https://sprinter-source.com/forum/sh...light=Seatbelt

If you find there is a way to reprogram, that'd be great.
OldWest is offline   Reply With Quote
Old 08-16-2019, 05:43 PM   #4
autostaretx
Erratic Member
 
autostaretx's Avatar
 
Join Date: Sep 2006
Location: Seattle
Posts: 17,564
Thanks: 3,079
Thanked 7,940 Times in 5,789 Posts
Default Re: New instrument cluster- now problems...

Mine has always beeped (for 6 seconds, then shuts up) since it was new in 2005.

Hmmm... My Autel can report the status of the latch ... my one test was with it UNbuckled and it said "Open"
I'll have to see if it notices when it's closed.

--dick
__________________
2005 T1N 118" Freightliner 2500 Passenger Wagon (2.7L, 15" tires, standard (short) roof)
Get YOUR Sprinter's full configuration datacard by entering your VIN to https://www.datamb.com/
http://diysprinter.co.uk/reference <-- lots of service documentation, Thanks to Jens Moller and Arnie_Oli
((as always: this post may go through a couple of post-posting edits... so maybe give it ten minutes before commenting))
autostaretx is offline   Reply With Quote
Old 08-16-2019, 05:45 PM   #5
Preston
04 Sprinter, 118" Cargo
 
Preston's Avatar
 
Join Date: Mar 2014
Location: Nevada City, California
Posts: 80
Thanks: 60
Thanked 10 Times in 8 Posts
Default Re: New instrument cluster- now problems...

Quote:
Originally Posted by autostaretx View Post
"ALWAYS" as in it never shuts up?

Obviously it's telling you to return to the dealer and hold their public address microphone next to the instrument cluster.

(i wonder if they bent a pin?)

--dick
Good thinking Dick. I'll do the public address mic if I can't figure it out first. Sounds like other have had the problem- maybe there is a fix so I don't have to take it back to them! Cheers.
Preston is offline   Reply With Quote
Old 08-16-2019, 06:07 PM   #6
Preston
04 Sprinter, 118" Cargo
 
Preston's Avatar
 
Join Date: Mar 2014
Location: Nevada City, California
Posts: 80
Thanks: 60
Thanked 10 Times in 8 Posts
Default Re: New instrument cluster- now problems...

Quote:
Originally Posted by OldWest View Post
Yes, the new instrument cluster has the beeping and flashing seatbelt light for a 6 second interval even if you have already buckled the seatbelt. Very annoying. Posted a thread on it.

https://sprinter-source.com/forum/sh...light=Seatbelt

If you find there is a way to reprogram, that'd be great.
Thanks for forwarding the link. Very useful, though I think my situation might be a little different because my SRS light has been on for a while. Something tells me the new cluster is beeping nonstop because of that?

Both belts seem to work fine and with the old cluster, the thing never beeped- just constant SRS light illuminated.

I think the SRS light came on because water over flowed the shallow well in the passengers side dashboard. I thought maybe the airbag was tweaked. Do you know, is that a reason why the light would be on and possibly why the seatbelt light is beeping like crazy?
Preston is offline   Reply With Quote
Old 08-16-2019, 09:27 PM   #7
OldWest
T1N Westfalia
 
Join Date: Jul 2009
Posts: 2,043
Thanks: 211
Thanked 599 Times in 452 Posts
Default Re: New instrument cluster- now problems...

If beeping beyond the 6 to 7 seconds and have SRS light, then probably a different issue then just seatbelt buckling.

Problem is that new replacement instrument cluster may mean old diagnostic protocols may not be the same. Hopefully, someone has more info (I'm not a tech, just sharing personal experience and repeating what I saw on the Internet).
OldWest is offline   Reply With Quote
The Following User Says Thank You to OldWest For This Useful Post:
Preston (08-16-2019)
Old 08-16-2019, 09:40 PM   #8
autostaretx
Erratic Member
 
autostaretx's Avatar
 
Join Date: Sep 2006
Location: Seattle
Posts: 17,564
Thanks: 3,079
Thanked 7,940 Times in 5,789 Posts
Default Re: New instrument cluster- now problems...

I can't recall people complaining of a beeping if their SRS light came on due to a fault
(usually powering up the Sprinter without having reconnected an airbag)((amazingly common user-goof))

Once an "airbag connection dubious" condition has been sensed, the SRS light will not go out until it's cleared by a scanner.
The SRS "logic" is handled in the SRS controller, not the IC panel.

--dick
__________________
2005 T1N 118" Freightliner 2500 Passenger Wagon (2.7L, 15" tires, standard (short) roof)
Get YOUR Sprinter's full configuration datacard by entering your VIN to https://www.datamb.com/
http://diysprinter.co.uk/reference <-- lots of service documentation, Thanks to Jens Moller and Arnie_Oli
((as always: this post may go through a couple of post-posting edits... so maybe give it ten minutes before commenting))
autostaretx is offline   Reply With Quote
The Following User Says Thank You to autostaretx For This Useful Post:
Preston (08-16-2019)
Old 08-16-2019, 11:30 PM   #9
Preston
04 Sprinter, 118" Cargo
 
Preston's Avatar
 
Join Date: Mar 2014
Location: Nevada City, California
Posts: 80
Thanks: 60
Thanked 10 Times in 8 Posts
Default Re: New instrument cluster- now problems...

I have found a local T1N owner on this forum and he has the proper tool to reset the SRS light. I'll start with that to see if anything changes. Thanks for the input. I'll let you know if that helps!
Preston is offline   Reply With Quote
The Following 2 Users Say Thank You to Preston For This Useful Post:
autostaretx (08-17-2019), HelloPitty (08-17-2019)

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT. The time now is 08:19 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.