Sprinter-Forum    
 

Go Back   Sprinter-Forum > Sprinter-Based RV's & Conversions > Sprinter-Based RV Brands > Roadtrek


 
Thread Tools Display Modes
Old 07-14-2017, 12:49 AM   #1
jasonpax
 
Join Date: Jul 2016
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Question Drivers Door Lock -- only! -- all others work with Remote

Hi all,

I have a 2007 NCV3 motorhome conversion that is having a strange locking problem. One day I was sitting in the van reading, engine off, and the locks suddenly started freaking out, locking and unlocking, for no apparent reason that I am aware of.

At the end of it although the locks settled down, they refused to stay locked, unlocking as soon as a lock command was sent.

Eventually, the center locking button on the console ceased to operate altogether, and even if I key locked the van, the locks would unlock themselves within an hour.

One thing about this setup is that it has a Viper 7706v alarm system that is connected to the CAN bus via a DBALL2 interface. This system has been working fantastic for more than a year.

I reset and re-synced the DBALL2 interface, to make sure that the Viper was not fighting the system, and it did reactivate the center console switch, and all of the door locks started working again, except the driverís side.

I can key lock the driverís side, and remote lock the rest and it will stay locked, but when I remote lock everything, there is not even a sound from the driver side lock area.

I tried the DBALL2 reset again to no avail, as well as removing fuse #1 on the under dash panel, but that did not help.

The window and power mirror controls on the driverís side work, so I know that the connection is probably not the problem.

My next step (when I get into town) is to remove the DBALL2 entirely from the can bus, to make sure the viper is unrelated to the problem.

There are a couple of weird scan codes that came up via Carly for Mercedes:

0. Motor Control:
<--------------------------->
ME - Motor/Engine Electronics (MB: 0024468640):
- ECU OK, no fault code
<===========================>
1. Airbag:
<--------------------------->
AB - Airbag (MB: 9064461142):
- ECU OK, no fault code
<===========================>
2. Instrumentation:
<--------------------------->
UCP - Upper control panel (MB: 9065450307):
- Fault: Under voltage detection . Under voltage is not detected until after 5 s and a voltage of < 9.5 V.
- Code: 009036
<--------------------------->
IC - Instrument cluster (A1) (MB: 9064468021):
- ECU OK, no fault code
<===========================>
3. Systems:
<--------------------------->
EZS - Electronic ignition switch (MB: 9065454808):
- ECU OK, no fault code
<--------------------------->
ESP - Electronic stability program (MB: 9064460153):
- ECU OK, no fault code
<--------------------------->
SCM [MRM] - Steering column module (MB: 9065402745):
- ECU OK, no fault code
<--------------------------->
SAM-F - Signal acquisition and actuation module front (MB: 9065450601):
- ECU OK, no fault code
<===========================>
4. Body:
<--------------------------->
DCM-FL - Door control module front left (MB: 9068204026):
- Fault: Component E6/5 (Left exterior mirror turn signal lamp) or lead has Open circuit.
- Code: 00900D
<===========================>
5. Other:

Is it possible the rapid lock cycling blew a fuse? The ownerís manual is not very clear on what fuses might affect the driverís locking system (probably for obvious reasons).

So basically the current status is: The remotes and central lock button work fine, and all locks except the driverís door function normally.

I would love to get some ideas and feedback on what to check next. Itís hard to believe that a locking actuator freaked out and died and caused this, so I want to run everything else down first.

I have done a bunch of searches, but the Mercedes machine gun lock thing isnít really what the problem is.

Thanks in advance!
jasonpax is offline   Reply With Quote
Old 07-14-2017, 03:00 AM   #2
autostaretx
Erratic Member
 
autostaretx's Avatar
 
Join Date: Sep 2006
Location: Seattle
Posts: 17,843
Thanks: 3,120
Thanked 8,102 Times in 5,910 Posts
Default Re: Drivers Door Lock -- only! -- all others work with Remote

I'd start by looking for chewed wires where they pass into the A pillar from the door.
In T1N models, the door-travel-limit mechanism has occasionally snagged the wires in there and created quite a mess.

(there's another post of mine with an NCV3 door wiring drawing... i'll put it here when i re-find it)

OK... here's the MB drawing for what's in an NCV3 door. https://sprinter-source.com/forum/at...3&d=1498947849 (it's a PDF file)
You have to (mentally or physically print and) shuffle the first 3 pages to get them in the correct order to make the page-to-page wiring easier to follow.

--dick
__________________
2005 T1N 118" Freightliner 2500 Passenger Wagon (2.7L, 15" tires, standard (short) roof)
Get YOUR Sprinter's full configuration datacard by entering your VIN to https://www.datamb.com/
http://diysprinter.co.uk/reference <-- lots of service documentation, Thanks to Jens Moller and Arnie_Oli
((as always: this post may go through a couple of post-posting edits... so maybe give it ten minutes before commenting))

Last edited by autostaretx; 07-14-2017 at 03:04 AM.
autostaretx is offline   Reply With Quote
Old 07-14-2017, 05:26 PM   #3
jasonpax
 
Join Date: Jul 2016
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default Re: Drivers Door Lock -- only! -- all others work with Remote

Dick -- Thank you, I will check into that first thing in the morning! It seems like these fixes always happen in the summer when you're hoping to be using it more!
jasonpax is offline   Reply With Quote
Old 07-14-2017, 07:27 PM   #4
Sprinter Steve
 
Join Date: Aug 2016
Location: Pacifica, California
Posts: 72
Thanks: 1
Thanked 27 Times in 21 Posts
Default Re: Drivers Door Lock -- only! -- all others work with Remote

Lose, frayed wires is a good bet. Also, check terminals. They can look fine, but have backed out inside the connection.
Sprinter Steve is offline   Reply With Quote
Old 07-16-2017, 02:45 AM   #5
jvvjvv
 
Join Date: Jun 2016
Location: In a roadtrek agile
Posts: 111
Thanks: 56
Thanked 43 Times in 21 Posts
Default Re: Drivers Door Lock -- only! -- all others work with Remote

2008 Dodge Roadttrek Agile......... I have had the Viper system and my last three vehicles. Work flawlessly. I love the fact you can be blocks away from your vehicle and lock it, if you forgot to.

I had the system installed in my RV and the next day the locks went crazy, locking and unlocking, pretty much sounds like what yours did. Took it back and he unplugged and reset it. Back to normal, but the drivers lock was in operative. Installed a new actuator and it worked fine for a couple up of months. One day the clicking noise started again, so I unplugged it to reset it. The clicking stopped and the drivers door lock is not working again. Installed a new actuator and all was fine. After a few months the drivers lock stopped working again.

I am aware that the MB electrical system is finicky. I keep putting off calling Viper, because I hate dealing with factory techs that are usually clueless.............(in fairness, NOT all)......... I just leave the drivers door locked (manually) and use the RV slider. (The least effort fix I came up with.) The alarm guy is in Ca. and I am in Fl. So hoping Viper can recommend a shop out here. Gook luck with yours.

Last edited by jvvjvv; 07-16-2017 at 02:49 AM.
jvvjvv is offline   Reply With Quote
Old 07-21-2017, 03:23 PM   #6
jvvjvv
 
Join Date: Jun 2016
Location: In a roadtrek agile
Posts: 111
Thanks: 56
Thanked 43 Times in 21 Posts
Default Re: Drivers Door Lock -- only! -- all others work with Remote

Finally called Viper and got a dealer they recommend in Tampa. They pulled every thing apart and used test actuator. With the Viper disconnected, got the lock rapidly lock and unlock. So, the problem "must" be in the van?? I ordered a new actuator. They are willing to give it a go.
jvvjvv is offline   Reply With Quote
Old 07-21-2017, 07:49 PM   #7
autostaretx
Erratic Member
 
autostaretx's Avatar
 
Join Date: Sep 2006
Location: Seattle
Posts: 17,843
Thanks: 3,120
Thanked 8,102 Times in 5,910 Posts
Default Re: Drivers Door Lock -- only! -- all others work with Remote

Quote:
Originally Posted by jvvjvv View Post
So, the problem "must" be in the van??
No, the problem is that they are incorrectly interfacing to the van.

This is always a problem with/for 3rd-party devices... it is incumbent upon the 3rd party manufacturer to make sure their gadget won't interfere with the van's systems.

Which may, in truth, be almost impossible, given the sheer number of "systems" out there.
But it's an attempted cop-out to claim it's the van's fault for wanting to use its own communication system in whatever way it wishes.

MB didn't expect nor plan for some 3rd party to hang directly onto the module-to-module communications. The NCV3 driver's door has its own private module to command and control the locks, window and mirror motors that are out there. For folks that need access, MB provides the Programmable Special Module (PSM) option, which provides well (if you're versed in the subject) documented and "sand-boxed" pathways for "foreign" devices to "talk" to the Sprinter and request/command oddball operations.

Shy of using the PSM, Viper is effectively "hacking" into the Sprinter's systems, and the Sprinter doesn't like that.

--dick
__________________
2005 T1N 118" Freightliner 2500 Passenger Wagon (2.7L, 15" tires, standard (short) roof)
Get YOUR Sprinter's full configuration datacard by entering your VIN to https://www.datamb.com/
http://diysprinter.co.uk/reference <-- lots of service documentation, Thanks to Jens Moller and Arnie_Oli
((as always: this post may go through a couple of post-posting edits... so maybe give it ten minutes before commenting))
autostaretx is offline   Reply With Quote

Tags
door lock

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT. The time now is 08:02 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.