View Single Post
Old 12-11-2013, 04:37 PM   #1
Turbo John
 
Join Date: Dec 2012
Posts: 631
Thanks: 126
Thanked 271 Times in 137 Posts
Default Sprinter Skreem cure

The last time I was here I got the start error code. I ran all the 12 volt tests and everything was A ok
Now I did email Andy and he said you have no choice: Send the Skreem/keys and ECM to
SOS Diagnostics. So I boxed it up and sent it to SOS.....cause it was an SOS !

Now they wont tell you a thing about the repair........so dont ask.

I got it back promptly with a 300 dollar charge attached.

The Skreem was sealed with their tape and so was the ECM....with a note that there was a lifetime warranty if I did not tamper with the box and left it sealed.

re-installed and after several tries...something like it was learning ......would not start

but after several tries with both keys it finally started and NO MORE ERROR CODE

Started right up every time since then with no issues.........fixed!

So here is my take...........for along time I would disconnect my negative side of the battery and re install to get it to start.........what ever goes bad with these trucks take place over a certain time period,

I think it was all related and finally it just quit. So if your experiencing no start issues in time it just wont start anymore and you will need to do what I did.

Having said that I do not know or heard of anybody else that can perform that service. They have a cottage industry built around this trouble shoot. I am thankful and grateful we have a company like them...........cause I do not know the next step to fix this mess.

Thanks you SOS Diagnostics...........this trouble shoot would have cost a small fortune at a dealer or foreign car shop. http://www.sosdiagnostics.com/sprinter.html

This forum can save you money if you pay attention and can do some things yourself.

I was able to check the 12volt issues first with a meter and then I knew it was not some fuse or other issue.........and was not real sure when I got it back it would start.

Evidently SOS knew when they checked the ecm and skreem there was an issue, otherwise I would have gotten a phone call saying there was no problem

Anyway I want to report this so in case others are having this issue......it can be fixed.

I only have 75 on my Sprinter so its not a mileage deal....

Last edited by hkpierce; 12-26-2017 at 11:09 PM.
Turbo John is offline   Reply With Quote
The Following 3 Users Say Thank You to Turbo John For This Useful Post:
Aqua Puttana (12-11-2013), Dieseldoctor (04-20-2014), Spiritsprint (05-16-2019)