PDA

View Full Version : Did I do this to myself?


gottahavabenz
02-09-2010, 12:53 PM
Hey all!

I recently did a few modifications in the name of fuel economy to my 04 Sprinter and may have inadvertently done something not so good.

First off I had it on the lift to change oil and fuel filter when the idea of removing the entire exhaust from turbo back and installing a 3" straight pipe came to me and so I did it, easy enough. I was hoping to gain a few miles in between fill ups and be a bit more torquey. But the things that follow may or may not be related about 2 days later -as reported on this forum- I needed to replace my instrument panel no left hand blinkers but had hazards blah blah blah. That is done and was successful. Next came my coolant light which after opening the radiator cap and filling doesn't seem to be a problem anymore (at least there is no light on now) and now I am losing power on some steep grades that never seemed to be a problem in the past. Is it possible that all these problems are, or were a product of my (ahem!) fuel minded experiment or merely coincidence? I am prepared to take a thorough verbal lashing for my efficiency test? I did check the air filter and under the cover at the injectors all look good and no other lights on the dash so what can I check now?

Oh yeah, the results of the test are currently inconclusive, the new exhaust sound coupled with the bit more torque is making my heart flutter which drives my foot to the floor losing all economical benefits!:rad: Sorry will try harder to behave!

hkpierce
02-09-2010, 03:12 PM
Might want to PM TurboBrick: http://sprinter-source.com/forum/showthread.php?t=7558&highlight=exhaust