PDA

View Full Version : 03 Freightliner Sprinter 3500 no shift past 2nd


MnMike
11-27-2017, 06:42 AM
Hello forum,
Mike here, new member. Have referenced the forum many times in the past few years while dealing with my various sprinter concerns. Traveled from Minnesota to California a month or so ago. Was going from LA to Las Vegas and exited at Barstow, Ca for a fuel stop. As I slowed going up the off ramp, my transmission hard shifted into 2nd, and I havenít been able to upshift past 2nd gear since. Over the last month, Iíve carefully driven it about 1100 miles in 1-2nd gear.
Iím using an icarsoft MBII and am able to read and clear codes. Transcodes are P2500, P2502, p2503. TCU appears to be working. Scanner shows n2, n3 and wheel speed sensors working fine. Iíve installed a new conductor plate, new Connector, filter. Carefully checked resistance and function of all solenoids, switched 2-3 solenoid with 3-4 solenoid, completely dis-assembled valve body, cleaned thoroughly, carefully reassembled while referencing ATSG manual for all check ball locations as well as screens and the check valve.
Still have the problem.
Down to two possibilities. (1) I did not replace any valve components and am aware that could be causing a pressure loss. (2) It May be an internal problem with a clutch pack.
Iím leaning towards the second, as I did not notice any warning signs. Iíve changed the fluid and filter 4-5 times in the last year, prior to leaving on work trips, and shell 134 was the fluid. Always new fluid added. Fluid always looked good other than some fines and particles that one might expect as normal. Last thing. Hindsight, I wonder if I might have found disc evidence in the filters indicating a deteriation of clutch components.
Today I am going to remove the transmission, tear it down and see whatís up inside. The sprinter is a 2003, 242,000 miles, but the valve body has 2008 stamped on it. I donít know if that means the transmission was changed since 2008 or just the valve body.
Any feedback will be appreciated.