PDA

View Full Version : 2010 with EGT 3 code


morre
03-06-2017, 02:53 AM
on a 2010 3500 with SCR i get code p242B exhaust gas temp sensor 3
live data from scan tool shows good temperature from all 3 sensors, so looks like some kind of short somewhere. any body knows if this sensor wired directly to ECM or it wired to SCR module, from my understanding third sensor needed for SCR system only, trucks without SCR there only 2 sensors.

showkey
03-06-2017, 04:18 PM
If the live data is good.......a short or an open for that matter does not seem the likely cause of the code as those two problems would cause the temp reading to be wrong or missing.

Could the system be looking for a temperature change over the SCR and it's not seeing the change????

morre
03-19-2017, 04:28 AM
problem solved.

check engine light happen next day after adblue delete was done, adblue delete requires SCR module to be unplugged, it looks like egt3 has something to do with SCR module and thats why ECM freaked out and set a code. software was modified one more time to take care of this problem, all good now.

showkey
03-19-2017, 01:47 PM
:hmmm::thumbup:Think you left out some important info........the delete :shhh::shhh:

morre
03-19-2017, 04:05 PM
well i did, but vehicle was just purchased it had many codes for many different systems, and i didnt know if it was old code or new code just popped. i figured it by plugging SCR module back online and driving around, no code.
and delete is a big secret, nobody suppose to know, right??

but the same time i have similar problem on 14 sprinter with 4cyl, same thing, code for 3rd EGT sensor, live data is good, no tune, all original, almost brand new truck wit just 170k miles, erase code drive for about a month, get code, erase all good.