PDA

View Full Version : Van heat


Upyourkiltbatman
01-23-2017, 06:35 PM
I'm freezing , for some reason my 311 only gets warm on the passenger side , it used to be ok , could this be a matrix problem ?

NelsonSprinter
01-23-2017, 08:38 PM
Your van may have a worn out/seized auxiliary coolant pump that pumps hot coolant to the heater.It is located on the firewall, getting a used replacement is not recommended, only new or rebuilt . Are you keeping the top side vents closed? Are you blocking the rad airflow in cold weather?

Upyourkiltbatman
01-23-2017, 08:51 PM
I recently change the auxiliary pump with a second hand one because the original broke , I did think it might of been that but felt it and it was buzzing / vibrating so thought it was ok , I haven't blocked the rad but will try that

Aqua Puttana
01-23-2017, 09:06 PM
Is the air coming out of the dash vents at approximately the same flow rate? There has been some history of the diverter operating cables and parts breaking, or getting stuck.

I believe that MercedesGenIn has some information on testing the heater matrix aka heater core.

https://sprinter-source.com/forum/showthread.php?p=430131#post430131

He has many good Write-ups and tips on his site. :thumbup:


vic

SneakyAnarchistVanCamper
01-24-2017, 06:54 AM
On my van, if you put your hand back behind the blower, you can feel where the blower housing seals onto the firewall. On mine it leaks quite a bit of air pressure. But it sounds like your mode doors are not opening. Remove the switch panel housing and HVAC dash shroud to get to the cables that the HVAC mode control knob controls.