PDA

View Full Version : Both EBER dead and outside airtemp dead.


Alelalen
10-11-2016, 10:58 AM
Hello this is my first thread here.
I live in north Sweden and have a Mercedes Sprinter 316 (3.5t and 156hp). About 211k miles on it now, have had it about 62k miles, never been standing on the side of the road!!! No black death, but new dieselpump (the one on the front of the engine becuse of leak), new clutch (a solarspring was bend (strange) just when I come home on the parking, could not push the clutch down), new waterpump, ac pump (but the system leaks, must fill every summer, termostate (the old was not bad (didnt know this) but on the winter the heatpacking for cabin cool the watertemp, maby cover a part of the radiator), multi-strap and strap-wheels on the engine. All by my self.

Great car, about 100-105L dieseltank, extra strong suspension package, 2800kg hitch, AC, cruise controll, EBER for the cabin (with timer) and one for the engine.:thumbup:

Both EBERS not working, they did first when i bought the truck but not now.
The one for the cabin have I done a rebuild on, new gaskets, fuelfilter on the inside. Didnt work before I did that.

No errors on the timer display. It have stayed out of battery for a couple of days also.
No sound of it when I start. The timer starts and goes. I hear a click on the smal pump on the underside, or its a relay, when I stop it. :thinking:


And the other one is the same. I start it, but I don't hear anything from it either.
Been testing to start it a couple of various times, cold engine, in speed and so on.
The "parking watercirculation-pump" was dead so I replaced it, maby after that it needs a reset by a computer?
And the outside airtemp is not working, thats why also?
Been replaced it by a new but its only says "---" on the dashboard´(when I click for it).

Any tips to follow the wiring? Where it goes? :rolleyes:


Been checking ALL fuses and cabels (by eye).

Is it possible for a Mercedes shop to connect a computer and see anything?

johnshmit
10-11-2016, 01:58 PM
Yes, you can test and activate both factory heaters with a Xentry

Tukala
10-16-2016, 07:15 PM
Hi,

And greeting from neighbor (FIN) :D


Can you get ´em running hwen engine is running?
I quess not (anymore)?

Fuel level must be above 1/4 tank, but don´t think this is the matter here.
As said earlier, can be tested with Xentry (reliable way) , but can be tested other way too

There´s a chance that they´re "locked", caused by too many strat attempts.



EDit.

They are called Espar (s) , out in the big world :D

Alelalen
10-18-2016, 01:44 PM
Hi,

And greeting from neighbor (FIN) :D


Can you get ´em running hwen engine is running?
I quess not (anymore)?

Fuel level must be above 1/4 tank, but don´t think this is the matter here.
As said earlier, can be tested with Xentry (reliable way) , but can be tested other way too

There´s a chance that they´re "locked", caused by too many strat attempts.



EDit.

They are called Espar (s) , out in the big world :D


Hello neighbor. :cheers:
Fuel level is more than 1/4 yes, but thanks.
Then I contact a Mercedes shop.

I have been reading that they could be "locked" and think so too.

I will update. :thumbup: