PDA

View Full Version : P0336 on 2012 NCV3


RonR
06-25-2016, 11:55 PM
Am I the first?
Search did not have any other NCV3 hits on P0336.
Just got a P0336 (crankshaft position sensor) code when stating up this afternoon. Started after glow indicator went off but (a first) it started rough and ran rough for a couple of seconds. Then sounded and ran normally.
Has anyone had this happen? Is it as simple as replacing the sensor?

Thanx
Ron

Aqua Puttana
06-28-2016, 12:32 PM
Am I the first?
Search did not have any other NCV3 hits on P0336.
Just got a P0336 (crankshaft position sensor) code when stating up this afternoon. Started after glow indicator went off but (a first) it started rough and ran rough for a couple of seconds. Then sounded and ran normally.
Has anyone had this happen? Is it as simple as replacing the sensor?

Thanx
Ron
As nobody has answered.

The sensor code and rough running would point to the sensor maybe being involved in the problem. A visual inspection of the wiring harness may reveal something.

Are you under warranty? If yes, do not reset the DTC's. Get in to the dealership.

If no, I would at least purchase a sensor and know how to install it.

vic

RonR
06-28-2016, 11:38 PM
Thanx for the info.

I got the P0336 code after one (never before experienced) rough start. Post start it ran fine and started fine a few more times. I check wiring but found no issues. I set up an appointment. Not wanting to go into LHM 300 miles from home we squeezed into our little Mazda for the weekend.

Normal start and no check engine light when starting up to go to the dealer today. Still have the code (that I can't clear with the Scan Gauge and my MD802 is acting funny) but it runs just fine so I canceled the appointment not wanting to spend the money to hear about "no problem found".

It appears that some CELs clear after a few starts when the original issue is not repeated.

If it happens again, I'll just put in a new one.

The dealer claimed that they do not see many P0336 codes on the 2012.

Ron