PDA

View Full Version : Weird clunk noise up front


Jchirchirillo
04-20-2016, 12:54 PM
2013 short body 2500 65k on OD:
Guys ,,I got a weird clunking noise comeing from the front. It's more noticeable when I go over small choppy bumps. Any idea where this is coming from?
Also booster heater making a grinding noise ?

lindenengineering
04-20-2016, 01:05 PM
Sway bar bushes maybe links!
Uprated and available from the dealer as a kit !
You will need two sets.
Dennis
Mechanic

Jchirchirillo
04-20-2016, 01:33 PM
Tks Dennis,
I dropped it over at mb this Morning. Service manager said , most likely a bad shock without looking.. Let's see what happens..
Jimmy

bryan11
04-20-2016, 02:15 PM
Had a bad shock myself with similar noise. Seems your repairs are following mine, same year, same mileage. I'm at 56K miles. Had a steering noise repaired under warranty. Didn't you as well?

My brakes are close to finished as well, dealer quoted 1500 total, yikes. Also looking to replace serpentine belt. Wish I could do it myself as the belt itself is cheap. Dealer wants 400-500.

Jchirchirillo
04-20-2016, 05:21 PM
front end MB diagnosis:

inner tie rod ends- worn
outer tie rod ends - partially worn
both shocks -rubber bumper worn

not covered under Mb extended warrantee. due to all sprinters being commercial .

This MB extended warrantee i purchased is turning out to be a looser...

holy smokes!

Jchirchirillo
04-20-2016, 05:25 PM
Had a bad shock myself with similar noise. Seems your repairs are following mine, same year, same mileage. I'm at 56K miles. Had a steering noise repaired under warranty. Didn't you as well?

My brakes are close to finished as well, dealer quoted 1500 total, yikes. Also looking to replace serpentine belt. Wish I could do it myself as the belt itself is cheap. Dealer wants 400-500.

yep, i would say the clunk noise started about 55k miles. was just to busy to take it in .. I got a similar quote from MB & service manager said mb has elected to half . so the original invoice would have been almost 3 grand.. :bash:

moondawg14
04-20-2016, 06:58 PM
Had a bad shock myself with similar noise. Seems your repairs are following mine, same year, same mileage. I'm at 56K miles. Had a steering noise repaired under warranty. Didn't you as well?

My brakes are close to finished as well, dealer quoted 1500 total, yikes. Also looking to replace serpentine belt. Wish I could do it myself as the belt itself is cheap. Dealer wants 400-500.

Yup, just paid 500 for 2 serpentine belts as well.

and $200 for an alignment. I sure hope there were no worn parts when they did the alignment. Van has 70k!

FireandIceHVAC
04-21-2016, 01:08 AM
Had the same noise with approximately 34,000 miles, turned out to be both front shocks, inner and outer tie rod ends . All covered under the 3 year / 36k factory warranty. A bit surprising . hope i don't have to replace these items again anytime soon