PDA

View Full Version : Amber lights stay on


WeBeGone
01-27-2016, 07:42 PM
Last night I noticed the amber turn signal/parking lights were on and won't tun off on my 2004 T1N. I disconnected the battery so it wouldn't go dead, and this morning hooked it back up with the same issue.

Now the turn signals and emergency flashers won't work because the lights stay on all the time unless I disconnect the battery.

Is there some sort of reset, or does anyone have any ideas where I should start looking?

Thanks in advance.

Ron
__________________

MercedesGenIn
01-27-2016, 09:35 PM
Hi there.
Play with the hazard warning switch and see if it's that causing the issue. The indicators are controlled by the power distribution module under the steering column. There is no flasher relay in the traditional sense, it's all internal to the power fuse module. There is however a relay that controls the stalk function, it can be found in the link below.
If you drop the fuse board down and have a look around paying special attention to the twin connectors that marry with the indicator and lighting stalk assembly. It may also be the stalk that is faulty but less likley.
The fuse board module is known to be troublesome, have a look here for more info.
http://www.mercedes.gen.in/WP35/?s=fuse&submit=Search

More info on that fuse board and it's removal here...
http://www.mercedes.gen.in/WP35/unsual-intermittent-power-problems-mercedes-sprinter/


All the best
Steve

misterbond10
01-27-2016, 09:58 PM
Are they blinking or staying lit?

WeBeGone
01-27-2016, 10:43 PM
They are staying lit, and as a result the blinkers as emergency flashers don't blink/flash.

I have tried cycling the emergency flasher switch but it made no difference.

I will try dropping the fuse panel....Do you know if it comes off with the bolt at the top of the panel, or the 2 trim type screws on the steering column plastic shroud.

Thank you guys for the ideas !!

Ron

PS.....I just tried removing the bolt at the top of the fuse panel and as one might expect, the backing nut is turning.
Now I need to figure out how to stop that nut so I can remove the bolt....
Seems every step involves a few more......LOL

NelsonSprinter
01-27-2016, 10:47 PM
Some have had the same issue ,caused by a short circuit in the rear lights circuit board warping/grounding, easy inspection from inside of van in front of taillights
Fuse panel comes off from top bolt, but try pushing up on fuse panel while pushing down on emergency flasher switch to push connectors together to see if that works too

WeBeGone
02-22-2016, 07:30 PM
Well, I disconnected all four light clusters individually to see if that solved the problem, and it didn't. I also read oin a Dodge forum that the #1 fuse block under the steering column had been a culprit, so I installed a new OEM fuse block and the problem is still there.

At this point I have taken the bulbs out of the turn signals and installed a battery disconnect so I can drive it until I can figure this out.

Has anyone else dealt with this issue ?

Any help is greatly appreciated.

Thanks
Ron

Midwestdrifter
02-22-2016, 07:54 PM
I would suggest pulling fuses (start with ones related to lights) until you find the one feeding power to the lights. This will at least get you started looking for the fault. If the fuse is the one dedicated to the amber lights, the fault is likely in the switch or the tail light assemblies.

It is possible that the multi function switch has an internal short circuit?

Once you discover which fuse is feeding the lights you would then consult the service manual to determine what circuits are fed by that fuse. From there you just need to check the wiring where the lights and the faulty circuits are near each other.