PDA

View Full Version : 2006 2500 runninng rich/ black smoke


vinny17
09-26-2015, 06:30 PM
HI,

I've been searching info for a while now and I seem to have three different scenarios

150K on it. Running great up to a definitive point where it stalled once.
I drove it the rest of the day and in the morning I had to start it 30 times until it caught.
I thought glow plugs being they had never been changed and had the local garage do it. that day.... and the glow plug module, only to find out they were not capable of diagnosing the problem. Here's what I got going on.

(Ill leave off the part about the dodge dealership and Mercedes dealership and be glad im only out 500 bucks for no info. )


My 3 scenarios as of this week driving it every day for at least 50-100 miles a day
1st starts up and runs great 25% of the time

2nd starts up and stalls, then I start it 5-15 times till it stays running and its smells rich and
runs rough and will barely have the power to move till I feather the gas pedal, it surges a bit till I can get the rpm's up and turbo kicks in lightly smoking in the beginning to a thick cloud runs smooth up to highway speeds and after a few times i'm good to go.

3rd starts up and stays running ( usually engine is warm for this one ... I think) no smoke, smooth running engine, takes a while to get up to speed but I can run it over 60 mph but turbo never kicks in.

observations, seems best when outside temp is hot
on cool days its tougher but also noted one cool day it started right up and ran great
no engine light


I'm off to change the fuel filter now as I noticed it looks pretty old.

Tplumbn
09-26-2015, 06:57 PM
Is the "Check Engine Light" lit up ? Will the engine rev over 3000 RPM in neutral ?

vinny17
09-26-2015, 07:34 PM
no engine light.

ill have to check on the rpms in N, but I don't recall ever seeing go higher than 3000 at any time

sailquik
09-26-2015, 08:35 PM
vinny17,
Changing the fuel filter is probably a good thing to do.
But your symptoms pretty clearly indicate an over fueling condition (I.E. black smoke from unburned fuel).
Have you checked all the easy things?
Turbo resonator.....turbo hhoses....Charge air Cooler?
These would not normally affect how it starts, but could easily be part of the issue here.
Have you looked at the turbo actuator and lubed the linkage...again should not affect how it starts, but
could be contributory.
Might be good to find someone with a DAD or DRBIII unit to check your fuel pressure.
Could be as simple as a bad O'ring in the fuel pressure regulator.
How is the condition of your battery?
If your battery voltage is low, it may not be turning your engine fast enough on the starter to generate
the required minimum fuel pressure (I think Vic has stated it's ~ 2900 PSIG/200 BAR).
Or perhaps your starter is getting a bit weak, and when your Sprinter is cold, it does not generate
the required RPM to build the fuel pressure, but when it's warm and been running the voltage is better
and the engine spins up enough to give the required fuel pressure.
Or perhaps you have a faulty or intermittent fuel pressure sensor.
Hope this helps,
Roger

anythingcomputerrelated
09-27-2015, 02:17 PM
Not sure on the 2006 but my 2002 cut off after startup, was smoking etc. and I may be wrong but it seems to be doing a lot better since I took off the EGR valve and cleaned it real good.
I said better, it's still not perfect but that's in another thread.

vinny17
09-27-2015, 02:42 PM
HI and thaks for the reply. answers so far...

>Have you checked all the easy things? Turbo resonator.....turbo hoses....Charge air Cooler
*...resonator shows no cracks, turbo hoses in good shape. visually the charge air looks good, what I can see of it so far, but I don't really have experience with one to know what to look for. I hear no leaking while running.

NOTE: during hose inspections when I removed the retaining ring on the main air intake hose at the manifold and noticed a small bit of oil. also noted an oil leak at the turbo but it appears to be from the oil return hose gasket. ( which I know I had some difficulty attaching last time I pulled the turbo) I'm thinking it might be a good time to clean the EGR


>Have you looked at the turbo actuator and lubed the linkage...
*....moves freely, diconnected to make sure waste gate was not binding up
its an aftermarket turbo apx 40K on it with original actuator..


>Might be good to find someone with a DAD or DRBIII unit to check your fuel pressure.*...I will work on this angle. might take some hunting but ruling things out is half the battle


>How is the condition of your battery?
*...spins the starter like a champ

icarus
09-27-2015, 03:56 PM
Charge air leak? Get a scan gauge or scan tool and check MAP.

Icarus

vinny17
09-27-2015, 05:39 PM
NOTE:
I might just add that it starts right up 80% of the time on first or second try but if I even touch the gas pedal it boggs down and/or bucks and/or stalls.

Tplumbn
09-27-2015, 05:52 PM
When I originally started having problems with my 2006 Sprinter, I checked the Turbo resonator and could not see a problem. It was easy to pull it out so I decided to take a closer look. Even though there was no obvious sign of any leak, the seam was split and was leaking air.

vinny17
10-04-2015, 12:16 AM
Wow. A confusing vehical for sure. Today it started right up and ran lika a champ the first start. Second start of the dsy right back to scting up. Hope to get a chance to work on it this week and stop smoking out me neighborhood

Still no engine light

Would a charge air leak be so intermittant?

Aqua Puttana
10-04-2015, 01:50 PM
...

Would a charge air leak be so intermittent?
Depending upon the failure mode they can be.

You mentioned oil in the charge air system. Oil inside the charge air system is very normal. That oil leaking out isn't. I would carefully inspect any oil covered areas as it may point to a charge air leak.

That is a suggestion, not a diagnosis.

vic