PDA

View Full Version : glow plug light triggering a fault code


syncro_G
06-26-2015, 05:57 PM
I paid a visit to Ben Crilly to figure out why my check engine light was on.
His SDS, indicated it was a fault with the glow plug system and specifically a burned out LED in the instrument cluster. That's an impressive tool.

So now I'm faced with a DIY repair that I'm sure I'm capable of doing. However, from what I know about electronics in general, this seems like such an unlikely problem.

Is the instrument cluster circuit board known to have failures like this?

Rob S
06-26-2015, 06:37 PM
I've read quite a lot on this forum, and have not read about such a thing.

jmoller99
06-26-2015, 08:34 PM
Glow Plugs are a common failure issue on Diesels. The New Mercedes Glow Plug Controller is self resetting Once you replace the bad glow plugs - however, the original Glow Plug Controller had fusible links (that blew inside the controller - you can fix those if you take it apart - not that simple).

I don't recall LEDs on the dash doing more than flagging the Glow Plug issue (the 2002 and 2003 don't consider it a reason to turn on the MIL light, but the 2004 - 2006 TiNs do). How would anyone know any were burned out using an ODBII Scanner?

I suspect you need your Glow Plugs changed, and maybe the new Glow Plug Controller (if you had an older version installed).

Aqua Puttana
06-26-2015, 10:20 PM
I've read quite a lot on this forum, and have not read about such a thing.
The only Instrument Cluster LED problem I recall was where the MIL aka CEL was ripped out to make it look like there wasn't any MIL problem.

The dash LED's are easily checked visually during lamp check when the ignition key is first turned on. No fancy scan tool is really needed.

Glow Plugs are a common failure issue on Diesels. The New Mercedes Glow Plug Controller is self resetting Once you replace the bad glow plugs - however, the original Glow Plug Controller had fusible links (that blew inside the controller - you can fix those if you take it apart - not that simple).

I don't recall LEDs on the dash doing more than flagging the Glow Plug issue (the 2002 and 2003 don't consider it a reason to turn on the MIL light, but the 2004 - 2006 TiNs do). How would anyone know any were burned out using an ODBII Scanner?

I suspect you need your Glow Plugs changed, and maybe the new Glow Plug Controller (if you had an older version installed).
I agree. He must have an NAS aka NAFTA 2004 MY or newer if the glow plug problem is illuminating the MIL.

vic

syncro_G
06-27-2015, 04:08 AM
Yes, 06 sprinter.

The fault was found using the star diagnostic system (sds). Not an obd2 scanner.

The glow plug system appears to be fine otherwise.

syncro_G
07-29-2015, 02:37 AM
What ever it was, I haven't seen the error again.

(knock on wood)