PDA

View Full Version : a few daft questions from a sprinter newbie


campermans cave
04-26-2015, 08:00 PM
hey guys i have a 2003 lwb 311 cdi, and being new to sprinters i have a few daft questions to ask,

1, do i have an egr? cant seem to find it or any pipe work,
2, no cat, is this normal?
3, no turbo resonator just straight from air box to turbo and from turbo to intercooler.

also power wise the turbo spins lovely got boost but seems to lack power when travelling at say 40mph and i put my foot down it dosent seem to want to accelerate quickly at all (like a carburettor car without air filter if you know what i mean) all other van iv had seem to have a bit more guts.
also revs only seem to want to go upto 3000rpm

any ideas or am i just stressing over nothing,
i should mention that when i was out driving the other day the turbo pipe blew off the intercooler, frightened the living s**t out of me lol

cheers
martin

NelsonSprinter
04-27-2015, 01:54 AM
Welcome Martin
I don't know where you are but some countries don't require an EGR or Cat convertor, some people remove them for more power or fuel efficiency.
If you had an EGR it would be bolted on just before the intake manifold to the turbo hose. Turbo resonators came into use in N. America in 2004, maybe where you are too.
Not going over 3000RPM is a form of Limp Home Mode where the computer detects something wrong with a component and limits the engine/transmission use until it's fixed. If your turbo hose has come off, you may have a lose connection somewhere else that is leaking turbo charged air and causing the LHM

Aqua Puttana
04-27-2015, 02:03 PM
What NelsonSprinter said +.

hey guys i have a 2003 lwb 311 cdi, and being new to sprinters i have a few daft questions to ask,

1, do i have an egr? cant seem to find it or any pipe work,
2003 Euro models typically do not have an EGR.

2, no cat, is this normal?
I'm not sure for Euro models. I thought that the 5 cylinder OM612 did? :idunno:

3, no turbo resonator just straight from air box to turbo and from turbo to intercooler.
Your 5 cyl OM612 or 4 cyl Euro model doesn't have a Turbo Resonator.

also power wise the turbo spins lovely got boost but seems to lack power when travelling at say 40mph and i put my foot down it dosent seem to want to accelerate quickly at all (like a carburettor car without air filter if you know what i mean) all other van iv had seem to have a bit more guts.
also revs only seem to want to go upto 3000rpm

any ideas or am i just stressing over nothing,
i should mention that when i was out driving the other day the turbo pipe blew off the intercooler, frightened the living s**t out of me lol

cheers
martin
Again, I agree with NelsonSprinter in that it sounds like you have a problem which is keeping your power limited. Perhaps the hose blowing off set something in the ECM aka ECU? Is the MIL aka EDC light on? Even if not you should get a scan with a Sprinter specific scan tool. vic

campermans cave
04-27-2015, 03:49 PM
thanks for the replies guys,
a few things iv checked over today, the turbo actuator arm is perminently in the downward position and never moves when i rev the engine. when i disconnect the vacuum pipe the actuator returns to center, reconnect and it pulls down again with no further movement in the rev range does this mean my boost actuator is broken or something else before i spend money

thanks again
martin

Eric Experience
04-28-2015, 10:43 AM
Martin.
That turbo actuator behavior suggests you have a bad air leak in the boost system and the turbo is not able to get the pressure up to normal. Look for splits in the hoses or the tanks on the ends of the cooler. Eric.

Tooth Fairy
04-28-2015, 10:58 AM
Martin.
That turbo actuator behavior suggests you have a bad air leak in the boost system and the turbo is not able to get the pressure up to normal. Look for splits in the hoses or the tanks on the ends of the cooler. Eric.

What Eric said.....^^^^^^^.....:thumbup: