PDA

View Full Version : brake problem


stevevoid
10-21-2014, 12:14 PM
hi there
i have a 1997 mercedes 612d vario, my brakes appeared to be sticking on and heating up the new brake discs, it started when my air compressor seemed to brake, this may be a coincidence but i took out the pins at the back so that the air handbrake was disconnected, btw the foot pedal is hydraulic and the hand brake air! i made sure that the arms that connect to the wheels via the pins were on the outside of the vehicle ie the hand brake disengaged, i kept friving and the brakes were still getting hot, im pretty sure its not possible that the handbrake is still engaged but they were still heating up, weve taken the calipers apart and the pistons out to make sure they werent sticking, they seem to be allright. Im wondering where I need to look next? What else may cause this problem. I could feel the brakes on slightly whilst driving and the pedal didnt feel right.
Any advice appreciated
thanks

MercedesGenIn
10-21-2014, 04:33 PM
Take a look at this, air over spring loaded parking brakes are a wonder to themselves... Try the fault finding check routines here. Similar layout and may help you.:thinking:

http://ww2.justanswer.com/uploads/Chezario/2011-01-31_091344_w670_checking_compressed-air_syste...ring-loaded_parking_brake.pdf

Steve

stevevoid
11-01-2014, 02:43 PM
Hi there
I have checked through the system and realised that the compressor doesnt turn on electrically, i have run wires direct to it and it works, so the problem does seem to be electrical, ie from th eignition switch or somewhere, I dont suppose you have a diagram of the electrical system for the parking brake?, that would be really helpful, thanks