PDA

View Full Version : Webasto booster heater (Operation)


44tonner
03-01-2014, 02:57 AM
First, I'm new to my 2006 Dodge 2500 Passenger Van. I've had it 5 weeks and slowly learning how it works. First tried the heater and it ran till it got hot and quit. From reading the forum figured it was the electric water pump, Replaced it and all was well. The morning it was -13 so fired up the heater to preheat the engine before trying to start it up. Heater fan comes on, runs 3-4 minutes, then shuts off. Tried it a couple of times, same thing. Would not fire up. Go back in side to warm up. Two hours later come back out, now a -5, and try it again. Now I hear the fuel pump clicking and it fires right up. So my question is, when I turn it on, should the fuel pump always be clicking? With it that cold, would the fuel pump fail? Should I replace it? It has 110,000 miles on it. As far as I can tell (Carfax) it's always been in Michigan. Thanks in advance for any suggestions or help.

sailquik
03-01-2014, 03:08 AM
When did you last fill it up with fuel?
Where did you last fill it up with fuel?
Might be a good idea to add some anti-gel to your fuel.
Or a bottle of diesel 911 in the tank.
Roger

44tonner
03-02-2014, 06:17 PM
Tank was filled full 3 days ago at the local (Leslie) station. There never has been an issue with water in his fuel. The question I was asking is, should I always hear the the fuel pump clicking when I turn the booster heater on? Thanks Gary.

mean_in_green
03-02-2014, 09:18 PM
The pump is usually audible but can vary in volume.

If I haven't used mine for a while and the fuel level is low it will be louder than if I used it yesterday and the fuel level is high. In other words it gets louder the harder it has to work to pull diesel out of the tank. It's totally normal operation.