PDA

View Full Version : P0740 code = need new transmission?


bryanfowler
01-02-2014, 11:21 PM
I have a 2005, 2500, 150WB sprinter. 344K miles (New transmission at 300K. Previous owner did that, I don't know much about it)

It's showing a P0740 code (Torque Conv Clutch, No RPM Drop at Lockup)
Fluid is within range, it shifts fine. I don't think it's missing a gear.

I chatted with a local transmission place, and they said it might need a new transmission, but they need to check it. They said it would be in the $2500-2800 range for a new transmission.

How can I get a 2nd opinion on this? I think if I take it to another transmission place they'll just say the same thing. (which I guess counts) but I'm hoping to pick your collective brains first.

Thanks

(sorry if this post is premature. i.e. "wait till the diag comes back")

pfflyer
01-02-2014, 11:35 PM
What are your symptoms? From your post it sounds like it is operating proper and just throwing the code? Maybe an old code that needs to be cleared.

I would take it to someone with the proper scanner either freightliner or MB. Pay for an hour shop time to properly diagnose before I drop that kind of money on another rebuilt or new tranny.

bryanfowler
01-02-2014, 11:38 PM
You're right. No symptoms that I can tell. A friend who owned a 2002 for 10 years drove mine this weekend and said it felt, and sounded great to him. He's not a mechanic though. And I've only had it 3 weeks and I'm a new sprinter owner. So I may be missing something.

I've cleared the code several time, but it comes back instantly.

pfflyer
01-02-2014, 11:56 PM
I'm not a mechanic and by no means an expert either. Unless you have the proper equipment like at the dealer most codes you wont be able to clear. Most repair shops equipment wont get to the sub-codes or clear codes unless they spend $10-20k for the MB equipment. There are plenty of threads here that discuss these computers in more detail. Unless the shop repairs a lot of Mercedes they aren't going to invest in this expensive equipment and that is one reason why Mercedes are expensive to fix. Welcome to the forum by the way.

bryanfowler
01-03-2014, 12:02 AM
Thanks PF. So far I've spent quite a bit of time reading all these posts. Great stuff here. I'll need ages to get through it all =)

I'll ask the transmission guy if he has the gear for reading MB codes. I thing that Diesel Plus in Ringgold might have them too.

pfflyer
01-03-2014, 12:26 AM
He may be able to pull the P0740 code but there are sub-codes that would pin-point the problem. There is a Freightliner Sprinter shop in Chattanooga(Ringgold).

http://www.ringgold.ftlsprinterdealer.com/

lindenengineering
01-03-2014, 02:48 AM
Just an overview.
The most prevalent code indicating you need a replacement transmission are concerned with mismatch of speeds. Often involved with 2 to 3 change flares (slip) of the clutches causes a mismatch. That if severe with throw a code and might even effect a limp mode or loss of drive

Equally there are some sprag (one way mechanical clutches) inside the running pack which can slip start to break up and these scatter metal inside the box. Now caution there are two types of metal; in layman terms I call them the fuzzies and the sparklies.

The fuzzies are normal amounts of fine metal particles that are to be found in ANY auto transmission over time adhering to the donut shaped magnet in the pan, and to many a DIY'r this goop is alarming. Much of it can be removed in doing thorough a service and replacing the defunct donut with a new magnet one which these days is square and looks like 5 bar gate. Cost is about $10,00.

Problem is that if you extend to service period or totally neglect it, the fuzzies also can adhere to the speed sensors located in the circuit board corrupting the speed signals and you can get similar fault codes. Some less than honest shops interpret the fuzzies as severe metal contamination and that determines a replacement posture/claim, so beware!

The Sparklies are something different! This is substantial metal particles shed off of components breaking up like a sprag clutch going south or teeth / bearing wear taking place.
Dropping the fluid and checking some in a glass jar will show if there are sparklies in suspension. Dropping the pan and examining the suction filter and the pan floor will reveal metal in abundance if its going south.

A road test can often give you some indications. Luckily here in Golden I have the front range of the Divide to punish the transmission up some steep grades. If its about to go south it will protest and sometimes stop driving. Happened to me only last week! Customer complained of loss of drive when hot.

Had to get a Landrover to drag the lame beast back to the shop during an aborted test run!

With a scanner connected in data and with an assistant reading the outputs I get it hot then use the tiptronic to shift the gears "hard" through the speeds doing power shifts on a grade. If there is going to be a shift "flare" in the making it will show up on the up shift and you will feel the clutch pack or the sprag clutch slip and this will often result in a very jerky shift or total slip condition. On this 05' Tinny were were testing the blighter held for one circuit up the mountain but took a dump on the second run. We both exclaimed there she goes Capt'n :laughing:, "Bingo" found it!
Going down the grades I lost all speeds and opening the window I could hear the jingle bell rock tinkling away from underneath! There's the problem inside the running pack!

So first the unit needs a good interrogation with a scanner and a check on fluid/filter service history conditions before determining it needs a new box.

On this last case it did with 350K on it but one before with 175K needed a good service to make it run like new again.

To conclude
A good examination and service can be much cheaper than a replacement ,
Hope this has helped you,
Cheers Dennis

bryanfowler
01-03-2014, 03:16 PM
Thanks again guys for the advice. Dennis, wish I was closer. =)

The local Freightliner is asking $120 to do the diagnostic. Does that sounds like a normal fee? The other local transmission shop won't charge anything for a superficial diagnostic. I'm just concerned they won't have the tools to see what's wrong. Maybe that's not giving them fair credit. Not sure.

dickknapp
01-03-2014, 03:35 PM
Dennis, I'm interested in source for the new square magnet. Will do a service this spring. I too wish you were closer :-)
Dick

pfflyer
01-03-2014, 03:45 PM
$120 sounds about right. That is for an hour so if you have any other issues get them to look at that as well. Not sure what the mileage is for transmission service but might not be a bad idea to get one done and let them analyze the fluid and shavings like Dennis said. Think transmission service is in the $200-300 range to get it done right. They should hook you up to the computer as part of this service anyway. Either way I would take it to someone equipped and experienced to look at and diagnose Sprinters. Local no charge diagnoses so far have come up with new transmission recommendation. Local shop may be cheaper than FL or MB but will they use the correct fluids and know all the ins and outs of a transmission they may have never seen before.

bryanfowler
01-04-2014, 08:39 PM
Well, that was an expensive opinion. =)

I took it in, and this is what they said. (I didn't talk to the mechanic myself, which is a bit of a pain. I had to go through the receptionist)
I had them look at two engine codes. This was what I received on the ticket...verbatim.

"344166 Check has codes for glow plug and failed control and excessive current draw on torque converter. code usually caused by excessive metal in transmission fluid. found dipstick tube leaking on transmission. quote glow plug, controller and O-ring. Need approval to remove trans pan and inspect for metal. 414/KB"

I will call in for a quote on monday. I'm guessing it'll be expensive. Maybe.

My main concern is wether or not I continue to drive it or not. I have a couple of 3 hr trips over the next week.
The Glow plug code was P0683. If I clear it, it takes a couple days to come back on.

mawsea
01-05-2014, 01:49 AM
I can't really tell you if you should keep driving your van or not but I will tell you my experience. I was having glow plug issues and completely disconnected them over a year ago and have started the van in temps as low as 16 deg. without issue. A year ago a Mercedes dealership told me I needed a new torque converter based on a slight shudder at around 1500 rpm. I have driven it over 20,000 miles since then without issue. I grilled Mercedes on why they thought I needed a new torque converter and they never could give me a logical or reasonable answer. I have put over 200,000 miles with the same 'ol shudder so who knows. Maybe I do need a new torque converter but in the mean time it drives fine.