PDA

View Full Version : Stalling Issues


ttilghman
11-04-2013, 02:21 PM
2004 / 2500

-vehicle stalls under heavy load (acceleration from standing stop/hills) at around 1300 rpm
-will restart
-generic fuel pressure regulator circuit open code generated
-will rev freely at idle
-will rev past 1300rpm in reverse under load
-will rev past 1300rpm if not under heavy load
-revs seem to be limited at highway speed (max 65mph)

any ideas?

thanks-
timothy

autostaretx
11-04-2013, 04:42 PM
1st vote: dirty fuel filter
2nd vote: leaky turbo resonator (look for baked-on oil on hoses below it)

If it's truly an "engine flat-out quits" stall, then forget #2.
If it's merely "engine has no power (but keeps running)", suspect #2.

--dick

Dingo
11-04-2013, 05:49 PM
Change the fuel filter & make sure you have NO air leaks into the filter head

ttilghman
11-04-2013, 06:00 PM
thanks guys. had already changed the fuel filter. there is some oil on hoses beneath resonator but it is truly and "engine flat out quits" scenario. will only stall in 1st gear between 1500 and maybe 2000rpm with heavy load. will run up in rpm in all other gears once past 1st gear, but doesn't have usual power. i'll look at resonator. thanks

pacman_34
11-05-2013, 01:39 AM
I have a van that would shut off when accellerated hard from stop. Turned out that the van was overfilled with oil. Drained out about a quart and never had the stalling problem again. Very uncommon scenario but worth a check.

ttilghman
11-05-2013, 08:41 PM
oil is OK, turbo resonator replaced. no luck yet.

?????

Dingo
11-05-2013, 08:59 PM
Well then it is either a dying lift pump or you have junk fouling the lift pipe from the tank to the pump .

One thing i would check , if it is an electric pump , you have a good earth connection