PDA

View Full Version : Mercedes Sprinter 310d Well Down On Power


mbwoy84
04-25-2013, 10:25 AM
Hi,

I've researched this on the net a little already and found quite a bit, although no definitive answers, so apologies if I'm covering old ground here.

I have a 1999 Mercedes Sprinter 310d (2.9 Turbo Diesel) Recovery Truck (previously a box van). I've owned the truck just coming up to 12 months now and it's always been down on power since I've owned it.

I've just given it a fresh service and flushed out every fluid and changed literally everything. I took it on a long run to collect a car on Tuesday and I noticed a substantial difference for most of the journey. It still didn't have the power it should, but it was getting there. It was flying up hills in fifth gear that I would previously have been down to third to climb. But towards the end of the journey it was struggling again, probably worse than ever.

Generally speaking, top speed is around 60mph, might do 70mph empty eventually if pushed.

I know there's a slight blow from the exhaust, but that got worse towards the end of Tuesday's trip and now makes a noticable roar which doesn't help. Also the exhaust is missing its rear box. As the original exhaust would foul the recovery bed, someone has just stopped it short of the rear section. I need to get something new made up to make it exit at the side as the truck is very loud on the road. I also want to Dynamat the cab, but that's another matter.

Any ideas what could be causing the lack of power? There is some white smoke, with a strong diesel smell at cold/idle.

The truck has covered 243,000 miles and not much isn't original. Could it be a tired turbo? Issue with the intercooler? Any pipework I should be checking?

I've found a place which can ultrasonically clean fuel injectors and guarantee they can get any functioning injector back to flowing as good as new and fit all new seals etc. They say they can even bring dead injectors back to life in some cases. So I think that could be worth doing. And changing the MAP sensor.

Anything else I should be checking?

I know a place that claims to be able to re-map the 310d to 140bhp, which I would love, but need to make sure the truck is healthy and running properly first, which it is not. Even if it is always 100% reliable and still gets to its destination without fuss (*touch wood*), just far slower than it should do!

Cheers

Mike

Eric Experience
04-25-2013, 12:34 PM
Mike.
Does your unit have a vacuum operated boost control. If so check you vacuum by placing a "tee" in the boost control hose. Often in that model there is not enough vacuum to drive the turbo control. a common fault is the hose to the heater vent control can split and fall of also the hoses going to the back of the head lights can fall of or split, the third place to look is the head light control on the dash, make shore it is not leaking around the hoses. Eric.

mbwoy84
04-25-2013, 03:08 PM
Thanks for that, I'll have a look.