PDA

View Full Version : P2007 Intake Manifold Runner Control Stuck Closed Bank 2


SkyDan
04-10-2013, 05:15 PM
Would like to know what causes this problem and ways to repair it besides taking it to stealers. The engine seems to be is running fine, but the error MIL is displayed and I need to pass state inspection very soooon. Please help.

Vander
04-15-2013, 08:09 PM
Is the code an active code? Can It be erased and Come back on? Sometimes these are momentary issues, however if comes on all the time then it may be a serious problem. The Intake runner flaps are in the intake manifolds and can only be replaced by replacing the Intake manifolds, they usually become stuck by a large amount of gunk build up, from long Idling all time. Even more so an issue sense your sprinter is before the addition of adblue.

http://sprinter-source.com/forum/showthread.php?t=11031 <<< the pictures in this thread shows a good example of gunk build up of a sprinter that idles a lot. In order to replaces these it requires 10+ hours of work, much longer if you have never done it before and don't have accese to r&r procedures, it includes taking off the turbo. If the code is a constant issue then I would have a dealer check it over to make sure.

jabiscarner
04-18-2013, 01:06 AM
done about 20 of these and have them down to 7 1/2 hrs even made my own port cleaning tool

SkyDan
05-01-2013, 01:46 AM
Thanks guys, been very busy and away. Yeah:frown:the code can be erased and goes away sometimes but usually it's on. I also have power loss, dunno if it's related to the code.:idunno:

Vander
05-03-2013, 07:57 PM
done about 20 of these and have them down to 7 1/2 hrs even made my own port cleaning tool

Nice! Much faster than me!

If you have a loss of power then they are probably clogged with build up. Those Runners control air flow. Only way to know is to remove the manifolds yourself or take the van to the Dealership and perform tests with the Computer. Sorry to hear this, it's not cheap.
Long idle times and Wrong oil are the 2 biggest causes of this.

davidskick
05-25-2013, 05:03 PM
I get the exact same on mine... I have a scanner. I can erase the code.. it goes away.. and it may come back in a month, a week or 5 months.. I also get P040B Exhaust Gas Recirculation Sensor A Circuit Code.. No clue what that means.. The 2 do NOT pop up together.. they come and go erratically. I have no issues with power or behaviour. The van acts normal all the time..
I also have no clue about what you are talking about when you talk about "runners".. sorry.. Where are those and what are they meant to do? It sounds like runners are sort of "vents".. or air ducts.. and are part of (?).. turbo? Please educate me.. THANKS!

Jason5323
04-13-2014, 11:20 PM
If you could give us some direction on how to remove the intake manifold and clean the ports, it would be very helpful

ryanita
04-14-2014, 01:18 AM
Hey guys, i bought my car with the check engine light on and it had the code p2006, p2007, and so.etimes the p2404. I have already found 2 vacuum leaks that it had and after checking about 6 times, i can not find any more. I have cleared the codes but they keep coming up. Is it possible that my vacuum pump went out? Because if i turn my car on there is no sucktion in any like. The car's idle is normal and it runs great but i still have those codes. Any suggestions?

showkey
04-14-2014, 01:45 AM
If you could give us some direction on how to remove the intake manifold and clean the ports, it would be very helpful

Shop manual shows the basics............it has a book time of 12 hours so instructions here would not be practical...............other than both intake manifolds and all the stuff above them has to be removed.............and the EGR ports or runners has to be cleaned and it would be a good idea to clean the EGR cooler and all the "plumbing" connections.

Turbone
09-11-2016, 04:23 PM
Resurrecting a dead thread here.......Has anyone tried using a chemical to clean the runners? Seafoam or the like?
I've replaced a turbo on one of our Sprinters at work and its something I wouldnt care to do again, just to fix this problem

Oh, look what I found.

http://sprinter-source.com/forum/showpost.php?p=370246&postcount=2

Should maybe drink a few more cups of coffee before searching lol

SprinterHelp
09-14-2016, 01:37 AM
[QUOTE=ryanita;297364]Hey guys, i bought my car with the check engine light on and it had the code p2006, p2007, and so.etimes the p2404. I have already found 2 vacuum leaks that it had and after checking about 6 times, i can not find any more. I have cleared the codes but they keep coming up. Is it possible that my vacuum pump went out? Because if i turn my car on there is no sucktion in any like. The car's idle is normal and it runs great but i still have those codes. Any suggestions?[/QUOT

Where were your vacum leaks?

If a rail is sticking, that will throw off LOD BOOST readings etc.??????
Trying to track down charge air leak went thru egr seals, new egr valve, cleaned egr cooler, serviced clean DPF, new O ring inturbo output.

Now only 0299, can find no leak, boost jumpts from .8 to dropping to .5 to .1 ...0 or .2

My voltage is swaying between 13.7 to 14, ocassionally dropping to 13. With air cond or no accessories.

Now got 2007 code which I thing was tjrowing my codes when reading if I have solved my leak with new gaskets.
Stuck rail and voltage probably giving LHM.... man I dont know because half a dozen things can cause just one code or many.

Spraying 1/2 seafom and diesel in the intake and let it set to loosen crud.
This happened about 8 months ago and replaced swirl valve.

I can switch a swirl actuator out now record time once turning the actuator screws... 20 to get out,ten to seat clips and ten to retighten actuator screws.... that in minutes.
I also got a throttle code momentarily before the 2007...forgot code, has not come back.

At idle after a little douse of concoction I get .4 boost minimum at 17 lod, if i drive it either works well for a few blocks then idle drops to .1 or 0 and LOD just to maintain 30 mph , high 60 middle 70 on flats and fuel drops tp 13mpg.

When it rains it pours, thank our fine government for saving our air, charging us trillions in taxes just to turn our trucks into DPF garbage bins costing us thousands and displacing the pollution liability on the citizens. Hazardous waste bins undrr our truck...FACT.
After three sprinters i think without question the 2007 and up are a chrome garbage can. Like Oldmobile trashing the diesel engine in the past Dodge has failed miserably in allowing the destruction of the engine by accepting under engineered pollution system be put on these truck. Dodge will no longer do anything for their Sprinters except order parts.... what a joke.

I guess I better check the electrical while the varnish in my inferior fuel melts. Maybe then I can get some honest values out of the computer.

SSMaui
09-15-2016, 11:50 PM
I can switch a swirl actuator out now record time once turning the actuator screws... 20 to get out,ten to seat clips and ten to retighten actuator screws.... that in minutes.

I think I had called BS on this in another post. :lol: (All in fun)

So serious: How do you remove the E10 bolt that is under the wiring harness that sits under the turbo inlet that holds the EKAS into place without removing the harness or turbo?

What are the actuator screws?

SprinterHelp
09-17-2016, 11:40 PM
1 fuel line needs a little motivation to move foreward just a tad after rubber supports are removed. Fuel line does not need be moved back after switch and can be reattached.

On 07 08 and avion 08 the harness is not in the way, all e10s are easily removable but need to take out outlet tube and bracket which comprise of a few of those pesky e10s.

Just went 1500 miles. Had about 6 lhms on the way which is fine considering I could not get a mile before.
First day 1 lhm after parking. Needs ungoo juice every stop for know and multiple soaks. I would not be suprised if intake manifold can hold enough waste products to foul dpf if all sluffed off into system at once.

Changing out last two ujoints tomorrow. One is red powdered toast...these too started to fail after famous iowa rain. Went thru another record rain in North Dakota.... at least no hail.

SSMaui
09-19-2016, 06:00 PM
Well, I'll be damned. :) I have two 2008s and the harness is there (or so I thought...I'll have to check again!). Where is it on yours?

manwithgun
09-20-2016, 02:48 AM
Well, I'll be damned. :) I have two 2008s and the harness is there (or so I thought...I'll have to check again!). Where is it on yours?

Not sure if this helps but here are a couple of pics from my archives of a 2007...


http://i67.tinypic.com/1pzc7d.jpg

http://i66.tinypic.com/301qdt1.jpg