PDA

View Full Version : Loud whining noise from transmission


qahrens
06-14-2012, 01:28 AM
This is a 2004 Dodge Sprinter with 206K miles. I bought it at 176K miles and the original owner replaced the transmission with one from a junk yard with about 98K miles. So I'm assuming this transmission has about 130K miles on it.

Anyway, when I put it in gear, either forward or reverse, it makes a loud whining noise which goes away under power at about 5-10 mph. The noise only shows up after about 15 minutes of driving. It shifts fine. It used to have mild RSN, but that is now gone (not sure if related).

I've taken it to Freightliner twice now to get it fixed. First time, they said it was a broken transmission mount and replaced the mount. The tech didn't test drive it long enough for the noise to show up. Second time they dropped the pan, found metal and clutch material in the pan, and are recommending a new transmission - quote at $5800.

Does anyone have any thoughts on what this could be and/or some diagnostics to help find out?

Thanks in advance,
Quinn

NelsonSprinter
06-14-2012, 01:41 AM
If the transmission is damaged or needing replacement, there usually will be transmission error codes in the computer. Did they say what the numbers were or what they indicate?
I'm suggesting you see a Mercedes dealer with a proper Scan tool to see the codes, if they are not an approved Sprinter dealer. If they are, they can print the codes out from the scan. A close member with a DAD could scan the computer. Search for "Type2teach" to find the link to members with scanners willing to help.

Could it just be a worn center hangar bearing near the transmission, connecting the driveline to the transmission?

1cylshort
06-14-2012, 04:06 PM
If they found just the regular fine slime, no big deal.

But if they found grindings / chunky stuff, tranny rebuild time.

$5800 seems a bit rich, but that's probably normal for a dealership truck shop.

You might want to consult with DoktorA or WayneRodd or haul it to them, if they are even fairly close to you.

qahrens
06-15-2012, 02:15 PM
I'm against a bit of a time crunch on this one, so I decided to go ahead and put in another transmission, but not before questioning them on the price. Some of the techs let it slip that they had put in Silverstar transmissions before in some of the fleets that they service. There were 2 problems I had with the dealer's quoted new transmission: 1) the price ($5800) and 2) they were only offering 24 month 24K mile warranty on the new one. The Silverstar rebuild is $2195 (with core) and offers a 36 month 100K mile warranty. When I questioned the dealer on the difference, they said, "let me check with our parts department" ... they CAN get a Silverstar transmission, and it will be $1800 cheaper. My actual cost on the rebuilt transmission install, given I had another issue with the belt, will be about $3600. I figure that's doable.

I live about an hour away from the dealer so I had to ask the service manager over the phone about the metal and clutch material in the transmission. He said that even though the transmission was shifting normally, given the large amount of material in the pan (he saw it himself), that he was very worried about putting us back on the road with the original transmission.

I checked with Doctor A to see if he had any more of the DAD units available but no luck. So, given my time crunch, I decided to go ahead with the Silverstar install by the dealer.
Quinn