PDA

View Full Version : Help! Power Steering problems while travelling


Tuono
09-29-2007, 01:54 AM
Hi all! I'm hoping someone here can offer some advice on a problem that I'm experiencing on the road while travelling.

My power steering went out today. The first thing that I noticed was a new noise from the engine compartment after starting the van. I think the steering was mostly ok at this point, but after a few miles, the power steering was gone. 10 mins later, arriving at my destination, I noticed fluid leaking from the driver's side of the engine compartment, mostly from a hose fitting (or thereabouts) under what I think is the power steering unit. The black reservoir with the black cap just under the (+) battery jumping connection is not registering any fluid on the dipstick (can someone confirm that this is the steering pump?)

I do not see any belts that are obviously missing, but I will look more closely right now.

I've been travelling in BC Canada and was planning to drive home to Oregon tomorrow. The closest Sprinter service center does not have a tech until Monday, and even then I might not be seen right away... :thumbdown:

My best idea is to add fluid, check if the power steering works (at all) or not and go from there, possibly limping home if it looks possible after trying the fluid.

Any thoughts or ideas?
Thanks in advance...

Altered Sprinter
09-29-2007, 02:02 AM
Identify the leak source and fix it or patch up refill the fluid and be careful driving ,if the power steering continues to fail and it becomes obvious it is unsafe to drive, get it towed.
Richard

Tuono
09-29-2007, 02:13 AM
Identify the leak source and fix it or patch up refill the fluid and be careful driving ,if the power steering continues to fail and it becomes obvious it is unsafe to drive, get it towed.
Richard

Well, source identified. The hose fitting into the pump body was torqued to about 1 Nm (if that much). I don't want to over do it, but I can safely torque this down quite a bit more. When I get some fluid I'll see what happens from there.

Thanks.

Tuono
09-30-2007, 12:07 AM
Ok, on the road now. Everything is good after tightening the hose and adding fluid. Thanks!